Qnap [ XBOXdrv ][ 8.8.2 ] [ HDStation4 ] Bring compatilibty with joystick over HDStation

QoolBox

Représentant QNAP
2 Janvier 2014
10 579
166
153
50
France
www.qnap.com
controller.jpg


Source : http://pingus.seul.org/~grumbel/xboxdrv/

Download :

HDStation : https://www.qnapclub.eu/fr/qpkg/368

Note :

unzip , install over HDStation, enjoy

services are launch automatically , logs output are published in /share/Public

About :

Xboxdrv is a Xbox/Xbox360 gamepad driver for Linux that works in userspace. It is an alternative to the xpad kernel driver and has support for Xbox1 gamepads, Xbox360 USB gamepads and Xbox360 wireless gamepads. The Xbox360 guitar and some Xbox1 dancemats might work too. The Xbox 360 racing wheel is not supported, but shouldn't be to hard to add if somebody is interested.

Some basic support for the Xbox360 Chatpad on USB controller is provided, Chatpad on wireless ones is not supported. The headset is not supported, but you can dump raw data from it.

This driver is only of interest if the xpad kernel driver doesn't work for you or if you want more configurabity. If the xpad kernel driver works for you there is no need to try this driver.

Test

Because i am unable to test it, a friend used Caprice32 (amstrad emulator) + Gryzor game + Xbox 360 paddle and confirm me it is working
 
Hi
I used xboxdrv on my QNAP ts 251+ with mame on HDSTATION 3.2.6 et that was great. With the qnap QTS update to 4.4.1 hdstation has update to 4.0.3.
Is there a way to get it work on hdstation >4.0.0?? The latest version (8.8.1) requires hdstation >3.0.0 and <4.0.0.
Any update coming soon??

Thank you
 
Hi,
Do you have contact with the team?? Are they working on it??
I have mail-bounce with the emails on their page!!
 
hi,
thank you for the integration.

It's a little bit buggy: I'm on hd_station 4.0.3 (last beta of QTS) with kodi 18.3 and retroarch 1.7.5. This version of xboxdrv works but there's something making everything freeze (like if my memory RAM is overflow: 4go) so i loose all controls (need to reboot hd_station).
I tried this :
1-uninstalling everything than installing kodi18.3 + xboxdrv (freeze)
2-Uninstall everything than Installing retroarch+xboxdrv (freeze, and after reboot my xbox controller doesn't work: xboxdrv don't recognise my controller).

Any leads?
Thank you.

Ps: sorry for my bad english :oops:
 
Hi

I've installed this (thanks by the way!) and retroarch is showing that it's detected the wireless USB adapter (4 ports too, excellent). However the gamepads just won't pair with the adapter.
Can anyone suggest any steps to fix this please? (I'm using a microsoft issue adapter - actually tried two - N and G)

Any help would be so very much appreciated. I'm so close!!
 
Merci pour la reponse.

I've found out what it 'might' be...I'm using an official XBOX 360 wireless adapter - apparently these aren't in any way supported off the Xbox (not even in Windows). I've ordered a Qumox version which has a pairing button on the adapter (the standard ones do not).

I'll report back to this thread if it works (as I'm using the XboxDRV build from here).

Thanks

:-D :-D :-D :-D
 
I'm currently stuck, I installed retroarch and Xboxdrv 882 on my TS251 qnap, my xbox360 PC usb controller is connected (the dial has 1/4 circle green light showing meaning it should be working) but it doesn't work. Seems to me like the wired USB pc controller is not compatible with the driver?

When retroarch boots i see a message "100% Xbox wireless receiver (1118/1817) not configured". Once again, i am using the PC xbox360 controller and not the controllers that came with an xbox console.

Anyone has a clue why and what to do to get this working?

Thank you,
 
I am not sure... but here i dont have any Joystick for test

but some people told me it works when joystick is wired.. not sure for retroarch, but seems behavior is different with different applications

they mainly tried with a PS3 and Xbox (if i remember on official Qnap forum)...

I just have a Nintendo Switch.. i already saw some sources to be able to handle joycon on Linux.. (i could try only this ones)
if only Qnap can implement it natively (may be make a ticket for asking a feature request on HDStation)
 
I know that the xbox 360 USB PC controller is different than an xbox 360 usb controller. I believe it uses different drivers or something because several years ago i tried using my console controllers on my computer and it did not work, i had to go to the store and purchase specific "xbox 360 PC usb controller". There might have been a tweak to make it work, but once i accepted my faith and bought the PC 360 controller, it was plug and play.

Without Xboxdrv, the green circle flashes continuously searching for a connexion, meaning the QNAP doesn't recognize it at all. Once i launch the Xboxdrv, the remote gets recognized and controller 1 lights up. If i plug a second one, it goes on the 2nd quarter circle light. everything behaves correctly, but just won't work.

This tells me that the xboxdrv does contain something that makes it work, but it just doesn't do the whole trick. could it be that the driver only works for wireless controller linked to the QNAP through the xbox360 usb receiver? That would also explain the "100% Xbox wireless receiver (1118/1817) not configured" i get everytime.

If so, tweaking the thing to make the system work with the wireless controller would be a bit more complex than for my application, who can help me see if there is a couple of lines of code to throw in Xboxdrv to make it recognize my type of controller?

Thank you,
 
did you try other QPKG .. Ludo , dolphin , Mame ... ?

may be related to RetroArch ... i have no clue

the xboxdrv is installed from Ubuntu PPA (if i remember)

may be you can check under HDStation envrionment, if have enought knwoloedge to connect into HDStation in SSh

/etc/init.d/HD_Station.sh attach

once done you are under an Ubuntu 1804
 
No i did not try any other qpkg. and from what I saw Xboxdrv would allow me to use my controller in HDStation and not Retroarch alone, and it doesn't work in HDstation (meaning browse through the files and select Retroarch app), so it looks like its Xboxdrv related.

I'm more familiar with C/C#, VB, java, I don't have any experience in Ubuntu whatsoever.

If anyone has some insight or can look it up in xboxdrv, i'm sure that the answers are already there and pretty easy to put together. Otherwise, I guess i'll have to either wait for an update or to purchase xbox 360 wireless controllers and a usb receiver.

Thanks,
 
i will build it natively from HDStation... with HDStation libs (full version)

actual version is an AppImage..; so may be some libs can mess up....
 
found also an old ubuntu post... https://doc.ubuntu-fr.org/paddle_x360_for_windows_sur_ubuntu

The controller is detected but does not work.
If it vibrates when you plug it in, is detected by the lsusb control but the ignition button flashes without stabilizing, try updating the xpad driver.

-Unplug the controller

-Install git

-Run the following commands

sudo git clone https://github.com/paroj/xpad.git /usr/src/xpad-0.4
sudo dkms install -m xpad -v 0.4
sudo modprobe -r xpad
sudo modprobe xpad

so may be build xpad driver from Kernel (GPL code) can make it work
 
Dans mon cas la manette ne vibre pas quand je la connecte, mais la lumière se stabilise. Je peux faire des essais si tu veux m'envoyer différentes versions avant de la publier officiellement.