Synology [Tuto] Installation de Speedtest-Tracker en Docker sur un NAS Synology ( docker-compose )

Totoons

Nouveau membre
Salut,
Je ne suis pas sur de moi mais je pense que le speedtest fonctionne sur le meme principe que le site, il va donc choisir de lui meme le serveur en fonction du ping ( donc souvent le plus pres de toi géographiquement parlant ).
Dans la description du conteneur, je n'ai pas vu d'options permettant de forcer cela sur un autre serveur.
Salut,

Merci pour ton retour et pour tes tuto. ;)
 

Feneck91

Maître Jedi
Je l'ai supprimé du NAS et refait sur mon mini-PC qui est le seul à posséder une carte réseau 2.5 GBits.
At là j'ai du débit !
Seul hic, impossible de faire un Clear all speedtests => Delete All, il m'affiche un message "somethink went wrong". Je ne comprend pas bien pourquoi.
 

EVOTk

Modérateur
Membre du personnel
Seul hic, impossible de faire un Clear all speedtests => Delete All, il m'affiche un message "somethink went wrong". Je ne comprend pas bien pourquoi.
Regarde les logs du conteneur, peut etre un probleme de droits sur les fichiers ? Vérifier les PUID/GUID sur tes fichiers, et ceux déclarer dans la configuration du conteneur
 

Feneck91

Maître Jedi
T'es au taquet. J'ai rien mis sur le PUID / GUID.
sudo id root
>> uid=0(root) gid=0(root) groupes=0(root)
 

Feneck91

Maître Jedi
C'est une Debian.
Je peux administrer mes container avec portainer. Bon là, j'ai maintenant : 502 Bad Gateway
 

EVOTk

Modérateur
Membre du personnel
As tu veérifier a qui apartienne tes fichier sur ta debian ?

ls -al dans le repertoire
 

Feneck91

Maître Jedi
J'avais le répertoire racine qui était à apt (bizarre). J'ai tout supprimé et recommencé.
Là je me connecte dessus.
Le Delete All déconne toujours autant.
Et le 0,30 * * * * ne fonctionne pas, il faut mettre 0/30 * * * * pour le cron ce qui est bizarre... C'est bien buggué comme application.
Et là le 0,30 * * * * vient de fonctionner alors que ça n'a pas fonctionné de toute la journée.
 

bliz

Nouveau membre
bonjour,
Je n'ai pas pu avoir le lien de la modification du fichier EVOTk dans le fil car le fichier est marqué expiré c'est marqué expiré

Dans les faits, j'ai une erreur 500 et le terminal indique ceci (si ça peut aider)

1655214550641.png
 

EVOTk

Modérateur
Membre du personnel
Voici un fichier "speedtest"* a télécharger ici, celui ci est a placer ( conteneur a l'arret ) dans le dossier /config/www/app/Bin du montage de ton conteneur.

Edit : C'est effectivement un probleme avec le conteneur , la modif a etait proposé pour la MAJ du conteneur, mais elle n'a pas encore était appliqué :https://github.com/henrywhitaker3/S...mits/4e9fbe6742583d81f012dbdf25b46ee22a01c5b5
Ensuite redémarre le conteneur et dit moi se qu'il en est :)

Le nom du fichier doit etre uniquement speedtest, sans extension, ni rien.

Voici un nouveau lien vers le fichier en question https://www.swisstransfer.com/d/9b35b917-1aac-4215-9a11-38990c569c17

Dans les faits, j'ai une erreur 500 et le terminal indique ceci (si ça peut aider)

Pourrai tu lister/faire un screen des dossiers/fichiers présents dans /config/www ?
 

EVOTk

Modérateur
Membre du personnel
Salut,
Je ne vois pas d'ou pourrai venir ton soucis.
As tu essayé de repartir sur un installation "clean" via un dossier de config vierge ?
 

bliz

Nouveau membre
je vais recommencer, merci
Mais pour l'instant, j'ai reçu mon nouveau ge76, et je suis un peu pris
Petite question : je suppose que je peut le mettre dans le dossier docker pour éviter de créer des dossiers partagés ?
 
Haut Bas