Forum des NAS

Tous les fabricants de NAS réunis sur un forum unique : Asustor, Qnap, Synology...

BitTorrent Sync, KODI, IPKG, NZBGet, pyLoad...

Modérateur : QoolBox

par giopas
#23159
Tu pourrais refaire KeyBox de la même manière stp? :)

De cette sorte je pourrais garder ngrok pour encore d'autres service... :)

ps avec un virtual-host mnt j'ai un mail.xxx.com pour me connecter à la webmail :)
#24693
Salut giopas,

Pourrais-tu me dire s'il est possible de faire un reverse proxy pour Rainloop comme tu l'as expliqué pour plexpy sur ce post : http://www.forum-nas.fr/viewtopic.php?f ... =10#p23202

Actuellement pour aller sur Rainloop je dois me rendre sur l'adresse https://nas.domaine.fr:8081/RainLoop/
Hors j'aimerai accéder à Rainloop par l'adresse : https://webmail.domaine.fr

Merci ;)
#24696
Salut Tosh,

en HTTP c'est très simple:

1. sur le site de ton domain provider éditer le DNS avec un CNAME qui renvoit à xxx.myqnapcloud.com. (rappelle-toi d'ajouter le "." à la fin!) par exemple pour avoir webmail.domaine.fr

2a. ouvrir une session ssh sur ton NAS et éditer le fichier httpd-vhosts-user.conf:

Code : Tout sélectionner
[~] # vi /etc/config/apache/extra/httpd-vhosts-user.conf
3a.

rajouter le code suivant (et sauvegarder la modif):

Code : Tout sélectionner
### WebMail - RainLoop
<VirtualHost *:80>
        ServerName webmail.domaine.fr
        DocumentRoot "/share/Web/RainLoop"
</VirtualHost>
4.

rédémarrer apache avec:

Code : Tout sélectionner
[~] # /etc/init.d/Qthttpd.sh restart

Si par contre tu veux essayer d'utiliser HTTPS théoriquement tu devrais suivre la procédure suivante (mis à part le point 1. et 4. qui sont les mêmes):

2b. ouvrir une session ssh sur ton NAS et éditer le fichier httpd-ssl-vhosts-user.conf:

Code : Tout sélectionner
[~] # vi /etc/config/apache/extra/httpd-ssl-vhosts-user.conf
3b.

rajouter le code suivant (et sauvegarder la modif):

Code : Tout sélectionner
### WebMail - RainLoop
<VirtualHost *:8081>
        ServerName webmail.domaine.fr
        DocumentRoot "/share/Web/RainLoop"
</VirtualHost>

Toutefois en faisant comme cela tu as le problème que tu sera obligé de rejoindre le service en spécifiant la porte 8081, car la porte standard 443 est normalement déjà utilisée par QTS.

Pour fixer le problème tu pourrais alors (3ème option) créer un virtual host en http lié à webmail.domaine.fr qui renvoit directement à RainLoop en HTTPS avec un fichier index.php.

Je n'ai jamais essayé cela mais on pourrait essayer un truc du genre:

a) ouvrir une session ssh sur ton NAS et créer le folder Mail:

Code : Tout sélectionner
[~] # mkdir /share/Web/Mail
b)

toujours en ssh, éditer le fichier httpd-vhosts-user.conf:

Code : Tout sélectionner
[~] # vi /etc/config/apache/extra/httpd-vhosts-user.conf
c)

rajouter le code suivant (et sauvegarder la modif):

Code : Tout sélectionner
### WebMail - RainLoop
<VirtualHost *:80>
        ServerName webmail.domaine.fr
        DocumentRoot "/share/Web/Mail"
</VirtualHost>
d)

rédémarrer apache avec:

Code : Tout sélectionner
[~] # /etc/init.d/Qthttpd.sh restart
e)

toujours en ssh, créer le fichier index.php dans le folder Mail:

Code : Tout sélectionner
[~] # vi /share/Web/Mail/index.php
f)

rajouter dans ce fichier le code suivant (et sauvegarder la modif):

Code : Tout sélectionner
<?
header('Location: https://nas.domaine.fr:8081/RainLoop/');                         
?>

J'espère que cela peut t'aider. Stp poste la solution et chaque changement que tu trouves nécessaire, ainsi qu'on puisse tous apprendre! ;)

giopas

ps: moi perso je ne peux pas utiliser la 2ème et la 3ème solution car depuis mon travail j'ai toutes les portes bloquées sauf la 80 et la 443. Donc je suis obligé de me connecter à RainLoop en HTTP.

Dernière modification par giopas le 10 mars 2016 12:13, modifié 1 fois.
#24723
J'ai donc procédé en suivant la troisième solution, afin de ne pas avoir à indiquer le numéro de port.
J'ai donc créé un virtual-host et j'ai placé une redirection dans le fichier index

Mais ça n'a pas l'air de fonctionner, je suis à chaque fois redirigé vers la page de connexion de QTS...
#24729
La solution 2 c'est pareil, je retombe sur la page d'identification de QTS et la solution 1 je ne l'ai pas testé car je tiens absolument à avoir le https
On va attendre une réponse à ton post.

Par contre, il me semble ce matin lorsque j'ai configuré en suivant ta troisième solution, j'ai créé un vhost pour Rainloop et un autre pour PasswordManager tout deux en https.
Pour le webmail ça n'a jamais fonctionné, par contre pour PasswordManager j'ai réussi tout de suite après a l'atteindre avec l'url : passman.domaine.fr

Je me suis donc acharné à faire en sorte que le vhost webmail fonctionne de la sorte également... En vain...

Après cela j'ai retenté passman.domaine.fr et la ça ne fonctionne plus... J'arrive aussi sur QTS...

Il est vrai que je me suis levé tôt ce matin mais je ne pense pas avoir rêvé, ça a marché quelques minutes...
#24731
Quelles portes tu utilises pour QTS? Est-ce que tu forces l'accès à QTS par HTTPS avec la porte 443?

La solution 1 marche sans doutes car je l'utilise moi même, la 3ème marche pour VHost sur la porte 80 et renvoie en HTTP, mais je ne suis pas encore arrivé à faire marcher cela en HTTPS... :(

EDIT: quelque link utile pour comprendre la situation:

http://forum.qnap.com/viewtopic.php?f=3 ... l&start=15
http://forum.qnap.com/viewtopic.php?f=3 ... 43#p497949
http://forum.qnap.com/viewtopic.php?f=32&t=111660
http://forum.qnap.com/viewtopic.php?f=32&t=72009
http://forum.qnap.com/viewtopic.php?f=3 ... 43#p461426

Si tu as quelque idée ou solution, écris la stp! :)

Salut, Je ne connait pas la gamme Seagate pour t'a[…]

Bonjour, je suis exactement dans la même […]

débit RN104

Bonjour, Au vu de la configuration du produit, je […]

Salut, Si tu install par exemple Nextcloud c'est p[…]

Site hébergé sur un serveur IKOULA

Ikoula