Qnap [ RainLoop ] [ 1.16.0.0 ] SIMPLE, MODERN & FAST WEB-BASED EMAIL CLIE5

QoolBox

Représentant QNAP
2 Janvier 2014
10 577
165
153
50
France
www.qnap.com
logo-256x256-tiny.png


Source : http://www.rainloop.net

Native (all NAS) : https://qnapclub.eu/fr/qpkg/274
Apache73 : https://www.qnapclub.eu/fr/qpkg/1139
Apache74 : https://www.qnapclub.eu/fr/qpkg/1140
Apache80 : https://www.qnapclub.eu/fr/qpkg/1141

Note :

To access admin panel, use URL of the following kind: http://NAS_IP/RainLoop/?admin
Default login is "admin", password is "12345".



FEATURES

Modern user interface.
Complete support of IMAP and SMTP protocols including SSL and STARTTLS.
Sieve scripts (Filters and vacation message).
Minimalistic resources requirements.
Direct access to mail server is used (mails are not stored locally on web server).
Allows for adding multiple accounts to primary one, simultaneous access to different accounts in different browser tabs is supported. Additional identities.
Administrative panel for configuring main options.
Really simple installation and update (the product is updated from admin panel).
Integration with Facebook, Google, Twitter and Dropbox.
Managing folders list.
Simple look'n'feel customization.
Configurable multi-level caching system.
Extending functionality with plugins installed through admin panel.
Perfect rendering of complex HTML mails.
Drag'n'drop for mails and attachments.
Keyboard shortcuts support.
Autocompletion of e-mail addresses.
 
Je prends !

Merci beaucoup, très sympa.

Les fiches contact sont trop minimalistes mais j'ai cru comprendre que l'équipe RainLoop proposera mieux prochainement.
 
Je connaissais un peu Rainloop, intéressant de pouvoir le tester sure NAS.

Sent from my GT-N8000 using Tapatalk
 
Est-ce qu'il serait possible de l'utiliser pour accéder à gmail? Est-ce que dans ce cas il faudrait tjrs utiliser une connection SSL?

Sent from my A0001 using Tapatalk
 
Mon problème serait comme d'hab de devoir uniquement utiliser la porte 80 avec un reverse proxy en http...

Sent from my A0001 using Tapatalk
 
Merci, j'ai configuré gmail, ainsi je peux lire/écrire les nouveaux émails privés même derrière un corporate firewall ;-)
 
Tu pourrais refaire KeyBox de la même manière stp? :)

De cette sorte je pourrais garder ngrok pour encore d'autres service... :)

ps avec un virtual-host mnt j'ai un mail.xxx.com pour me connecter à la webmail :)
 
Salut giopas,

Pourrais-tu me dire s'il est possible de faire un reverse proxy pour Rainloop comme tu l'as expliqué pour plexpy sur ce post : http://www.forum-nas.fr/viewtopic.php?f=21&t=3503&start=10#p23202

Actuellement pour aller sur Rainloop je dois me rendre sur l'adresse https://nas.domaine.fr:8081/RainLoop/
Hors j'aimerai accéder à Rainloop par l'adresse : https://webmail.domaine.fr

Merci ;)
 
Salut Tosh,

en HTTP c'est très simple:

1. sur le site de ton domain provider éditer le DNS avec un CNAME qui renvoit à xxx.myqnapcloud.com. (rappelle-toi d'ajouter le "." à la fin!) par exemple pour avoir webmail.domaine.fr

2a. ouvrir une session ssh sur ton NAS et éditer le fichier httpd-vhosts-user.conf:

Code:
[~] # vi /etc/config/apache/extra/httpd-vhosts-user.conf
3a. rajouter le code suivant (et sauvegarder la modif):

Code:
### WebMail - RainLoop
<VirtualHost *:80>
        ServerName webmail.domaine.fr
        DocumentRoot "/share/Web/RainLoop"
</VirtualHost>
4. rédémarrer apache avec:

Code:
[~] # /etc/init.d/Qthttpd.sh restart
Si par contre tu veux essayer d'utiliser HTTPS théoriquement tu devrais suivre la procédure suivante (mis à part le point 1. et 4. qui sont les mêmes):

2b. ouvrir une session ssh sur ton NAS et éditer le fichier httpd-ssl-vhosts-user.conf:

Code:
[~] # vi /etc/config/apache/extra/httpd-ssl-vhosts-user.conf
3b. rajouter le code suivant (et sauvegarder la modif):

Code:
### WebMail - RainLoop
<VirtualHost *:8081>
        ServerName webmail.domaine.fr
        DocumentRoot "/share/Web/RainLoop"
</VirtualHost>
Toutefois en faisant comme cela tu as le problème que tu sera obligé de rejoindre le service en spécifiant la porte 8081, car la porte standard 443 est normalement déjà utilisée par QTS.

Pour fixer le problème tu pourrais alors (3ème option) créer un virtual host en http lié à webmail.domaine.fr qui renvoit directement à RainLoop en HTTPS avec un fichier index.php.

Je n'ai jamais essayé cela mais on pourrait essayer un truc du genre:

a) ouvrir une session ssh sur ton NAS et créer le folder Mail:
Code:
[~] # mkdir /share/Web/Mail
b) toujours en ssh, éditer le fichier httpd-vhosts-user.conf:

Code:
[~] # vi /etc/config/apache/extra/httpd-vhosts-user.conf
c) rajouter le code suivant (et sauvegarder la modif):

Code:
### WebMail - RainLoop
<VirtualHost *:80>
        ServerName webmail.domaine.fr
        DocumentRoot "/share/Web/Mail"
</VirtualHost>
d) rédémarrer apache avec:

Code:
[~] # /etc/init.d/Qthttpd.sh restart
e) toujours en ssh, créer le fichier index.php dans le folder Mail:

Code:
[~] # vi /share/Web/Mail/index.php

f) rajouter dans ce fichier le code suivant (et sauvegarder la modif):

Code:
<?
header('Location: https://nas.domaine.fr:8081/RainLoop/');                         
?>
J'espère que cela peut t'aider. Stp poste la solution et chaque changement que tu trouves nécessaire, ainsi qu'on puisse tous apprendre! ;)

giopas

ps: moi perso je ne peux pas utiliser la 2ème et la 3ème solution car depuis mon travail j'ai toutes les portes bloquées sauf la 80 et la 443. Donc je suis obligé de me connecter à RainLoop en HTTP.
 
J'ai donc procédé en suivant la troisième solution, afin de ne pas avoir à indiquer le numéro de port.
J'ai donc créé un virtual-host et j'ai placé une redirection dans le fichier index

Mais ça n'a pas l'air de fonctionner, je suis à chaque fois redirigé vers la page de connexion de QTS...
 
Oui j'ai vu aussi ce problème ce matin (ici). Est-ce que les deux autres options marchent par contre?
 
La solution 2 c'est pareil, je retombe sur la page d'identification de QTS et la solution 1 je ne l'ai pas testé car je tiens absolument à avoir le https
On va attendre une réponse à ton post.

Par contre, il me semble ce matin lorsque j'ai configuré en suivant ta troisième solution, j'ai créé un vhost pour Rainloop et un autre pour PasswordManager tout deux en https.
Pour le webmail ça n'a jamais fonctionné, par contre pour PasswordManager j'ai réussi tout de suite après a l'atteindre avec l'url : passman.domaine.fr

Je me suis donc acharné à faire en sorte que le vhost webmail fonctionne de la sorte également... En vain...

Après cela j'ai retenté passman.domaine.fr et la ça ne fonctionne plus... J'arrive aussi sur QTS...

Il est vrai que je me suis levé tôt ce matin mais je ne pense pas avoir rêvé, ça a marché quelques minutes...
 
Quelles portes tu utilises pour QTS? Est-ce que tu forces l'accès à QTS par HTTPS avec la porte 443?

La solution 1 marche sans doutes car je l'utilise moi même, la 3ème marche pour VHost sur la porte 80 et renvoie en HTTP, mais je ne suis pas encore arrivé à faire marcher cela en HTTPS... :(

EDIT: quelque link utile pour comprendre la situation:

http://forum.qnap.com/viewtopic.php?f=32&t=64143&hilit=widgets+virtual&start=15
http://forum.qnap.com/viewtopic.php?f=32&t=88037&p=497949&hilit=virtual+host+443#p497949
http://forum.qnap.com/viewtopic.php?f=32&t=111660
http://forum.qnap.com/viewtopic.php?f=32&t=72009
http://forum.qnap.com/viewtopic.php?f=32&t=102618&p=461426&hilit=virtual+host+443#p461426

Si tu as quelque idée ou solution, écris la stp! :)