WOL depuis WAN

upsi

Apprenti
Bonjour.

Est-ce que quelqu'un a de l'expérience dans la mise sous tension du NAS depuis Internet ?

Sur mon TS1080, le WOL fonctionne uniquement depuis le réseau interne.

Le routeur Zyxel NBG4615 v2 permet le WOL depuis le WAN mais malgré l'ajout de la MAC address et la redirection du port 7, je ne peux l'allumer depuis l'extérieur.

J'ai essayé avec le Qmanager ainsi qu'une application tierce sur le smartphone, sans succès...

Merci.
 

sam

Padawan
upsi a dit:
(a)...Le routeur Zyxel NBG4615 v2 permet le WOL depuis le WAN...

(b) ... la redirection du port 7, ...
(b) : Je doute que cela se passe ainsi ... mais je peux me tromper...
Pour ma part , je me connecte depuis l'Internet sur l'interface de mon routeur sous DDWRT , et je clique sur l'option Wol de l'appareil auquel j'ai préalablement saisi l'adresse MAC. Ca reste du réseau local...
(a) : que dis exactement la notice de ce routeur sur ce mode de fonctionnement ?
 

upsi

Apprenti
@sam

En ce qui concerne le fonctionnement du wol, je te renvoie à l'article suivant:

http://fr.wikipedia.org/wiki/Wake-on-LAN

Et pour la configuration du Zyxel, ben il n'y a que le numéro du port et l'adresse Mac à mettre...

Par contre, je ne veux pas me connecter via l'interface du routeur (depuis le smartphone, pas pratique) mais bien utiliser un programme comme Qmanager, qui permet aussi le WOL et fonctionne en local.
 

upsi

Apprenti
Oui, et si je me connecte au routeur depuis l'extérieur, je peux mettre le Nas sous le tension.

Mais depuis le Qmanager, non: cela fonctionne en local, mais pas depuis le Wan.
 

sam

Padawan
upsi a dit:
Oui, et si je me connecte au routeur depuis l'extérieur, je peux mettre le Nas sous le tension.

Mais depuis le Qmanager, non: cela fonctionne en local, mais pas depuis le Wan.
Ok ...donc ca marche avec le Zyxel contrairement à ce que tu laissais entendre plus haut ...
Il s'agit donc un pb de routage du paquet magique en provenance d'internet... ce sur quoi j'émettais des doutes.... Il est fort probable que dans l'absolu ca marche si on en croit l'article wikipedia que tu cites... mais pour une raison que je ne connais pas , plusieurs personnes ont eu le même problème que toi et n'ont pas eu de solution . Existerait il en amont un filtrage du FAI ou un non routage de certains paquets UDP ? je n'en sais rien mais peut etre n'est-ce pas à exclure ....En tout cas je ne suis pas en mesure de t'aider sur ce point. D'autres ici pourront peut etre t'en dire plus ...
A titre personnel, de toute facon, je préfère ne pas ouvrir de ports quand je peux faire autrement , y compris le port 7 pour ne pas avoir un allumage intempestif accidentel .
 

Philero

Nouveau membre
Bonjour,

Je rebondis car j'ai le même souhait : pouvoir réveiller le NAS depuis Internet.

J'ai vu sur le site d'ASUSTOR que certains modèles sont Wake On LAN, d'autres sont Wake On Wan.
Le mien n'est que WOL (AS-204TE) donc je ne peux pas le réveiller depuis Internet.

Pour autant, je ne comprends pas non plus pourquoi une redirection vers le port 7 ou 9 de mon routeur vers mon NAS ne permet pas de le réveiller.
Je suis chez Free, j'ai activé le Proxy WOL sur la Freebox et sur le site free.fr/espace client.

Si quelqu'un comprend le blocage ou si quelqu'un a au contraire réussi à le mettre en place, je suis très intéressé.

Philippe
 

Philero

Nouveau membre
Bonjour,

Je me demandais :
Pour autant, je ne comprends pas non plus pourquoi une redirection vers le port 7 ou 9 de mon routeur vers mon NAS ne permet pas de le réveiller.

Je viens de trouver la réponse :
"Tout simplement parce que si votre ordinateur est éteint, il n'a pas d'adresse IP, et il est impossible de rediriger un port sur une IP qui n'existe pas sur le réseau local (LAN)."

Pas bête...

Je vous conseille cette page où j'ai trouvé la réponse : http://www.finalclap.com/tuto/wake-on-lan-internet-wan-79/

La Freebox Revolution "ruse" comme l'explique la solution 1 de l'article ci-dessus.
L'idée est de forcer le routeur à garder l'entrée de votre PC dans sa table ARP en définissant une entrée permanente (une entrée statique).

Cet article explique comment le faire : http://hjj.free.fr/FBV6/page165.html

J'avais bien activé les options, pour autant je n'avais pas réussi à réveiller mon NAS.
Je referai des tests maintenant que la problématique est plus claire.
 

Philero

Nouveau membre
sinon QuWakeup

Bonjour,

Merci pour l'info, je ne connaissais pas, c'est intéressant!
Pour mon petit usage de particulier, c'est un gros moyen :)

Je crois que certains ont fait l'équivalent avec un Raspberry Pi.

Pour moi, l'idéal serait que cela fonctionne avec la Freebox puisque :
- elle est censé le permettre
- c'est le seul appareil connecté que je souhaite voir allumé toute la journée

Philippe
 
Haut Bas