Synology Wake On Lan ne fonctionne pas bien sur DS413J

Trishul

Nouveau membre
Bonjour à tous,
Je vais avoir besoin de vos lumières, car je bute sur un problème de configuration d’un Syno DS413J.
Mon besoin est de pouvoir arrêter et de relancer le NAS automatiquement, respectivement lorsque le PC est arrêté en fin de journée et lorsque ce même PC est allumé le lendemain matin.
L’arrêt automatique se fait très bien grâce à un batch qui se déclenche à l’arrêt du système Windows, et dont voici le texte :
plink «ma-session-Putty» /sbin/shutdown -h -t 4 now

La relance automatique aussi, toujours grâce à un batch qui se déclenche au démarrage du système Windows et dont voici le texte :
c:\Users\Trishul\ssh\mc-wol 00:11:xx:xx:xx:xx

Et pour ceux que cela intéresse, cet outil : “mc-wol.exe” peut être trouvé à cette adresse : http://www.filecluster.com/downloads/WakeOnLAN.html

Le réveil du NAS se fait très bien tant qu’il n’est pas arrêté trop longtemps. Après quelques heures d’arrêt, cela ne fonctionne plus.
Le bon fonctionnement du WOL du NAS serait-il lié à sa table ARP ? bizarre…
Ma question est de savoir s’il y a moyen dans la configuration de l’interface « eth0 » de la garder UP même quand la machine est arrêtée électriquement ?
Pour information, j’ai enlevé le commentaire dans le fichier /etc/rc.local pour activer la commande suivante :
lethtool -s eth0 wol g
Mais cela n’a rien change.
Je précise que le réveil du NAS se fait bien, même après un flush des tables ARP du PC émetteur de la commande WOL.
Quelques idées ?
 

FX Cachem

Administreur
Membre du personnel
Trishul a dit:
e réveil du NAS se fait très bien tant qu’il n’est pas arrêté trop longtemps. Après quelques heures d’arrêt, cela ne fonctionne plus.
Le bon fonctionnement du WOL du NAS serait-il lié à sa table ARP ? bizarre…
C'est effectivement très étrange... Juste pour être sûr, tu as bien activé le Wake On Lan (WOL) depuis l'interface d'administration Panneau de configuration > Matériel et alimentation...
As-tu testé avec un autre outil ? Le NAS est-il sur le même switch (routeur) que ton ordinateur ?
 

Trishul

Nouveau membre
FX Cachem a dit:
Trishul a dit:
e réveil du NAS se fait très bien tant qu’il n’est pas arrêté trop longtemps. Après quelques heures d’arrêt, cela ne fonctionne plus.
Le bon fonctionnement du WOL du NAS serait-il lié à sa table ARP ? bizarre…
C'est effectivement très étrange... Juste pour être sûr, tu as bien activé le Wake On Lan (WOL) depuis l'interface d'administration Panneau de configuration > Matériel et alimentation...
As-tu testé avec un autre outil ? Le NAS est-il sur le même switch (routeur) que ton ordinateur ?

Bonjour FX :)
Le WOL est bien activé dans Matériel et alimentation
Oui j'ai testé avec Synology Assitant et c'est pareil.
Le NAS et le PC sont sur un même switch (CISCO, non administrable) alors que le routeur est sur un autre switch (Cisco administrable), les deux Cisco sont chaînés.
Et pour info l'ensemble de mes machines est dans le même plan d'adressage IP.

Petite erreur le WOL ne fonctionne pas avec Synology assitant.
Mais ça passe bien avec WakeOnLan V3.8.2 de Dipisoft
 

Trishul

Nouveau membre
Trishul a dit:
FX Cachem a dit:
Trishul a dit:
Petite erreur le WOL ne fonctionne pas avec Synology assitant.
Mais ça passe bien avec WakeOnLan V3.8.2 de Dipisoft
C'est tout de même étrange...

J'ai ouvert un ticket au support hier (Ticket: #655576)
J'attends une réponse, que je vous donnerai ici ;)

Bon la réponse est toute simple...et bien sûr logique.

Pour que le WOL fonctionne, encore faut-il que les équipements restent alimentés :oops:
Or le soir avant d'aller dormir j'ai l'habitude d'arrêter électriquement toute mon installation (PCs, swtichs, NAS, etc..)

Conclusion tout fonctionne correctement ;)
 
Haut Bas