Asustor VPN SERVER

thebadboy

Maître Jedi
4 Janvier 2016
603
2
48
Bonjour,

depuis le dernier MAJ de vpn server avec l'ajout du L2tp, je n'arrive pas a avoir accès au server.

hier, il y a eut une nouvelle MAJ et je me suis re-penché sur le problème.


j'arrive a me connecter au server en local, donc en inscrivant l'ip locale " 192.168.150.10" dans l'onglet server des paramètre vpn de mon iphone,

si je tape mon nom de domaine ou même mon ip wan je n'ai plus accès au server ( par-feu du nas desactivé).

Tous les ports sont bien ouvert mais le port 500 se met en rouge dans Ez-routeur, je l'ai ouvert directement dans mon routeur asus mais cela ne change rien et je ne sait pas si le problème vient de la.

Est il possible de changer le port par defaut " 500" du server vpn pour que je puisse tester.


merci
 
j'ai trouver, le problème vient de mon routeur asus rt-ac66u et je ne sait pas pourquoi.

j'ai activer le dmz avec l'ip du nas et j'arrive enfin a me connecter au serveur vpn depuis le wan, par contre tous mon trafic ( iphone) est redirigé vers le serveur :evil: même avec l'option décochée.... du coup je suis limité par mon upload du FAI.

autre chose, il est impossible de mettre des caractères spéciaux dans la clé du serveur vpn.

AMHA, asustor n'est pas trop copain avec ces caractères :lol:
 
ne JAMAIS mettre un nas dans un DMZ sauf s'il a plus qu'un port réseau ET qu'un des deux (celui dans la MDZ) sert pour le server web !

La ton nas est à 100% exposé à internet !

Ton soucis c'est que pour faire tu dois ouvrir les ports
Code:
L2TP over IPSec
To allow Internet Key Exchange (IKE), open UDP 500.
To allow IPSec Network Address Translation (NAT-T) open UDP 4500.
To allow L2TP traffic, open UDP 1701.
 
webmail a dit:
ne JAMAIS mettre un nas dans un DMZ sauf s'il a plus qu'un port réseau ET qu'un des deux (celui dans la MDZ) sert pour le server web !

La ton nas est à 100% exposé à internet !

Ton soucis c'est que pour faire tu dois ouvrir les ports
Code:
L2TP over IPSec
To allow Internet Key Exchange (IKE), open UDP 500.
To allow IPSec Network Address Translation (NAT-T) open UDP 4500.
To allow L2TP traffic, open UDP 1701.



merci pour l'info ;) , mais c’était juste pour tester avec la DMZ.


comme dit plus haut, j'ouvre tous les ports manuellement ( 500/4500/1701/1723==> udp et tcp pour test) dans le routeur mais cela ne va pas, je pense que le port 500 est le problème ( il est surement utilisé dans le routeur).
 
youpie j'ai trouvé grâce a un tuto sur un forum :cool:

Qund j'ouvre un port dans mon routeur, je met le port dans l'onglet "plage de port " ainsi que dans l'onglet "port local".

Dans le tuto il disait que pour un serveur L2tp il faillais juste remplir l'onglet plage de port..... et cela fonctionne.


Par contre tout mon traffic internet passe par le serveur quand je suis en 4G, y a t'il une astuce ? car l'onglet " tout envoyer" est bien décoché

Dernière chose, quand je suis en 4g et que je me connecte au wifi, l'iphone reste sur la 4g tant que la connection est faite au serveur vpn :oops: , je me suis casser la tete pendant des jours a faire aller ce truc pour au final en revenir a mon serveur openvpn de mon routeur :lol: