Synology VPN Server L2TP impossible par WiFi

tyone27

Nouveau membre
Bonjour à tous,

Je viens vous demandez de l'aide chère communauté pour l'installation et la configuration du paquet VPN Server sur mon Synology DS415+.

Après avoir installer le paquet en question, j'ai activé le serveur L2TP/IPSec et clé pré-partagé.
Une fois ceci fait, j'ai ouvert les ports 500, 4500 et 1701 sur le pare-feu du Synology et créé une redirection sur mon routeur.
La phase des tests s'est montrée un peu plus coriace :
- L'accès au VPN sur un iPhone 5 en 3G a fonctionné.
- En revanche, l'accès au VPN depuis le WiFi local ou depuis une connexion extérieure en WiFi n'a absolument pas fonctionné.

Sur les PCs, l'erreur 789 apparaît, quant à l'iPhone en WiFi un message d'erreur s'affiche aussi.

Voilà je crois vous avoir dit tout dit.
J'espères que mon problème en intéressera plus d'un et qu'une solution sera trouvée.

Merci beaucoup pour toute aide fourni !
 

FX Cachem

Administreur
Membre du personnel
Hello,

Je suis loin d'un NAS Synology pour pouvoir t'aider... Est-ce que tu peux revoir ta config avec http://www.cachem.fr/vpn-nas-synology/ ? Ce qui m'inquiète, c'est que tu puisses l'utiliser en 3G mais pas en WiFi depuis l'extérieur...
 

tyone27

Nouveau membre
Bonjour FX,

Tout d'abord merci de ta réponse rapide.
Après quelques soucis de modem/routeur, j'ai opté pour un changement de matériel auprès de mon FAI.
Je possède maintenant un modem et routeur séparés.

Bref, pour en revenir au VPN, j'ai bien suivis les étapes de https://help.synology.com/dsm/?section=VPNCenter&version=1.2&link=vpn_setup.html pour configurer le serveur VPN L2tP puis pour la suite j'ai bien suivi le tutoriel de Cachem.
Mais je vais recommencer l'installation et la configuration pour être sûr des paramètres.
Je prendrais des screenshots.

Je vous recontacte au plus vite.
Merci encore.
 

tyone27

Nouveau membre
Bonjour,

Après ce changement de configuration réseau j'ai recommencé l'installation et la configuration du VPN Server.

J'ai suivi à la lettre le tutoriel de Cachem, en testant d'abord le protocole PPTP.
Après configuration du VPN Server, du pare-feu du NAS, de la redirection de port du routeur, j'ai configurer la connexion sur un ordinateur portable connecté en WiFi.
Dans les propriétés de la connexion VPN, je me suis rendu dans l'onglet "Sécurité".
J'ai sélectionné le protocole PPTP, niveau de chiffrement maximal et j'ai coché "Protocole Microsoft CHAP Version 2 (MS-CHAP v2)".

La première tentative fut un échec. Une erreur s'est affiché. Malheureusement, je ne me souvient plus du numéro mais l'erreur spécifiait que le nom d'utilisateur et/ou le mot de passe était erroné ou que la connexion avec le serveur VPN n'était pas autorisée.

J'ai alors modifié dans les propriétés le protocole utilisé pour l'authentification et j'ai sélectionné "Microsoft : Mot de passe sécurisé (EAP-MSCHAP v2) (chiffrement activé)". Et là le deuxième essai fut le bon.

J'ai donc décidé d'utiliser la configuration pour le protocole L2TP.
la première tentative fut un échec. J'ai obtenue l'erreur 628, comme quoi le serveur avait fermé la connexion sans attendre qu'elle soit terminée.

J'ai donc essayé de changer le protocole d'authentification et j'ai coché "Protocole Microsoft CHAP Version 2 (MS-CHAP v2)". J'ai ensuite inséré la clé pré-partagée et je me suis connecté sans aucun soucis.

Donc mon problème est RÉSOLU !

Par contre j'aurais quelques questions, certaines ne sont pas en rapport avec le sujet.
Si il faut que je le fasse ailleurs, dit moi où et veuillez m'excusez.

1° Comment se fait-il que le pare-feu ne bloque pas l'accès au DSM, lorsque je suis connecté en VPN, alors qu'aucune règle n'accepte les adresses IP fourni par le serveur VPN ?

2° Est-il utile de laisser activé l'option UPnP sur mon routeur ?

3° Est-il bien de se connecter au DSM via "http://quickconnect.to/[nom_NAS]" quand je suis sur le réseau local ?

Je crois que pour l'instant c'est tout bon.
Merci de votre aide à tous, même les simples lecteurs.
 

FX Cachem

Administreur
Membre du personnel
tyone27 a dit:
Donc mon problème est RÉSOLU !
Bonne nouvelle, merci pour ce retour...


tyone27 a dit:
1° Comment se fait-il que le pare-feu ne bloque pas l'accès au DSM, lorsque je suis connecté en VPN, alors qu'aucune règle n'accepte les adresses IP fourni par le serveur VPN ?
Parce que ton NAS et ton PC sont sur le même réseau local...

tyone27 a dit:
2° Est-il utile de laisser activé l'option UPnP sur mon routeur ?
C'est toi qui voit... Aucune obligation :)

tyone27 a dit:
3° Est-il bien de se connecter au DSM via "http://quickconnect.to/[nom_NAS]" quand je suis sur le réseau local ?
Si tu passes par l'extérieur (hors de chez toi), c'est plus pratique... en local, aucun intérêt.
 
Haut Bas