[Tuto] Installer SWAG en Docker ( Reverse Proxy )

pikeupe

Nouveau membre
slt

pas eut le temps de regardé hier le petit fils ne m'a pas lâché (que du bonheur)
par contre, j'ai l'impression que crowdsec bloque des services
 

exemple54

Nouveau membre
Salut,
Pour rebondir un peu sur votre discussion, j'ai un souci, justement sur la redirection de portainer.
Je l'avais fait sous la forme portainer.ndd.fr et je ne sais pas pourquoi depuis hier, alors que seule la nuit est passée, et que je n'ai rien touché avant et après, ça ne fonctionne plus cette redirection.
J'ai le droit à un :

Ce site est inaccessible​

L'adresse DNS de portainer.ndd.fr est introuvable. Identification du problème…

DNS_PROBE_POSSIBLE


Bref, incompréhensible (pour moi), quelqu'un aura peut être une idée
Merci par avance ;)
 

EVOTk

Modérateur
Membre du personnel
Salut,
Pour rebondir un peu sur votre discussion, j'ai un souci, justement sur la redirection de portainer.
Je l'avais fait sous la forme portainer.ndd.fr et je ne sais pas pourquoi depuis hier, alors que seule la nuit est passée, et que je n'ai rien touché avant et après, ça ne fonctionne plus cette redirection.
J'ai le droit à un :

Ce site est inaccessible​

L'adresse DNS de portainer.ndd.fr est introuvable. Identification du problème…

DNS_PROBE_POSSIBLE


Bref, incompréhensible (pour moi), quelqu'un aura peut être une idée
Merci par avance ;)
Salut,
Vu que c'est une erreur DNS, je te dirait de vérifie cela en 1er ?
Si depuis une invite de commande sur ta machine tu ping portainer.ndd.fr
L'ip retournée est juste ? Essaye aussi un nslookup [B]portainer.ndd.fr[/B] voir si la résolution se fait bien par ton DNS
 

MilesTEG1

Modérateur
Membre du personnel
Il y a eu une grosse maj de swag hier . Pas mal de fichiers de conf ont changé.

Et ce matin plusieurs autres qui Ajoute des bricoles.
 

exemple54

Nouveau membre
Merci des retours

Si depuis une invite de commande sur ta machine tu ping portainer.ndd.fr
L'ip retournée est juste ?
Alors j'ai l'impression qu'il ne trouve pas lorsque que je ping l'adresse de portainer
Code:
La requête Ping n’a pas pu trouver l’hôte portainer.ndd.fr. Vérifiez le nom et essayez à nouveau.

Essaye aussi un nslookup [B]portainer.ndd.fr[/B] voir si la résolution se fait bien par ton DNS
Et pour ça je pense que c'est lié mais ça renvoie aussi une erreur en soit :
Code:
*** Aucun enregistrement internal type for both IPv4 and IPv6 Addresses (A+AAAA) disponible pour portainer.ndd.fr

donc j'imagine que c'est comme si ce lien n'existait pas.
Ce qui est bizarre c'est que tout lien autre que "portainer.ndd.fr" et "omv.ndd.fr" (cf. dernier paragraphe), me redirige vers la page "Welcome to your SWAG instance" (qui part ailleurs tous ces liens inexistants j'aimerais les envoyé sur une page unique mais c'est pour plus tard quand je maitriserais mieux les choses ^^)

(PS : je remplace bien ndd par mon vrai ndd si jamais quelqu'un se demandait)

Pas mal de fichiers de conf ont changé.
Merci pour les infos. J'ai vérifié et je n'ai pas trouvé qu'ils avaient changé

Pour être plus précis j'ai suivi le tuto de gtesté :
pour effectué mes redirections de lien
Hier soir en essayant de tout vérifié j'ai refais certain points etc... et je me suis rendu compte que pour openmediavault, si j'utilisais
Code:
openmediavault.ndd.fr
ça fonctionnait parfaitement mais si j'utilisais
Code:
omv.ndd.fr
(en redéfinissant comme il le fait dans le .conf crée le sous-domaine, ça ne fonctionnait plus non plus)
 

exemple54

Nouveau membre
Mais tu as configuré ton DNS pour qui pointe vers ton IP local ?
Normalement oui
Par exemple j'ai configuré nextcloud sous la forme nextcloud.ndd.fr et ça fonctionne très bien
j'ai installé heimdall (heimdall.ndd.fr), et ça fonctionne parfaitement aussi .
et quand je met openmediavault : omv.ndd.fr ne fonctionne pas, alors que openmediauvault.ndd.fr fonctionne (et si je change et que je mes untruc.ndd.fr pour aller sur l'interface openmediavault, ça fonctionne aussi)

Ce que je comprends pas, c'est que ça fonctionnait il y a 3 jours quand je l'ai fais. J'avais : portainer.ndd.fr / omv.ndd.fr / nextcloud.ndd.fr / heimdall.ndd.fr
et en retournant sur les configurations le lendemain portainer.ndd.fr et omv.ndd.fr me renvoyait l'erreur DNS alors que les deux autres fonctionnent toujours très bien
J'ai testé en changeant "omv" par "openmediavault" et ça fonctionnait très bien.
Et depuis je cherche pourquoi sur ces seuls 2 adresses (portainer.ndd.fr et omv.ndd.fr) ça plante. J'imagine que j'ai une erreur quelque part et à résoudre comme ça, ça risque d'être compliqué

Si je ping portainer.ndd.fr et omv.ndd.fr j'ai la meme erreur
alors que si je ping truc.ndd.fr (qui me renvoi sur la page d'accueil swag) ou openmediavault.ndd.fr ou nextcloud.ndd.fr ça fonctionne bien

Je me disais qu'il y avait un fichier de configuration qui était mal défini, donc j'ai tout refait, pour les 4 services, histoire de vérifier que je faisais la meme chose, et ça ne change rien.
 

MilesTEG1

Modérateur
Membre du personnel
Tu as un serveur DNS sur ton réseau ? (pour résoudre les ndd dans ton LAN)
C'est quoi ta box ? Il se peut qu'elle ne gère plus/pas le loopback qui te permettrait de te dispenser d'un serveur DNS local.
 

pikeupe

Nouveau membre
slt

je tente les notifications via Gotify, mais je ne reçois rien
les logs de swag aucun problème enfin, je pense
la question que je me pose est-ce que le script fonctionne sous Ubuntu 22.04 ou la commande

merci pour vos lumière
 
Haut Bas