[Tuto] Connaitre le PUID / PGID d'un utilisateur

EVOTk

Modérateur
Membre du personnel
Bonjour,
Souvent pour une installation via Docker, le PUID et le GUID d'un utilisateur est nécessaire.

Le PUID est le "UserID", donc l'ID de l'utilisateur.
Le PGID est le "GroupID", donc l'ID du groupe auquel appartient cet utilisateur.

Pour faire cette manip, il vous faudra vous connecter en SSH à votre NAS, si vous ne savez pas le faire, vous trouverez ici un tuto explicatif : [Tuto] Acceder à son NAS en lignes de commande.

Une fois en SSH, pour connaitre le PUID / PGID d'un uilisateur que nous allons nommer "test" il suffit d'indiquer :
Code:
id test

La commande va nous retourner par exemple :
HRozJs3.png

Code:
uid=1033(test) gid=100(users) groups=100(users)


Ici, on voit clairement notre PUID, qui est 1033 , utilisateur "test", et le PGID, qui est 100 ( il fait parti du groupe "users" )
 

Blockkk

Apprenti
Salut, j'ai suivis ce tuto => https://www.forum-nas.fr/viewtopic.php?f=56&t=13213

Quand je mets mon Ip, ça me met un message : "Network error: Software caused connection abort"

Quelqu'un sait comment résoudre ce problème?
 

EVOTk

Modérateur
Membre du personnel
Salut,
Aucune raison de faire un nouveau sujet, la question peu etre posé a la suite du tuto.
De quelle maniere te connect tu ?
Utilise tu le bon port ?
Est'il ouvert sur la machine ?
 

Blockkk

Apprenti
EVOTk a dit:
Salut,
Aucune raison de faire un nouveau sujet, la question peu etre posé a la suite du tuto.
De quelle maniere te connect tu ?
Utilise tu le bon port ?
Est'il ouvert sur la machine ?

Ok.

J'ai suivis cette procédure à la lettre ==> https://www.forum-nas.fr/viewtopic.php?f=56&t=11461
 

EVOTk

Modérateur
Membre du personnel
Le port SSH est bien ouvert dans le pare-feu de ton nas ? ( si celui ci est actif ? )
 

Blockkk

Apprenti
EVOTk a dit:
Le port SSH est bien ouvert dans le pare-feu de ton nas ? ( si celui ci est actif ? )

C'est à dire? Faut créer une exception, ça se passe comment? (j'ai essayé par feu inactif aussi, il y avait le même message)
 

EVOTk

Modérateur
Membre du personnel
Cela dépend comment ton pare-feu est paramétré, mais oui il faut que le port que tu as configurer en SSH soit autorisé
Mais si sans pare-feu c'est identique c'est que le soucis n'est pas ici.

Le port que tu renseigne est bien le bon ?
 

Blockkk

Apprenti
EVOTk a dit:
Cela dépend comment ton pare-feu est paramétré, mais oui il faut que le port que tu as configurer en SSH soit autorisé
Mais si sans pare-feu c'est identique c'est que le soucis n'est pas ici.

Le port que tu renseigne est bien le bon ?

Il faut créer l'execption du port dans le pare feu ou juste autoriser le "22" déjà présent? Si c'est la 2e manip, je l'ai fais et le message est le même
 

EVOTk

Modérateur
Membre du personnel
A la base dans le pare-feu, il n'y a rien, il faut autorisé le port 22 pour un usage local.
Ton IP n'est pas dans le liste de blocage par hasard ?
 

Blockkk

Apprenti
EVOTk a dit:
A la base dans le pare-feu, il n'y a rien, il faut autorisé le port 22 pour un usage local.
Ton IP n'est pas dans le liste de blocage par hasard ?


Dans le pare feu, on doit faire quoi concrètement pour pouvoir connaitre le PUID / PGID d'un utilisateur?

Où je peux trouver cette "liste de blocage"? Dans "compte"? Si oui, il y avait une adresse IP qui n'était pas celle du PC, je l'ai supprimé.
 

EVOTk

Modérateur
Membre du personnel
Il faut autoriser le port ssh afin que tu puisse te connecter.

Tu utilise putty également ?
 

EVOTk

Modérateur
Membre du personnel
Oui ici le port est ouvert
Dans terminal, le service esr bien actif, et cest bien le port 22 qui est choisi ?
 

EVOTk

Modérateur
Membre du personnel
Alors la je vois pas, je peu te proposer de regarder rapidement via teamwiever si tu veut ?

Si oui envoi moi tes identifiant par message privé
 

Blockkk

Apprenti
EVOTk a dit:
Alors la je vois pas, je peu te proposer de regarder rapidement via teamwiever si tu veut ?

Si oui envoi moi tes identifiant par message privé

Je vais au lit que je me lève dans 6h... on peut faire ça demain si t'es dispo

Je pense que ça a fonctionné à moitié. Me suis bien retrouvé sur la fenêtre noire "login as".
J'ai mis mon ID et quand j'écris mon MDP le curseur de la lettre ne bouge pas. J'écris mon MDP et ça met accès refusé
 

EVOTk

Modérateur
Membre du personnel
Moi 7h :) courage
Oki donc cest okeffectivement le mot de passe ne saffiche pas quand tu tape, cest normal
Le compte qui sert a se loger dans faire parti du groupe administrateur sur le nas.
 
Haut Bas