Qnap ts453a -parfois le nas ne se rallume pas - pb avec le mode "sleep"

doudoufr

Chevalier Jedi
Bonjour

Tous les jours (enfin soir) je mets mon nas en mode "sleep" a 00h01 et il se rallume a 6h59. (programmé dans l'interface).

Sauf que parfois, ben....il se rallume pas. Obliger d'appuyer sur le bouton et rebooter. (du coup, check du disque ensuite hein, car ben éteins a la sauvage donc ca lui plait pas !)


Mais ca le fait pas tout le temps.
Par exemple, ca me l'a fait ce matin, mais toute cette semaine, c'était OK.

Est ce que qq'un a eu ce pb ?

j'suis en 4.2.1.

J'ai ouvert un ticket sur le helpdesk. Mais je voulais savoir si qq'un avait déjà rencontré ce pb.
 

Gaijin

Chevalier Jedi
as tu analysé le log du NAS?

sous UNIX tu peux voir l'activité du NAS par la suite, si il est en sommeil et qu'il n'est rien fait tu verras pourquoi et pourra modifier selon...


bonne chance ;)

PS:tu as essayé de supprimer cette programmation, rebooté et créer à nouveau un planning?
 

Gaijin

Chevalier Jedi
je connais pas "encore" ton NAS, je ne sais pas quelle distribution est sur QNAP


mais je ferais ceci dans le terminal:

# cd /var/log

# ls

par la suite selon ce que tu veux:

# less /var/log/messages
# more -f /var/log/messages
# cat /var/log/messages
# tail -f /var/log/messages
# grep -i error /var/log/messages


le glossaire qui peut être utile:

/var/log/messages : General message and system related stuff
/var/log/auth.log : Authenication logs
/var/log/kern.log : Kernel logs

/var/log/cron.log : Crond logs (cron job)
/var/log/maillog : Mail server logs
/var/log/qmail/ : Qmail log directory (more files inside this directory)
/var/log/httpd/ : Apache access and error logs directory
/var/log/lighttpd/ : Lighttpd access and error logs directory
/var/log/boot.log : System boot log
/var/log/mysqld.log : MySQL database server log file
/var/log/secure or /var/log/auth.log : Authentication log
/var/log/utmp or /var/log/wtmp : Login records file
/var/log/yum.log : Yum command log file.

voila de la lecture pour fignoler


https://fr.wikibooks.org/wiki/Le_système_d%27exploitation_GNU-Linux/Les_fichiers_journaux_syslog




bonne chance
 

FX Cachem

Administreur
Membre du personnel
Le mode "Sleep" c'est lequel... Veille ? As-tu essayé avec le mode "Arrêter" ?

Il est écrit : "Le système ne peut pas être éteint ou redémarré en mode veille." Je te l'accorde, le système de planification de l'alimentation n'est pas vraiment clair chez Qnap.
 

doudoufr

Chevalier Jedi
Bonjour

Non je n'ai pas essayer le mode arreter. Juste le mode veille.

Et le nas se rallume bien en mode veille. Juste parfois ben....non. C'est bien ca le pb lol !
 

QoolBox

Représentant QNAP
tu n 'as pas coché la case différé l’extinction par hasard ?

mon TS-253PRO est également en Sleep à partir de 23h et mise en route 7h, il est en 4.2.1 et pas de soucis à se niveau là

la programmation se fait par le crontab, il faut vérifier si celui-ci n'est pas corrompu, ça peut arriver

tu peux auditer les fichier de config sur le NAS en SSH :

Code:
cd /tmp
wget http://download.qnap.com/Storage/tsd/utility/qck
chmod +x qck
./qck all
 

doudoufr

Chevalier Jedi
Coucou

Non non la case a coché "différé..." n'est pas coché.

et je le répète, ce n'est pas la mise en veille qui coince ! c'est le réveil ! il se met bien en veille sans souci !

a quoi sert ton qck ?

[edit] voila ce que me donne le qck :

Code:
NAS type:        TS-X53II
HAL model:       TS-453A
FW type:         HAL
FW version:      4.2.1
FW build:        20151224
md9 online:      yes
md9 mounted:     yes
md9 initialised: Jan 4 20:44:02 2016
md13 online:     yes
md13 mounted:    yes

uLinux.conf:     ok
smb.conf:        ok
crontab:         ok
Model_Name:      ok (TS-X53II)
BOOT.conf:       ok (TS-NASX86)

enc  port    device   signature  partitions  model
  0     1  /dev/sda   QNAP FLEX           5  WD20EARX-00PASB0
  0     2  /dev/sdb   QNAP FLEX           5  WD20EZRX-00DC0B0
  0     3  /dev/sdc   QNAP FLEX           5  WD20EZRX-00D8PB0
  0     4  /dev/sdd   QNAP FLEX           5  SSD 850 EVO 250G

Device          Status
-------         ------
/dev/md1        Filesystem not found!
/dev/md2          Failed to find physical volume "/dev/md1"
LVM device ()

Device          Status
-------         ------
cachedev1       DataVol1
 

doudoufr

Chevalier Jedi
jai un ticket ouvert au support, mais je sais pas si la dame est tres tres forte.....

parce que bon, elle m'a répondu "ah ben oui il vous dit que faut vérifier le disque la dans votre fichier log"....

heu oui....c'est normal vu que j'ai du l'éteindre a la sauvage et le rallumer, puisque rien ne réponds plus !

donc je sais pas o_O
 

QoolBox

Représentant QNAP
pas de madame chez Qnap, ça doit être mon collègue.. :lol: on a pas mal de taf en ce moment avec la Beta

tu as bien mis "mettre le serveur sous tension" et pas "redémarrer", c'est une erreur souvent rencontré
 

doudoufr

Chevalier Jedi
Salut

je me répete mais tout est bien configuré, puisque sinon ben ca fonctionnerait pas les autres jours.
La ca plante parfois....sans que je sache pourquoi !
 

doudoufr

Chevalier Jedi
voila :
Code:
# m h dom m dow cmd
0 2 * * * /sbin/qfstrim
0 4 * * * /sbin/hwclock -s
0 3 * * * /sbin/vs_refresh
0 3 * * * /sbin/clean_reset_pwd
0-59/15 * * * * /etc/init.d/nss2_dusg.sh
30 7 * * * /sbin/clean_upload_file
0-59/10 * * * * /etc/init.d/storage_usage.sh
30 3 * * * /sbin/notice_log_tool -v -R
0 3 * * 0 /etc/init.d/idmap.sh dump
35 7 * * * /sbin/qbox_util -c  > /dev/null 2>/dev/null
30 7 * * * /usr/local/sbin/version_cleaner -t 0 > /dev/null 2>/dev/null
42 17 * * * /share/CACHEDEV1_DATA/.qpkg/QcloudSSLCertificate/bin/ssl_agent_cli
* * * * * /mnt/ext/opt/netmgr/util/lock_timer.sh
59 6 * * 2 /etc/init.d/startup
4 3 * * 3 /etc/init.d/backup_conf.sh
1 0 * * 3 /etc/init.d/pw_sleep.sh
 

QoolBox

Représentant QNAP
Code:
59 6 * * 2 /etc/init.d/startup
1 0 * * 3 /etc/init.d/pw_sleep.sh

on vois les deux programmation

allumage a 6h59 le deuxième jour de la semaine (lundi)
extinction à 00h01 le troisième jour de la semaine (mardi)

la semaine commence le dimanche avec crontab

d’après moi ça devrait être plus :

Code:
59 6 * * */etc/init.d/startup
1 0 * * * /etc/init.d/pw_sleep.sh

si ta programmation est journalière...

essaye d'éditer le fichier avec WinSCP pour voir
 

doudoufr

Chevalier Jedi
Alors y'a un pb qqe part
car voila ce que j'ai dans les options d'alim
qnas alimentation.png

et il séteinds bien tous les jours a 00h01 et se rallume bien a 6h59....(sauf parfois)
hier soir (lundi), il s'est bien mis en veille
ce matin (mardi), il s'est bien allumé.
 

QoolBox

Représentant QNAP
à mon avis c'est un bug dans la programmation du gestionnaire d'alimentation

essaye de faire le changement et regarde demain si ça marche...
 

doudoufr

Chevalier Jedi
oki. J'ai changé. On verra now. :cool:

Le seul souci, c'est que le pb venait aléatoirement, donc ca sera pas forcément demain.

Vu que tu bosses pour Qnap, je compte sur toi pour remonter le bug a qui de droit a Tawaïn la bas :) :D

Merci bcp !
 

QoolBox

Représentant QNAP
oui c'est une bizarrerie, mon collègue qui a pris le ticket et venu voir notre échange sur le forum, il a contacté le HQ pour avoir plus d'éclaircissement
 

doudoufr

Chevalier Jedi
Dsl pour avoir dit que c'était une dame :).

Mais son nom / prénom laissez penser a ca :D

Tiens autre bizarrerie du jour : ma linux station à l'air d'être.....planté ou remise a zéro, car dans l'interface, eh bien il n'y a plus rien. Alors que hier, il y avait ce qu'il fallait.

De plus, quand on active le vnc sur la linux station, il n'y a pas de mot de passe. C'est un peu génant niveau sécurité je trouve. (jai aussi ouvert un ticket a ce sujet :))
 
Haut Bas