Qnap [ Traccar ] GPS tracking system OpenSource

4.12

Code:
More features migrated to the modern web app:

All reports, including export support
Drivers management
Computed attributes
User registration from login screen
Notable changes on the back-end side:

Enabled support for HTTP SMS API for commands
Better logging for forwarding
We are also in the process of migrating configuration parameters to a new system where we will potentially be able to generate documentation for all available configuration parameters. We had issues with undocumented configuration parameters for a long time and we are trying to fix it. As we are going through this process, we decided to simplify and remove some old code, including some features that you might be using, so please check before upgrading.

Removed CSV and GPX export - part of the code was not used much and was poorly maintained, so we decided to remove for now until we implement a better version of export
Removed XML attributes support - functionality hasn't been used by official Traccar version for a very very long time and removing it unlocks some code improvements
Removed JNDI support - same reason as above
Removed some legacy confuguration parameters - we removed quite a few configuration parameters that are deprecated or not recommended
Removed SMPP support - the library that we were using for SMPP support hasn't been maintained for a long time, so this is out of our control, but you can use HTTP API instead that most SMS services provide
If we removed a feature that you really need and rely on, please let us know on the forum or GitHub.

New device protocols:

MOBILOGIX (MBX) - hardware and software for IoT
SWIFTECH - a company form Chennai, India
FM IOTM - new MQTT based protocol from Xirgo Global
Dolphin - fleet management provider
Ennfu Scientific - custom hardware from Jiangsu, China
 
Hi, i just install new wersion of traccar 6.1 on my NAS.
After installation everything works fine. I can register a new user and the server runs at MY_IP:18082
If I stop the server via
/etc/init.d/traccar.sh stop
and run
/etc/init.d/traccar.sh sart again
the page MY_IP:18082 no longer runs. I'll add that I don't even change the configuration file

the only thing I found was this entry in the log

2024-05-18 08:08:24 INFO: Update summary generated
2024-05-18 08:08:24 INFO: Successfully released change log lock
2024-05-18 08:08:24 INFO: Command execution complete
2024-05-18 08:08:29 WARN: Port disabled due to conflict - Address already in use - BindException (...)
2024-05-18 08:08:29 WARN: Port disabled due to conflict - Address already in use - BindException (...)
2024-05-18 08:08:29 WARN: Port disabled due to conflict - Address already in use - BindException (...)
2024-05-18 08:08:29 WARN: Port disabled due to conflict - Address already in use - BindException (...)
2024-05-18 08:08:30 INFO: jetty-11.0.20; built: 2024-01-29T21:04:22.394Z; git: 922f8dc188f7011e60d0361de585fd4ac4d63064; jvm 18.0.2.1+1-1
2024-05-18 08:08:30 ERROR: Main method error - port out of range:1118082 - IllegalArgumentException (... < WebServer:223 < Main:126 < *:110)
2024-05-18 08:09:00 INFO: [T06d9e659] connected
I expect that the problem is in port 1118082 and should be 18082
How to solve it?
 
Necessary port are inside /opt/traccar5/conf/default.xml

one of the must be in use on your NAS

need by default 5001 to 5253 (but only some them are really necessary

if you want do not use a port just quote it within this file with

<!--

<entry key='gps103.port'>5001</entry>

-->

but traccar disable it automatically if in use

you modified the UI port to 1118082 wich is not a port you must set it until 65536
 
I guess that's not the point. I have been using traccar for a long time. Yesterday something went wrong with the installation of traccar 5.4 and I decided to install a new version 6.1. I removed the old one and installed the new one. It worked immediately on the default port 18082. I wanted to upload my configuration file and after stopping the application, I uploaded the file and started it again. Unfortunately the website no longer worked. I deleted the application from QNAP and reinstalled it with the new QJDK18. The app worked again. I entered /etc/init.d/traccar.sh restart in SSH and the WEB application no longer started, this time I did not change the configuration file.
Something is wrong, restarting the application causes WEB to stop working. I noticed this message in the log and the port 118082 is too high, but I didn't set it, it changes after a restart.
 
mmm i think i know where is the problem, remove the sed if you have one into startup script (/opt/traccar/traccar.sh) or comment it with a # and put back in config file 18082

will modify port without 8082 in port name
 
Dernière édition:
Unfortunately now it's worse. After installing the server, it is not possible to log in to the website using MY_IP:18082.
It is true that the application works, I checked it with the ps aux | command grep traccar and I got
```
10968 admin 275220 S /opt/QJDK18/bin/java -jar /opt/traccar/tracker-server.jar /share/CE_CACHEDEV1_DATA/.qpkg/traccar/conf/traccar.xml
```
after stopping the process and restarting the output of ps aux | grep traccar is empty, which would mean that the application does not start. When I want to stop the application via
```
/etc/init.d/traccar.sh stop
```
I get it
```
/etc/init.d/traccar.sh: line 63: kill: (21935) - No such process
```
 
I found bug in default.xml file in 6.1 version the defaul port was
Code:
<entry key='web.port'>1118182</entry>
In latest version 6.1.0.1 the default port number is 18182 diferent than previous 18082
Now register web page vorking fine on MY_IP:18182 and i'm testing restarting app to check it's everefing fine
 
Everything now works as it should. There was probably a problem with my configuration file, because after uploading it, the website stopped working. I created a new file based on the defual.xml file and everything works, I just changed the port again to the previous default 18082