Synology ResourceSpace erreur 103 Failed to move uploaded file

ben

Nouveau membre
Bonjour,

Comme dit dans le titre, je ne peux pas uploader de photos dans ResourceSpace (http://www.resourcespace.org/), logiciel de gestion phototheque.
Il y a le message 103 Failed to move uploaded file à chaque fois que je lance un upload.

J'ai une config un chouille différente de la config standard :
- resourceSpace est installé sur /volume1/www
- le dossier de stockage des images est dans le /volume2 (pas assez de place disque sur volume1 pour y mettre ttes mes photos)

J'ai personnalisé le open_base_dir PHP et testé avec et sans PHP safe mode :


Les droits sur le dossier de stockage sont root:users en 777 (j'en ai testé plein sans succès...)

Si quelqu'un a une idée pour me sortir de mes tests sans fin, je serais très reconnaissant ;)

Merci !
 

FX Cachem

Administreur
Membre du personnel
Alors je ne connais pas du tout cette application.
Tu as fait un chmod 777 donc il ne devrait pas y avoir de problème. Teste un chown -R users:users de ton dossier (je n'y crois pas, mais ça ne mange pas de pain). Teste aussi le nom de ton répertoire sur 8 caractères.
 

ben

Nouveau membre
Merci pour ces pistes.
De mémoire je crois avoir déjà fait le chown -R users:users mais ça coûte rien de réessayer.
Par contre je n'avais pas pensé au nom de répertoire sur 8 caractères et ça me parait très pertinent.

Au sujet de l'application, c'est une photothèque très performante qui prend en charge énormément de fichiers photo (dont PSD, RAW etc) les PDF ...
Pour ceux que ça pourrait intéresser (et qui ne jouent pas avec différents volumes comme moi) voici une proc d'install sur Synology qui fonctionne : http://wiki.resourcespace.org/index.php/Installing_on_Synology_DSM

A tout pour les résultats des tests
 

FX Cachem

Administreur
Membre du personnel
Si tu le laisses sur le Volume1, ça marche ? Si oui, tu peux faire ça :

Code:
ln –s /volume1/source/ /volume2/destination
Qu'en penses-tu ?
Cela va créer un lien symbolique entre répertoire ;)
 

ben

Nouveau membre
Il me semble avoir tenté ça au début de mes ennuis mais ça ne me coute rien de réessayer ;)
Pour le moment j'ai un alias dans le httpd.conf qui ne résoud pas le pb d'upload. M'en vais le désactiver et refaire un lien symbolique.
 

ben

Nouveau membre
Argh, ça marche pas non plus...!
Je soupçonne une sécurité spécifique qui interdit des copies de fichiers dans un répertoire autre que le root web. Mais quoi ???

(ps désolé, j'avais oublié de préciser que j'avais déjà testé les liens symboliques. mais en fait j'ai testé tellement de trucs depuis la semaine dernière que j'en oublie....)

Sinon, ça existe une photothèque sur Synology qui lit les PSD et fichiers raw d'appareil photo ?
Parce que là je crois que je vais abandonner Resourcespace...
 

FX Cachem

Administreur
Membre du personnel
Le RAW ? Aucun problème avec Photo Station... par exemple. :) (arw, srf, sr2, dcr, k25, kdc, cr2, crw, nef, mrw, ptx, pef, raf, raw, 3fr, erf, mef, mos, orf, rw2, dng, x3f)
Le PSD ? Ca rique d'être compliqué... :oops:
 

ben

Nouveau membre
Vi, c'est compliqué pour les PSD... d'ou ma galère avec ce logiciel de photothèque (je suis ex photographe et j'ai des années d'archives à indexer dont énormément de PSD).
Ou alors il faudrait que je trouve comment déplacer le root web sur le volume 2 au lieu du volume 1 par défaut...

En tous cas j'apprécie beaucoup aide, c'est sympa !
 
Haut Bas