Qnap Raid 1 en mode dégradé/Disque déconnecté - Problème NAS ou DD

IL-MAFIOSO

Maître Jedi
11 Janvier 2016
624
5
48
Bonjour à tous,

Je rencontre un soucis depuis hier avec mon NAS TS-253A. Je me suis retrouvé avec le RAID1 en mode dégradé.Voyant alim rouge + voyant disque 1 éteint avec divers messages : disque déconnecté, ........
J'avais lu un ancien Topic de 2018 sur le même genre de soucis. J'ai donc retiré les racks et tout dépoussiéré et remis les disques. LE NAS revoit le disque capricieux et relance la réparation du RAID 1.
Ce matin, je regarde l'avancé et rebelote, avec le disque 1 :

App Name: Hardware Status
Category: I/O Ports
Message: [Hardware Status] Failed to access the installed drive. Check the Host: 3.5" SATA HDD 1 for errors.

App Name: Storage & Snapshots
Category: RAID Group
Message: [Storage & Snapshots] RAID group "1" is degraded. Storage pool: 1.

App Name: Hardware Status
Category: Drives
Message: [Hardware Status] "Host: 3.5" SATA HDD 1": Disconnected.

App Name: Storage & Snapshots
Category: RAID Group
Message: [Storage & Snapshots] Skipped rebuilding RAID group "1". Storage pool: 1

Je ressors le disque ce matin et le remet. Et là c'est reparti. Il recommence la reconstruction:
1713077739405.png

Le disque n'a pas l'air en mauvais état:

1713077886433.png

Va-t-il-aller jusqu'au bout ? Je ne suis pas convaincu ...

BUG NAS ? DD HS ?
Pouvez-vous me dire ce que je peux vérifier en me guidant ? Afin que je puisse aller dans la bonne direction et prévoir le remplacement de ce qui va bientôt peut être lâcher ?
Merci d'avance
 
Bonjour,
Regarde les informations SMART du disque.
Si te la resorti c'est que le disque dur a un problème.
 
Le seek error rate n'est pas bon, enfin c'est pas la cata mais c'est tout de même un signe de problème.
Hello, je vais voir comment se passe la nouvelle tentative de reconstruction ... Si çà se replante de la même manière, je vais acheter un nouveau DD.
Vous préférez Iron Wolf NAS Pro ou WD NAS Pro en disque DD classique ?
 
Effectivement ton disque a des erreurs, en fonction de l'espace disponible ça peut le faire, mais si ton disque est presque plein, c'est dangereux.


Pour ma part je garde une préférence pour WD, retour sav sans problème ( d'après les retours que j'ai eu car mes plus vieux disques ont 8 ans et ronronne encore) les attributs smart sont faciles à comprendre et ce sont des bons disques.

Après au niveau de la gamme, tu a les red et red plus qui sont pas mal ( les red pro si tu as le budget)

Sinon j'utilise aussi les wd "white" que j'ai récupéré à partir de disques durs externes WD éléments desktop.
je ne les utilisent que depuis 1 ans et ils ne sont pas trop solliciter donc Difficile de te faire un retour.

Par contre @EVO Les utilisent depuis un moment ( il a même fait un article dessus)
Il pourra donc te faire un retour de son expérience qui sera plus significative que la mienne.
 
Merci pour ton retour. Comme j'utilise aussi le NAS pour de la vidéosurveillance, les disques "grattent" en permanence 24/24 7j7.
 
Merci pour ton retour. Comme j'utilise aussi le NAS pour de la vidéosurveillance, les disques "grattent" en permanence 24/24 7j7.
Il ne faut pas mettre sur les mêmes disques NAS les données de la vidéosurveillance et tes data. Pour la vidéosurveillance, il faut un ou des disques dédiés, et il existe des versions pour cela, les versions Purple de WD par exemple. En effet, la vidéosurveillance sollicite en écriture H24 les disques et cela réduit considérablement la durée de vie, d'où probablement ces erreurs. Les versions Purple ont vocation à être sollicitées en écriture H24, et ont quand même des durée de vie plus limitées. Après peu importe le modèle, le principale est d'avoir un disque dédié à la vidéosurveillance.
 
Il ne faut pas mettre sur les mêmes disques NAS les données de la vidéosurveillance et tes data. Pour la vidéosurveillance, il faut un ou des disques dédiés, et il existe des versions pour cela, les versions Purple de WD par exemple. En effet, la vidéosurveillance sollicite en écriture H24 les disques et cela réduit considérablement la durée de vie, d'où probablement ces erreurs. Les versions Purple ont vocation à être sollicitées en écriture H24, et ont quand même des durée de vie plus limitées. Après peu importe le modèle, le principale est d'avoir un disque dédié à la vidéosurveillance.
Hello, J'utilise un NAS en Raid 1 avec deux DD. Si tu parles de séparer la vidéosurveillance de mes datas, cela veut dire que je dois alors utiliser un disque externe pour la vidéosurveillance branché en USB ?
Pour mes données personnels, j'effectue déjà une sauvegarde régulière sur un DD externe via l'USB de façade que je retire une fois la sauvegarde effectuée.
 
Dernière édition:
Je ne sais pas si tu peux faire de la vidéosurveillance avec un disque dur externe, à priori oui, il faut voir avec le logiciel de vidéosurveillance que tu utilises.
Vu que tu as un NAS deux baies, quel est l'interêt du RAID1 ? Pourrais-tu utiliser un des deux emplacements pour un disque dédié à la vidéosurveillance ?
Pour rappel la technologie RAID n'est pas une sauvegarde, c'est de la disponibilité. En fonction de l'usage de ton NAS, le RAID n'est pas forcement indispensable.
 
Je ne sais pas si tu peux faire de la vidéosurveillance avec un disque dur externe, à priori oui, il faut voir avec le logiciel de vidéosurveillance que tu utilises.
Vu que tu as un NAS deux baies, quel est l'interêt du RAID1 ? Pourrais-tu utiliser un des deux emplacements pour un disque dédié à la vidéosurveillance ?
Pour rappel la technologie RAID n'est pas une sauvegarde, c'est de la disponibilité. En fonction de l'usage de ton NAS, le RAID n'est pas forcement indispensable.
J'utilise QVR Pro pour la surveillance. Dans le cas de mes soucis actuels, le RAID 1 me permet quand même d'accéder plus ou moins à mes données, non ?
Si je n'avais pas le RAID et avec les problèmes que j'ai actuellement, je n'aurais plus rien eu si par exemple mes données étaient sur le disque 1 ?
Le mode dégradé permet quand même d'avoir accès en lecture/écriture mais avec des performances moindre apparement

Et est-il possible de passer d'un RAID 1 en deux disques distincts sans tout perdre ?

Je ne suis pas un pro, corrige moi si je dis des choses erronés, merci.
 
Dernière édition:
Et est-il possible de passer d'un RAID 1 en deux disques distincts sans tout perdre ?
Pour moi non on ne peut pas, il faut passer par une sauvegarde externe et recopier à nouveau les données. @EVO tu confirmes ?

Si je n'avais pas le RAID et avec les problèmes que j'ai actuellement, je n'aurais plus rien eu si par exemple mes données étaient sur le disque 1 ?
Bien sûre c'est ce à quoi sert le RAID, tes données sont toujours "Disponibles" ET sauvegardées sur un autre support. Mais c'est cet autre support qui est important et qui constitue ta véritable sauvegarde. Le deuxième disque du RAID1 permet d'avoir toujours accès à tes données en lecture/écriture. C'est juste que en fonction de l'usage que tu en as, est-ce grave de plus avoir accès à tes données pendant quelques jours sachant quelles sont bien sauvegardées sur un autre support ? Par exemple, pour un usage type PME avec des salariés qui bossent toute la journée sur ces données, cela n'est pas suffisant. Perdre des journées de travaille ce n'est pas vraiment acceptable. Pour un particulier, selon l'usage c'est je pense acceptable. C'est bien pour cela que le RAID permet la "Disponibilité" de tes données en se protégeant de la défaillance d'un disque dure mais ne constitue pas une "Sauvegarde".
 
Hello, merci . Je vais pour l’instant voir comment ça se passe. La reconstruction est toujours en cours (73%).
Existe t’il un log qui permettrait de voir pourquoi le disque s’est déconnecté ? (Le voyant du NAS pour le disque était éteint )
 
Hello, depuis quelques jours, tout a l'air de tourner à nouveau correctement. Mystère ... MAis tant mieux.
J'ai regardé le seek error rate, pour les deux disques, j'ai la même chose :
1713551561106.png
 
Mais dans un screen avant tu avait 32 non 🤔?
Oui exactement… même moi je ne saisis pas la chose ….
Lorsque j’avais tenté la 1ère reconstruction , je n’avais sorti à chaud que le disque 1 puis remis mais ça avait échoué un moins de 24h00 après son lancement.
Pour la 2ème tentative ,je n’ai fait qu’éteindre le NAS, sortir les deux disques , enlever la poussière, remettre les disques et redémarrer le NAS. La reconstruction a duré plusieurs jours.
Même le scan hebdomadaire antivirus qui s’est lancé en même temps a mis presque 2 jours.
Je veux bien comprendre ce qui s’est passé…. mais je suis très loin d’avoir vos compétences sur les NAS 😉