Qnap [ Qapache + PHP 7.2.26 ] [ 2.4.39 ] Apache WebServer + PHP + Extensions

QoolBox

Représentant QNAP
2 Janvier 2014
10 572
164
153
50
France
www.qnap.com
httpd_logo_wide_new.png

Source : http://httpd.apache.org/ - http://php.net/ - http://pecl.php.net/

Download :

[ Apache 2.4.39 + PHP 7.2.25+ PECL Extension ] x64, arm-x41, arm64


https://qnapclub.eu/fr/qpkg/268

Knwon issue :

for unknown reason mod_ssl avoid Qapache Starting on x73 series


Note :

Sauvegardez votre config avant to upgrade de qpkg, elle sera écrasée

Gestion dans ma Webui / manage in my own Webui

  • httpd.conf
  • SSL.conf
  • php.ini
  • error.log

HTTP = port 88
HTTPS = port 448

Héberger vos site Web dans votre partage htdocs / Host your website in your htdocs share
 
Hey,

Unfortunately I do not speak French. I hope it is fine if post this in English.
First of all thanks a lot for this nice package and for all the other packages I could find in this board. Really impressive.

I installed the package and everything seems to run quite smooth. Owncloud is impressive fast on my ts-269, much as faster as compared with the builtin webserver and php 5.3. However, I have one major problem. My HDDs do not spin down anymore. When I deactivate the package, the HDDs spin down properly. I observed the same behavior also if no further webapps like owncloud are installed. Do you have any idea what I could do about it? The spindown is really crucial for me so I hope that you can help me.

Thanks a lot
Daniel
 
dagginio a dit:
Hey,

Unfortunately I do not speak French. I hope it is fine if post this in English.
First of all thanks a lot for this nice package and for all the other packages I could find in this board. Really impressive.

I installed the package and everything seems to run quite smooth. Owncloud is impressive fast on my ts-269, much as faster as compared with the builtin webserver and php 5.3. However, I have one major problem. My HDDs do not spin down anymore. When I deactivate the package, the HDDs spin down properly. I observed the same behavior also if no further webapps like owncloud are installed. Do you have any idea what I could do about it? The spindown is really crucial for me so I hope that you can help me.

Thanks a lot
Daniel

Hi daniel,

not sure why you have this behavior with OwnCloud (or Apache), all qpkg are installed indeed on RAID Lun, also some loggin stuff and DB

By running iotop and using the "o" (only active processes) and "a" (accumulating) options in the program, you can see which processes are accessing data from hard drives.

let me know,
 
Hey,

Thanks for your help. I run iotop with the following output.

TID PRIO USER DISK READ DISK WRITE SWAPIN IO> COMMAND
2370 be/3 admin 0.00 B 76.00 K 0.00 % 0.43 % [jbd2/dm-0-8]
267 be/4 admin 0.00 B 48.00 K 0.00 % 0.00 % [kjournald]
17039 be/4 admin 0.00 B 128.00 K 0.00 % 0.00 % httpd -k start

I think this does not give many information. However, I could find out that the problem is due to the logging. Every ten second a new entry is written to the apache log file:

[Sat May 09 23:14:15.822577 2015] [example_hooks:notice] [pid 26475:tid 4147734208] x_monitor()

What does that mean? Is this a serious error? How can I turn off the logging as a work around.

Thanks again
Daniel
 
dagginio a dit:
Hey,

Thanks for your help. I run iotop with the following output.

TID PRIO USER DISK READ DISK WRITE SWAPIN IO> COMMAND
2370 be/3 admin 0.00 B 76.00 K 0.00 % 0.43 % [jbd2/dm-0-8]
267 be/4 admin 0.00 B 48.00 K 0.00 % 0.00 % [kjournald]
17039 be/4 admin 0.00 B 128.00 K 0.00 % 0.00 % httpd -k start

I think this does not give many information. However, I could find out that the problem is due to the logging. Every ten second a new entry is written to the apache log file:

[Sat May 09 23:14:15.822577 2015] [example_hooks:notice] [pid 26475:tid 4147734208] x_monitor()

What does that mean? Is this a serious error? How can I turn off the logging as a work around.

Thanks again
Daniel

have a look inside the httpd.conf within apache webui config, i think you should disable mod_example (not sure) or a mod_hook putting a # in front
click on modify and stop and restart QApache, cant check now...
 
Hey,

I disabled the following line: LoadModule example_hooks_module libexec/mod_example_hooks.so. Now it seems to work. Could you maybe briefly what this module is doing and why it caused the problems. Thanks

I tried to change the port but this did not work out. What do I have to do to change the port and maybe also the root directory where I upload the webpages?

Thanks a lot for all your help!
Daniel
 
to change port modify in http.conf the line "LISTEN" click on modify and restart app

not sure what is this mod adding (you can check it on Apache 2.4.x branch documentation)

to upload your file, simply create a share called "htdocs" ;)
 
I tried this already chaning Listen from 88 to 80. Afterwards the Server did not work anymore. Of course, I disabled the built in webserver to avoid conflicts. I created htdocs share but I would prefer the predefined Web folder since qpkgs are often installed there. Of course I could create a symlink but I thought a more straight forward solution is better.

Daniel
 
hi,

probably a missconfiguration, check if I didnt add a port number behind ServerName or elsewhere (I cant check right now)

for the htdocs, I prefered made a directory create on app installation ( /share/MD0_DATA/htdocs depending your NAS), once user create the share called htdocs within the webui, he will have acces to all files, ( basically create the share will just add a symnlink /share/htdocs pointing to your /share/MD0_DATA/htdocs )
 
I found 5 min to check

i need to update the package, i found some bugs that need to be resolved to use Qapache natively as web server.
I will upgrade to last php version as well..

stay tune ;)
 
Updated with :

PHP 5.6.9
Mod_Python
Mod_wsgy
Mod_mono (Beta)

fixed bug Subversion (mod_svn) (update to 1.8.13)
fixed bug ImageMagick (upgraded to 6.9.1, PECL 3.3.0 )
fixed cgi directory didnt call on right location
 
Is the Mysql module implemented? Because I can't connect to the database :? . (the creadentials are ok, beaucause I can connect with phpMyAdmin with nginx or via shell).

Merci beaucoup

Andrea
 
Hey,

For me localhost did not work but when I changed to 127.0.0.1 everything is running smooth.

Daniel
 
I also tried with the 127.0.0.1 but still doesn't work.. I used this code example to test:
Code:
<?php
        echo mysql_error();

        $connect=mysql_connect("127.0.0.1","username","password") or die("Unable to Connect");
        mysql_select_db("database") or die("Could not open the db");
        $showtablequery="SHOW TABLES FROM database";
        $query_result=mysql_query($showtablequery);
        while($showtablerow = mysql_fetch_array($query_result))
        {
        echo $showtablerow[0]." ";
        }
 ?>


and I always get the "Unable to Connect" error message. It's possible that I should run the mysql server with the option reachable from the network? Or are you running a special mysql server? (not this provided with the Qnap OS)

Thanks in advance

Andrea
 
What is your MySQL server, Nativ one or MariaDB ?

The cross compiled header and libs used for Qapache are MySQL 5.6.20, not sure if there is any inpact
 
I'm using the MariaDB, maybe is the Db version, but I see now on the forum that there are the version 5.6.22. I will try to install this version and retry, I will keep you up-to-date.

Thanks

Andrea
 
QoolBox a dit:
this version of MySQL is untested an may have bug, i made it long time ago for HAL firmware only

ok..how I can update my MySQL server for the legacy version?