Qnap [ Orthanc ] [ 1.11.3 ] DICOM Server

QoolBox

Représentant QNAP
2 Janvier 2014
10 577
165
153
50
France
www.qnap.com
telecharge-6.png

Source : http://www.orthanc-server.com


Download : x64, arm_64


Note :


Web Viewer Plugin embedded
DICOM Web Viewer Plugin embedded
Whole Slide Plugin embedded

config file :

/opt/Orthanc/Configuration.json (restart qpkg between each modification)

default storage : /opt/Orthanc/OrthancStorage

listen on port 8042 (DICOM service : 4242)

About :

Orthanc aims at providing a simple, yet powerful standalone DICOM server. It is designed to improve the DICOM flows in hospitals and to support research about the automated analysis of medical images. Orthanc lets its users focus on the content of the DICOM files, hiding the complexity of the DICOM format and of the DICOM protocol.

Orthanc can turn any computer running Windows, Linux or OS X into a DICOM store (in other words, a mini-PACS system). Its architecture is lightweight and standalone, meaning that no complex database administration is required, nor the installation of third-party dependencies.

What makes Orthanc unique is the fact that it provides a RESTful API. Thanks to this major feature, it is possible to drive Orthanc from any computer language. The DICOM tags of the stored medical images can be downloaded in the JSON file format. Furthermore, standard PNG images can be generated on-the-fly from the DICOM instances by Orthanc.

6-WebViewer.png
 
Dernière édition:
Mdr! :lol:

J'ai pu installer le qpkg sans problèmes, le serveur tourne parfaitement bien

Le seul hic c'est que mon échographe Philips n'arrive pas à se connecter au serveur DICOM sur le port 4242, chose étonnante car cela fonctionnait avec la version windows...

Toutes les autres fonctionnalités sont opérationnelles (serveur HTTP sur le port 8042) et quand je teste le serveur DICOM sur le port 4242 avec un petit programme test, aucun problème. j'ai pu importer la sauvegarde de ma base de données. L'accès au données via le serveur HTTP fonctionne nickel. Cela doit malheureusement venir de mon échographe, car le fichier log de Orthanc ne retrouve pas d'erreur de connexion ou d'authentification... Le log de mon échographe ne me donne pas plus d'informations mais je pense que je n'ai pas tous les détails. Je vais contacter le technicien Philips pour qu'il tente de trouver l'erreur...

Sinon le port fonctionne nickel, un logiciel de lecture DICOM comme Ginkgo CADx par exemple se connecte parfaitement dessus!

Il ne manque pas grand chose pour arriver au résultat que je souhaite!

Encore merci,
 
Oui merci, j'avais déjà commencé à regarder dans les FAQ et le google group d'orthanc.
Je vais regarder ça plus profondément ce soir.

Je ne manquerai pas de retourner la solution, si je la trouve.
 
Merci,

Alors chose très bizarre:
J'ai 2 NAS, un à mon domicile (TS-870 "ultimate" i7 3770T/16G) et l'autre à mon cabinet (TS-253 Pro Celeron J1900/2G).
Je n'arrive pas à connecter localement l'écho à orthanc sur mon TS-253, MAIS j'arrive à connecter à distance l'écho à Orthanc sur mon TS-870. :?
L'échographe semble hors de cause.

DONC
Ça ne doit probablement pas venir du QPKG qui est bien fonctionnel sur mon TS-870.
Soit c'est un problème de configuration sur mon TS-253, soit il y a un nœud réseau qui bloque la connexion (switch merdique ou routeur pourri, au choix)...

Je vais emmener mon TS-253 à la maison et tester une connexion à distance. Si ça marche il y a un problème réseau, sinon c'est mon NAS qui bloque quelque part (quid du blocage de port? Il ne me semble pas qu'il y ait un firewall natif ou une option de blocage des ports sur QTS hormis pour les connexion à distance sur certains protocoles...)

Je vous tiens au courant...
 
peut être une autre application qui tourne sur le port 8042

essaye de voir le log dans /opt/orthanc il doit les générer automatiquement de mémoire...
 
Bonjour,

Merci pour ton support.
Le log d'orthanc reste désespérément vide malgré les tentatives de connexion.

Je n'ai malheureusement pas encore pu tester la connexion à distance. Mais en comparant mes deux NAS, je me demande s'il ne s'agit pas d'une limitation de mémoire. Sur mon TS-870pro j'ai 16Go de RAM, contre 2Go sur mon TS-253 Pro, et 4Go sur mon PC portable Windows sur lequel j'ai effectué des test auparavant...

Je vais profiter de cette déduction pour upgrader ce NAS avec 8 Go de RAM et voir si cela change quelque chose...
Dans tous les cas cela ne lui fera pas de mal...
 
Bonjour,

Je reviens aux nouvelles après réception des barrettes de mémoire.
Malheureusement ce n'est pas la mémoire qui empêche la connexion de l'échographe au NAS...
Je vais essayer une connexion distante pour m'assurer qu'il ne s'agisse pas d'un problème de réseau local.
Si ce n'est toujours pas ça, je crois que je vais devoir tenter de réinitialiser le NAS... :(

Au passage ORTHANC est passé en 1.1.0 :)

A bientôt pour des nouvelles
 
bon bad news pour la 1.1

erreur de compilation, j'ai ouvert un ticket sur le bitbucket du dev

Code:
[  0%] Building CXX object CMakeFiles/CoreLibrary.dir/Core/DicomFormat/DicomMap.cpp.o
/SRC/Orthanc-1.1.0/Core/DicomFormat/DicomMap.cpp: In function ‘uint16_t Orthanc::ReadUnsignedInteger16(const char*)’:
/SRC/Orthanc-1.1.0/Core/DicomFormat/DicomMap.cpp:479: error: ‘le16toh’ was not declared in this scope
/SRC/Orthanc-1.1.0/Core/DicomFormat/DicomMap.cpp: In function ‘uint32_t Orthanc::ReadUnsignedInteger32(const char*)’:
/SRC/Orthanc-1.1.0/Core/DicomFormat/DicomMap.cpp:485: error: ‘le32toh’ was not declared in this scope
make[2]: *** [CMakeFiles/CoreLibrary.dir/Core/DicomFormat/DicomMap.cpp.o] Error 1
make[1]: *** [CMakeFiles/CoreLibrary.dir/all] Error 2
make: *** [all] Error 2


ah mon avis il n'aime pas la version de GCC de mon toolchain
 
Bon je vais devoir changer l'architecture du QPKG

il y a un prob sur x86... sur x64 pas de problème je viens de faire le teste tout se compile bien... (sans doute également sur x31/x31+)
 
Merci beaucoup, je teste ça rapidement.

EDIT: installation sans problème sur mes deux NAS, mais le TS-253 Pro reste de marbre devant la tentative de connexion de l'écho... :?
La suite au prochain épisode...
 
Bonsoir,

Désolé, mais je n'ai pas donné plus de nouvelles ces temps-ci.
J'ai trouvé le problème. Il s'avère que l'appareil d'échographie était configuré avec une DNS manuelle (celle de google, pour des raisons de télémaintenance), ce qui faisait qu'il ne trouvait pas le serveur en local mais qu'il trouvait celui en connexion distante.

Bref, la question n'est pas là.
Je viens de mettre à jour mon TS-253 Pro avec la version beta, pour tester, après bien entendu avoir enregistré ma base de données orthanc. Et depuis la mise à jour, cela ne fonctionne plus... Le qpkg semble tourner, mais le serveur http (port 8042) renvoie sur une page blanche :(

QoolBox, aurais-tu une idée du problème?

Merci par avance