Asustor Modules Apache

Yakatape

Apprenti
27 Juillet 2015
66
0
0
Hello à tous,

Pouvez-vous m'indiquer comment activer les modules apache sous asustor ?
J'ai beau avoir essayé avec a2enmod mais sans succès , je pense qu'ils s'ont effectués des modifs o_O
le module en question est bien présent dans /usr/builtin/etc/apache2/mods-available/ donc je me dis qu'il y a bien moyen de l'activer mais je n'ai pas trouvé comment :rolleyes:

En vous remerciant par avance
 
bon je les ai finalement déplacer (cp) tout simplement dans mods-enabled/

à voir si ça marche
 
Bon j'ai réussi à faire ce que je voulais.., mais je n'ai pu le faire qu'en faisant des modifications à la main des fichier @default et @default-ssl pour faire ce dont j'avais besoin car j'ai l'impression que l'interface graphique asustor ne nous permet pas de déclarer plusieurs vhost apache utilisant le même port avec différent Server Name.

je sais pas si quelqu'un de la communauté re-passera pas ici, mais pensez-vous que cela sera modifier ou implémenter plus tard ?

voici ce que j'ai voulus faire :
Requête http arrivant avec img.mondomaine.com > rediriger vers https://img.mondomaine.com m'affichant le contenu de mon répertoire "Public".
Requête https arrivant avec img.mondomaine.com > Afficher contenu répertoire "Public".

Cela m'évite ainsi de devoir utiliser un port XXXX et ainsi de ne plus à avoir à le renseigner dans l'url étant donner que nous ne pouvons déclarer plusieurs vhost avec le même n° port ce que je comprends pas trop d'ailleurs .. :eek:

voici du coup ma conf apache :

Partie HTTP :
Code:
<VirtualHost _default_:80>
    ServerName localhost
    DocumentRoot "/volume1/Web"
    SSLEngine off

    Alias /.well-known/acme-challenge/ /usr/builtin/etc/certificate/letsencrypt/.well-known/acme-challenge/
        <Directory "/usr/builtin/etc/certificate/letsencrypt/.well-known/acme-challenge/">
            Options FollowSymLinks MultiViews
            AllowOverride None
            Order allow,deny
            Allow from all
        </Directory>
</VirtualHost>
<VirtualHost *:80>
	ServerName img.mondomaine.com
	Redirect permanent / https://img.mondomaine.com
</VirtualHost>

Partie HTTPS :
Code:
<IfModule mod_ssl.c>
<VirtualHost *:443>
        ServerName wehack.mondomaine.com
        DocumentRoot "/volume1/Web"
        SSLEngine on
</VirtualHost>
<VirtualHost *:443>
        ServerName img.mondomaine.com
        DocumentRoot "/volume1/Public"
        ScriptAlias /cgi-bin/ "/volume1/Public/cgi-bin"
        SSLEngine On

        <Directory "/volume1/Public">
        	Options Indexes FollowSymLinks MultiViews
        	AllowOverride All
        	Order Allow,Deny
        	Allow from all
	</Directory>
</VirtualHost>
</IfModule>


Tout en ayant ajouter ceci dans mon apache2.conf évitant l'affichage de certaines info concernant le serveur sur l'index of "Public":
Code:
ServerTokens Prod
ServerSignature Off

Voilou :rolleyes:
 
ah, et pour activer les modules .. il faut simplement faire un ln (lien symbolique) dans le folder mods-enables/ du modules en question présent dans mods-available/

voilou :rolleyes:
 
@Yakatape : un OS NAS n'est pas un linux "complet"
Ton sujet est toutefois très intéressant => je le remonte donc, pour information, à notre équipe R&D
 
oui tout a fais dami1 c'est pour ça que je suis un peu perdu travaillant de plus uniquement sur du centos/redhat sachant que le kernel utilisé par asustor est basé sur du debian (si je dis pas de bêtise ?).