Asustor maj rpm : quelle distribution linux choisir ?

JacquesNAS

Chevalier Jedi
21 Janvier 2016
463
61
28
Bonjour,

je souhaite upgrader le rpm de la lib liblzma.so.5 sur le NAS.

Dans quelle distribution linux faut il piocher ?

Merci d'avance pour votre secours.
 
rpm est normalement un paquet redhat (dont les dérivé peuvent être fedora, opensuse ou encore centos) pour upgrader ton paquet, il faudrait savoir sur quelle base exactement il est installé.

plus d'info ici: https://fr.wikipedia.org/wiki/RPM_Package_Manager
 
Merci coyotus.

Quelle est donc la base du NAS Asustor ?

Où et comment updgrader la library liblzma.so.5 ?

Dami1, si tu nous entends, peux tu faire marcher ton réseau stp ?
 
D'intuition, je dirais quand même CentOS qui est une branche stable supportant ce système de paquet, mais ne possédant pas de NAS ASUSTOR, je ne peux pas te le confirmer.
Si tu as un accès SSH, tu peux peut être regarder avec des commande genre

Code:
uname -a
et
Code:
cat /etc/os-release

Sans garantie que cela donne l'info voulue.
 
Merci coyotus !

alors :

root@monhostname:/etc # ls
Wireless/ docker/ group@ init.d/ issue localtime@ machine-id netconfig passwd@ random-seed script/ skel/ usbip/
default/ exports@ gshadow@ inittab ld.so.cache login.defs mdev.conf network/ ppp/ resolv.conf securetty ssl/ wide-dhcpv6/
dhcp/ exports.d/ hostname inputrc ld.so.conf logrotate.conf mtab@ nsswitch.conf profile rsyslog.conf services sysctl.conf
dhcpd/ fstab hosts iproute2/ ld.so.conf.d/ logrotate.d/ nas.conf@ pam.d/ protocols rsyslog.d/ shadow@ ups/


root@monhostname:/etc # uname -a
Linux monhostname 4.4.24 #2 SMP Fri May 26 15:39:33 CST 2017 x86_64 GNU/Linux
root@monhostname:/etc # which rpm
/bin/rpm
root@monhostname:/etc # rpm -qp
BusyBox v1.19.3 (2017-05-16 18:27:53 CST) multi-call binary.

Usage: rpm -i PACKAGE.rpm; rpm -qp[ildc] PACKAGE.rpm

Manipulate RPM packages

Commands:
-i Install package
-qp Query package
-i Show information
-l List contents
-d List documents
-c List config files



Cette BusyBox v1.19.3 aurait donc un kernel en version 4.4.24 si je comprends.

Il n'y a pas les mêmes options sur la commande /bin/rpm que sur ce que je connais de moins mal en linux à savoir RHEL v6.

Est-ce que ca fait avancer le shimlblick ? Est-ce que je peux mettre un rpm ?
Cette library semble assez importante techniquement parlant et je voudrai être sûr du geste avant de casser ou de corrompre le système du NAS...
 
Le souci c'est que si tu modifie ta lib la question des dépendances peut faire en sorte que certains autre paquet ne fonctionnerons plus ou seront buggé, je pense qu'un dev ASUSTOR devrait répondre, car n'ayant pas de asustor moi même, je ne peux pas te garantir le bon fonctionnement de ton NAS après la mise à jour de ta librairie.