Installation glpi sur N2310

PolyDier

Nouveau membre
Bonjour,
J'ai installer le serveur apache et mysql sur le NAS, et je voudrais mettre les fichiers de glpi sur ce dernier.
J'ai créé un dossier partagé, en public, à la racine du NAS que j'ai appelé glpi et j'y ai glissé les dossiers en question.
en appelant l'url "IP du nas"/glpi/index.php je n'arrive pas a atteindre la page.
Je précise que j'ai démarrer le serveur apache sur le nas.
Ce qui est valable pour glpi l'ai aussi pour n'importe quelle autre application web.

Quelqu'un pourrait il m'aider car je viens juste d’acquérir mon premier nas et je découvre ce nouveau monde.

Merci
 

QoolBox

Grand Maître Jedi
Si tu utilises Apache 2.2.29

crée un partage htdocs et met tes fichiers dedans

sinon je peux te faire un module rapidement.

il sera accessible sur le port 88

;)
 

QoolBox

Grand Maître Jedi
Salut,

Simplement à lancer une autre session apache avec GLPI sur un port custom permettant également de gérer le httpd.conf et https de manière indépendante à la session du module apache

c'est ce que je fais avec toutes les autres webapp (owncloud, pydio, wordpress, ... et j'en passe)

;)
 

PolyDier

Nouveau membre
Cela pourrait être effectivement intéressant.

Je profite de ce forum, j'espère ne pas en abuser, pour voir si il serait possible de créer un module pour OCS Inventory.

Pour ma part j'ai installer la version OCSNG_UNIX_SERVER-2.1.2 sur le N2310, la version tourne mais je n'arrive pas à faire remonter les informations du OCSNG-Windows-Agent-2.1.1 vers le NAS.

Quelqu'un à déjà fait ce genre de manip ?

Merci
 

QoolBox

Grand Maître Jedi
J'ai créer l'agent pour les x86 de Thecus, mais ça ne marche pas terrible.. les infos remontés ne sont que très basique.

pour la partie serveur, il me semble qu'il a besoin du module python (ou perl) d'apache je ne me rappelle plus trop... faudrait que je vérifie si c'est faisable car cela fait longtemps.
 

PolyDier

Nouveau membre
Je ne sais pas si je suis le seul à vouloir utiliser un système automatique de remonté d'information d'inventaire, mais je trouve que celà à l'air vraiment pratique, peut être existe t'il d'autre système aussi performant qu'OCS Inventory;
Pour répondre à ta question, c'est PERL qui est requis. ci-dessous la liste complète des requis pour le serveur pour utiliser OCS

Vous devez vous assurer d'avoir :
Le serveur de base de données MySQL fonctionnant et écoutant sur le port par défaut 3306 avec les communications TCP/IP chargées.
Un serveur web Apache installé et fonctionnant pour le serveur de communication et le serveur d'Administration.
PHP et Perl installés et utilisables par le serveur web Apache pour la console d'administration.
Perl et mod_perl installés et utilisables par le serveur web Apache pour le serveur de communication.
Requis
Apache version 1.3.33 ou supérieure ou Apache version 2.0.46 ou supérieure.
Mod_perl version 1.29 ou supérieure.
Mod_php version 4.3.2 ou supérieure.
PHP version 4.3.2 ou supérieure, avec support ZIP et GD chargé.
PERL version 5.6 ou supérieure.
Module Perl XML::Simple version 2.12 ou supérieure.
Module Perl Compress:Zlib version 1.33 ou supérieure.
Module Perl DBI version 1.40 ou supérieure.
Module Perl DBD::Mysql version 2.9004 ou supérieure.
Module Perl Apache::DBI version 0.93 ou supérieure.
Module Perl Net::IP version 1.21 ou supérieure.
Module Perl XML::Entities
Module Perl SOAP::Lite version O.66 ou supérieure.
MySQL version 4.10 ou supérieure avec moteur InnoDB activé.
Utilitaire Make tel que GNU Make.

A+
 

QoolBox

Grand Maître Jedi
Je jetterai un coup d'oeuil, mais cela nécessitera une mise à jour du module Apache pour ajouter les CPAN à Perl
qui sont de base dans le module Apache

;)
 

QoolBox

Grand Maître Jedi
Je viens de rajouter les CPAN manquant à la version powerpc, également mis à jour la version d'openSSL suite à la nouvelle vulnérabilité

https://www.openssl.org/news/secadv_20141015.txt

et mis à jour PHP 5.6 en 5.6.2

je crois les doigts pour que ça fonctionne avec OCS, je ne suis pas très copain avec Perl

La compilation est en cours, c'est un peu long...
 
Haut Bas