Qnap [HELP] Redirection de port ou quelquechose comme ça...

poupou_gogui

Nouveau membre
9 Septembre 2016
13
0
0
Bonjour les Qnapeurs !

J'ai posé ma question sur le forum anglais, mais sans vouloir flooder, je la pose aussi ici ;) (https://forum.qnap.com/viewtopic.php?f=11&t=125936)

Depuis quelques jours je me bats contre le client VPN... J'ai gagné cette première bataille !...

Mais je me trouve confronté à un autre problème concernant la redirection de port (je pense que ça viens de là, mais je ne suis même pas sur).

J'ai un QNAP TS-251 à jour de la dernière version 4.2
J'utilise Transmission sur le port 53200 et Download Station sur la plage 52199 à 53201 (je sais pas si c'est bon pour Download Station mais je verrais ça par la suite...)
J'ai une box Bouygues sur laquelle j'ai ouvert les ports concernés.
J'utilise le provider NordVPN (qui ne nécessite pas l'ouverture de port de son côté... Tous les ports sont ouverts...)

Le problème c'est que quand j'active le VPN (j'ai testé avec 3 providers différents !...) :
Transmission me dit que le port est fermé
Canyouseeme.org me dit que le port est fermé

Quand je coupe le VPN : Tout est dans le vert... Les ports concernés sont bien ouvert...

Je n'y comprends pas grand chose mais j'ai testé des iptables PREROUTING / FORWARD / POSTROUTING
Mais au delà d'avoir probablement fait des bétises... La fonction PREROUTING ne fonctionne pas sur QNAP...

EDIT

Je viens de découvrir la commande nmap (installée via entware),

voici les résultats quand je fait un nmap sur l'ip locale de mon NAS :
Code:
[~] # nmap 192.168.XX.XX

Starting Nmap 7.12 ( https://nmap.org ) at 2016-09-15 22:19 CEST
Nmap scan report for NASFF3E83 (192.168.XX.XX)
Host is up (0.000027s latency).
Not shown: 986 closed ports
PORT      STATE SERVICE
22/tcp    open  ssh
80/tcp    open  http
139/tcp   open  netbios-ssn
443/tcp   open  https
445/tcp   open  microsoft-ds
548/tcp   open  afp
631/tcp   open  ipp
873/tcp   open  rsync
8080/tcp  open  http-proxy
8081/tcp  open  blackice-icecap
8200/tcp  open  trivnet1
9091/tcp  open  xmltec-xmlmail
49152/tcp open  unknown
49153/tcp open  unknown

Du coup, j'ai testé les ports 49152 et 49153 sur Transmission et sur canyouseeme.org : rien à faire : les ports restent fermés...

Ensuite j'ai fait nmap en spécifiant le port du début (53200)... Ben forcément, il est fermé...
Code:
[~] # nmap 192.168.XX.XX -p U:53200,T:53200

Starting Nmap 7.12 ( https://nmap.org ) at 2016-09-15 22:26 CEST
Nmap scan report for NASFF3E83 (192.168.XX.XX)
Host is up (0.00010s latency).
PORT      STATE  SERVICE
53200/tcp closed unknown

Nmap done: 1 IP address (1 host up) scanned in 0.10 seconds

Auriez-vous un conseil à me donner ou une idée vers où chercher / quoi modifier ?

Merci par avance la communauté !
Greg
 
hello !

as-tu trouvé une solution à ton problème? j'ai EXACTEMENT pareil et je m'arrache les cheveux dessus depuis 3 jours...
 
Hello,

Es-tu sûr que tous les ports NordVPN sont ouverts ? Je trouve cela étrange mais aussi très dangereux... Comment peuvent-ils connaitre les ports ouverts sur ton NAS/Box ?

Sais-tu si NordVPN fait du partage d'adresse IP ? C'est souvent le cas (majoritairement).
 
En effet un port ouvert depuis une liaison VPN c'est pas gagné, comme dit Cachem, il faut surtout que ce soit ouvert coté serveur VPN. Certains le font mais c'est bien dit et il y a des manips à faire. Sinon de toute façon le download en torrent marchera même port fermé, c'est l'upload qui sera plus bridé.
 
Hello, je viens de retomber sur mon post et vos réponses...
Entre temps, je suis passé chez vyprvpn...
Par contre je suis inquiet... Sur vyprvpn (goldenfrog) tous les ports sont ouverts d'office... Je n'y connais pas grand chose (côté serveur, côté client, etc...) En quoi est ce dangereux ? Que puis je faire ?
Merci de vos conseils !

Envoyé de mon ONEPLUS A3003 en utilisant Tapatalk