Qnap [ GitBucket ] [ 4.38.4.0 ] GitHub Clone

QoolBox

Représentant QNAP
2 Janvier 2014
10 577
165
153
50
France
www.qnap.com
20150130003236.png


Source : https://bitbucket.org/


Download : x86, x64, x41, x31 , arm64

https://www.myqnap.org/product/gitbucket/

Note :

create a GitBocket Directory in your share location to store object
listen on port 8668
log with root and password root

[ Dependencies ]

QGit
QJDK8


About :

GitBucket is a GitHub clone powered by Scala which has easy installation and high extensibility.

Feature :

The current version of GitBucket provides a basic features below:

Public / Private Git repository (http and ssh access)
Repository viewer and online file editing
Wiki
Issues / Pull request
Email notification
Simple user and group management with LDAP integration
Plug-in system

gitbucket_issues.png
 
Dernière édition:
petit avertissement remonté sur le forum Qnap, avant de migrer de la 3.13 à la 4.2.1, il faut d'abord passer par la 3.14

je viens de l'ajouter :geek:
 
update 4.3.0

Code:
Emoji support by gitbucket-emoji-plugin
User name suggestion
Add new web APIs and basic authentication support for API access
Root Endpoint
List endpoints
List Branches
Get contents
Get a Reference
List Collaborators
List user repositories
Get a group
List group repositories
Add new extension points
assetsMapping : Supplies resources in plugin classpath as web assets
suggestionProvider : Provides suggestion in the Markdown editing textarea
textDecorator : Decorate text nodes in HTML which is converted from Markdown
 
4.4


Code:
Import a SQL dump file to the database
go get support in private repositories
Sort milestones by due date
apache-sshd has been updated to 1.2.0
 
Bonjour Qoolbox,

D'abord merci pour les mises à jour régulières de l'appli et aussi pour les diverses solutions que vous apportez sur ce forum.

J'ai installé correctement la 4.9.0 et j'ai effectué également le transfert de port du 8668 sur mon routeur SFR.

Et quand je lance l'appli, j'obtiens l'erreur de connexion (ERR_CONNECTION_REFUSED) et pourtant je n'ai ni proxy ni parfeu qui bloque l'accès.

Est-ce qu'il aurait une configuration supplémentaire à faire sur le NAS qui m'a échappée ?

Je vous remercie d'avance.
 
Bonjour,

J'ai le NAS TS-253 Pro et la firmware est : 4.3.2.0050.

Je fais la MAJ de la firmware pour passer à la 4.3.3 pour voir si le problème serait réglé.

Je vous tiens au courant.
 
Pas de changement après la mise à jour de la firmeware(4.3.3.0095 Build 20170216), j'ai toujours l'erreur de connexion quelque soit le navigateur.
 
ethanazieff a dit:
Pas de changement après la mise à jour de la firmeware(4.3.3.0095 Build 20170216), j'ai toujours l'erreur de connexion quelque soit le navigateur.

Bonjour,

J'ai finalement installé GitLab via le container et ça marche très bien.