Qnap [Firmware release] - QTS 4.2.1 Build 20160311 official release for TDS-16489U & TS-X53A series

QoolBox

Représentant QNAP
2 Janvier 2014
10 577
165
153
50
France
www.qnap.com
[Firmware release] - QTS 4.2.1 Build 20160311 official release for TDS-16489U & TS-X53A series


QTS 4.2.1 Build 0311

[Applicable Models]
Code:
TS-x53A series and TDS-16489U

Code:
[Bug Fixes]

This release has corrected the following issues:

- Fixed an issue where changing folder permissions would not take effect if changing the folder permissions from R/W to Read-only via Samba protocol.
- Fixed an issue where the connection would fail during backing up a VM image to an external device.
- Fixed an issue where an error message would appear when performing a RTRR task to backup files from local to remote and placing a folder to the source folder through SAMBA protocol.
- Fixed an issue where the total number of music in the Media Library would be incorrect when adding .cue, .flac, and MP3 files into a folder.
- Fixed an issue where the system would become unresponsive when uploading high-resolution pictures in Photo Station.
- Fixed an issue where an error message would appear after creating a backup job and selecting specific folders in the source and destination folder where the selected folders have a prefix “share” in the folder name.
- Fixed an issue where files in the root folder would become folders after cloning a Snapshot.
- Fixed an issue where the system would show a warning message when linking to an OpenVPN server.
- Fixed an issue where the log file would report incorrect information when swapping HDD locations in a NAS and removing the pool.
- Fixed an issue where the pool expansion operation would fail.
- Fixed an issue where the system would be unable to show a clear indication of the maximum volume size when creating volume with default settings.
- Fixed an issue where the volume resize operation would fail if the file system is not clean.
- Fixed an issue where background tasks would be stuck in a calculation step when uploading files to File Station using Firefox.
- Fixed an issue where the “copy the link” option cannot be selected in download operations when sharing files with share links with the Android browser.
- Fixed an issue where "Compression" in Backup settings would be unable to remain on the edit page when doing iSCSI Storage.
- Fixed an issue where the QTS UI would get stuck on “Network” on a new NAS when migrating data from another NAS that used a complicated DDNS password (containing characters such as !=[].)
- Fixed an issue where Storage Manager would fail to restore a backup image file via CIFS on a NAS without storage pools.
- Fixed an issue where creating a download task by pasting a URL was not available in Download Station (click “+” > “Input URL”) using Internet Explorer.
- Fixed an issue where the “sed: bad option in substitution expression” warning message would appear after using the phrase ”backup” as the Time Machine password and restarting the NAS using the “/etc/init.d/atalk.sh restart” command in Putty.
- Fixed an issue where the NAS would occasionally fail to resolve a DNS name. 
- Fixed an issue where switching between different pages on a shared link would be recognized as an error event and an error log would be generated in System Logs.
- Fixed an issue where users could not add shared folders as media folders in Multimedia Management.  
- Fixed an issue where the shortcuts in Control Panel could not be dragged to the QTS Desktop as shortcut using Internet Explorer 11.


[Enhancement]

- OpenSSL has been updated to 1.0.1r.
 
voici les liens :

Code:
http://download.qnap.com/Storage/TS-X53A/TS-X53A_20160311-4.2.1.zip
http://download.qnap.com/Storage/TS-X89U/TS-X89U_20160311-4.2.1.zip
 
Bonjour,

Faudrait pas oublier les autres modèles pour la 4.2.1 :cry:

En espérant que cela arrive vite.
 
Dans la foulée j'ai aussi eu droit a une maj de virtualization station mais je n'arrive pas a voir le nouveau changelog, il m'affiche celui de fév 2015.. :|
 
Hello,

MAJ faite mais toujours le message après redémarrage du NAS :

Avertissement 2016/03/15 14:51:42 System 127.0.0.1 localhost [Volume DataVol1, Pool 1] The file system is not clean. It is suggested that you go to [Storage Manager] to run "Check File System".

Alors que le Check File ne signale aucun soucis ....
 
IL-MAFIOSO a dit:
Hello,

MAJ faite mais toujours le message après redémarrage du NAS :

Avertissement 2016/03/15 14:51:42 System 127.0.0.1 localhost [Volume DataVol1, Pool 1] The file system is not clean. It is suggested that you go to [Storage Manager] to run "Check File System".

Alors que le Check File ne signale aucun soucis ....


IDEM et ça commence à etre un poil enquiquinant dans le sens que cela apparait toujours au redémarrage et donc il me fait le coup tout le temps pour ne rien trouver comme soucis au final!

si je pouvais eviter cela serait une bonne chose :geek:
 
Y a un truc qui ne doit pas être fermer correctement avant le redémarrage ....
Avant de faire la MAJ, il m'a suggéré de faire un redémarrage car le NAS tournait depuis plusieurs jours ...
Et bing le message....
Après installation firmware, redémarrage et bing à nouveau le message....

Si au moins il pouvait dire ce qui le dérange :geek:
 
effectivement, si le système de fichier réclame d'être vérifié

une application lock le volume au moment du redémarrage (elle ne se coupe pas correctement)

il faudrait identifier cette appli... on avait un soft pour cela il faudraitt que je retrouve le qpkg
 
Ce serait bien de s'y plonger un peu car on est plusieurs de la série x53A à avoir ce soucis . [emoji106]
 
Code:
1. Install in the App Center
2. Reboot NAS or do filesystem check
3. If there was any volume fail to unmount, there will be a log file umountxxxxxxx.log in the Public folder. You can use this log to find the process which locks volume
4. If there was any volume fail to unmount, the package will try to kill the process and unmount again. Therefore you should not see error message in system logs after installing this qpkg.

http://www.positiv-it.fr/QNAP/APP/Qumount_0.2.qpkg
 
Bonjour,

Quelqu'un aurait des infos concernants la QTS 4.2.1? Selon les interviews lors du IT Partners cela devait être dispo. dans les prochains jours?
 
Je crois que l'on a un petit mois de retard du à divers bugs sur les dernières bêtas..
 
Je m'attendais à voir arriver le nouvel App Center tel que celui qui est disponible sur les x53A. J'espère que ça viendra :) !