Asustor Configurer Rustdesk sur son Asustor

merry.benji

Apprenti
2 Mai 2019
62
0
6
Bonjour tout le monde :)

Je reviens vers vous pour avoir des conseille et de l'aide^^.

Je souhaite mettre en place un petit réseau avec Rustdesk de l'extérieur. C'est pour faire des prise en mains sur des pc vers extérieur de mon réseau.

Alors dans un 1er temps j'ai ouvert les port de ma box qui sont les suivant :
21115 TCP
21116 TCP/UDP
21117 TCP
21118 TCP
21119 TCP ouvert

J'ai ensuite installé dans mon asustor l'application portainer et qui la installé en même temps l’application Docker.

J'ai donc créer un utilisateur et suit aller ensuite dans Stack et j'ai fais créer et mis ce code :

Code:
version: '3'

networks:
  rustdesk-net:
    external: false

services:
  hbbs:
    container_name: hbbs
    ports:
      - 21115:21115
      - 21116:21116
      - 21116:21116/udp
      - 21118:21118
    image: rustdesk/rustdesk-server:latest
    command: hbbs -r IP DE MON NAS SUR LE RESEAU:21117
    volumes:
      - ./data:/root
    networks:
      - rustdesk-net
    depends_on:
      - hbbr
    restart: unless-stopped

  hbbr:
    container_name: hbbr
    ports:
      - 21117:21117
      - 21119:21119
    image: rustdesk/rustdesk-server:latest
    command: hbbr
    volumes:
      - ./data:/root
    networks:
      - rustdesk-net
    restart: unless-stopped

Le réseau en interne cela fonctionne sans souci.
Sans oublier la clés pub.

J'ai du coup fait la même chose pour l’extérieur voici le code :

Code:
version: '3'

networks:
  rustdesk-net:
    external: false

services:
  hbbs:
    container_name: hbbs
    ports:
      - 21115:21115
      - 21116:21116
      - 21116:21116/udp
      - 21118:21118
    image: rustdesk/rustdesk-server:latest
    command: hbbs -r IP PUBLIQUE :21117
    volumes:
      - ./data:/root
    networks:
      - rustdesk-net
    depends_on:
      - hbbr
    restart: unless-stopped

  hbbr:
    container_name: hbbr
    ports:
      - 21117:21117
      - 21119:21119
    image: rustdesk/rustdesk-server:latest
    command: hbbr
    volumes:
      - ./data:/root
    networks:
      - rustdesk-net
    restart: unless-stopped

En plus de la cle pub mais la par contre ça ne fonctionne plus.

Le pc à extérieur donc le client, la connexion est en prêt, nous avons mis l'adresse ip Publique et la clés pub. Mais par contre avec le pc en interne il met pas connecté.


Et la je vous avoue que je suis perdu et ne sais plus quoi faire^^.

Par contre si j'utilise un vpn cela fonctionne ce qui est normal puisque je passe par le lan et non par internet.

J'ai donc trouvé un code sur le forum que j'ai du coup essayé que voici :

Code:
version: '3'

networks:
  rustdesk_network:
    name: rustdesk_network
    ipam:
      driver: default
      config:
        - subnet: 172.24.0.0/16
          ip_range: 172.24.0.0/24
          gateway: 172.24.0.1

services:
  hbbs:
    container_name: hbbs
    ports:
      - 21115:21115
      - 21116:21116
      - 21116:21116/udp
      - 21118:21118
    image: rustdesk/rustdesk-server:latest
    command: hbbs -r 192.168.2.203:21117 -k THE_KEY_GENERATED_I_DON_T_REMEMBER_HOW
    volumes:
      - /volume1/Docker/rustdesk/hbbs:/root
    networks:
      - rustdesk_network
    labels:
      - "com.centurylinklabs.watchtower.enable=true"
    depends_on:
      - hbbr
    restart: unless-stopped

  hbbr:
    container_name: hbbr
    ports:
      - 21117:21117
      - 21119:21119
    image: rustdesk/rustdesk-server:latest
    command: hbbr -k THE_KEY_GENERATED_I_DON_T_REMEMBER_HOW
    volumes:
      - /volume1/Docker/rustdesk/hbbr:/root
    labels:
      - "com.centurylinklabs.watchtower.enable=true"
    networks:
      - rustdesk_network
    restart: unless-stopped

Sa me generer des fichier dans mon nas dans le dossier Docker /Rustdesk/hbbr

Mais ça ne fonctionne toujours pas :(

Avez vous une solution ou une idée ?^^

Dans l'attente de vos retour merci à vous :)
 
Dernière édition:
Bonjour tout le monde :)

Je reviens vers vous pour avoir des conseille et de l'aide^^.

Je souhaite mettre en place un petit réseau avec Rustdesk de l'extérieur. C'est pour faire des prise en mains sur des pc vers extérieur de mon réseau.

Alors dans un 1er temps j'ai ouvert les port de ma box qui sont les suivant :
21115 TCP
21116 TCP/UDP
21117 TCP
21118 TCP
21119 TCP ouvert

J'ai ensuite installé dans mon asustor l'application portainer et qui la installé en même temps l’application Docker.

J'ai donc créer un utilisateur et suit aller ensuite dans Stack et j'ai fais créer et mis ce code :

Code:
version: '3'

networks:
  rustdesk-net:
    external: false

services:
  hbbs:
    container_name: hbbs
    ports:
      - 21115:21115
      - 21116:21116
      - 21116:21116/udp
      - 21118:21118
    image: rustdesk/rustdesk-server:latest
    command: hbbs -r IP DE MON NAS SUR LE RESEAU:21117
    volumes:
      - ./data:/root
    networks:
      - rustdesk-net
    depends_on:
      - hbbr
    restart: unless-stopped

  hbbr:
    container_name: hbbr
    ports:
      - 21117:21117
      - 21119:21119
    image: rustdesk/rustdesk-server:latest
    command: hbbr
    volumes:
      - ./data:/root
    networks:
      - rustdesk-net
    restart: unless-stopped

Le réseau en interne cela fonctionne sans souci.
Sans oublier la clés pub.

J'ai du coup fait la même chose pour l’extérieur voici le code :

Code:
version: '3'

networks:
  rustdesk-net:
    external: false

services:
  hbbs:
    container_name: hbbs
    ports:
      - 21115:21115
      - 21116:21116
      - 21116:21116/udp
      - 21118:21118
    image: rustdesk/rustdesk-server:latest
    command: hbbs -r IP PUBLIQUE :21117
    volumes:
      - ./data:/root
    networks:
      - rustdesk-net
    depends_on:
      - hbbr
    restart: unless-stopped

  hbbr:
    container_name: hbbr
    ports:
      - 21117:21117
      - 21119:21119
    image: rustdesk/rustdesk-server:latest
    command: hbbr
    volumes:
      - ./data:/root
    networks:
      - rustdesk-net
    restart: unless-stopped

En plus de la cle pub mais la par contre ça ne fonctionne plus.

Le pc à extérieur donc le client, la connexion est en prêt, nous avons mis l'adresse ip Publique et la clés pub. Mais par contre avec le pc en interne il met pas connecté.


Et la je vous avoue que je suis perdu et ne sais plus quoi faire^^.

Par contre si j'utilise un vpn cela fonctionne ce qui est normal puisque je passe par le lan et non par internet.

J'ai donc trouvé un code sur le forum que j'ai du coup essayé que voici :

Code:
version: '3'

networks:
  rustdesk_network:
    name: rustdesk_network
    ipam:
      driver: default
      config:
        - subnet: 172.24.0.0/16
          ip_range: 172.24.0.0/24
          gateway: 172.24.0.1

services:
  hbbs:
    container_name: hbbs
    ports:
      - 21115:21115
      - 21116:21116
      - 21116:21116/udp
      - 21118:21118
    image: rustdesk/rustdesk-server:latest
    command: hbbs -r 192.168.2.203:21117 -k THE_KEY_GENERATED_I_DON_T_REMEMBER_HOW
    volumes:
      - /volume1/Docker/rustdesk/hbbs:/root
    networks:
      - rustdesk_network
    labels:
      - "com.centurylinklabs.watchtower.enable=true"
    depends_on:
      - hbbr
    restart: unless-stopped

  hbbr:
    container_name: hbbr
    ports:
      - 21117:21117
      - 21119:21119
    image: rustdesk/rustdesk-server:latest
    command: hbbr -k THE_KEY_GENERATED_I_DON_T_REMEMBER_HOW
    volumes:
      - /volume1/Docker/rustdesk/hbbr:/root
    labels:
      - "com.centurylinklabs.watchtower.enable=true"
    networks:
      - rustdesk_network
    restart: unless-stopped

Sa me generer des fichier dans mon nas dans le dossier Docker /Rustdesk/hbbr

Mais ça ne fonctionne toujours pas :(

Avez vous une solution ou une idée ?^^

Dans l'attente de vos retour merci à vous :)
Bonsoir

Le réseau rustdesk_network c'est du bridge, essaies en réseau host pour voir.
Le pare feu sur le nas est il activé pour tout refusé sauf certaines règles ?

Je ne connais pas rustdesk mais ça ressemble à un blocage de firewall ou un port mal dirige (car ça passe bien sous vpn)
Pour les tests uniquement essaies de désactiver pare feu et blocage de listes pour voir si ça passe.
 
Dernière édition:
Bonsoir krononox,

C'est quoi que tu appelle network c'est du bridge ? C'est pour faire des prise en mains à distance sur n'importe quel poste avec le logiciel rustdesk en mode client.

J'ai effectivement bien ouvert tout les port sur mon nas et sur la box les même numéro de port.

Pour le par feu toute Autorise tout connexion entrent est coché et dans l'autre option Desfenseur réseau j'ai tout désactiver (je n'avais que la liste noir d'activer).

Et toujours rien malheureusement :(.

Je suis un peu comme toi pour moi sa viendrai d'un par feu car c'est vraiment étrange^^
 
Bonjour

Il y a plusieurs modes réseau pour docker : host, bridge, macvlan

En essayant avec le mode host tu attaques directement sur la carte et l'ip réseau du nas.
Il faut mettre network_mode: host dans ta stacks au lieu de ta rustesk_networks

C'est juste à titre d'essai car je ne préconise pas ce mode.

Ce qui m'étonne un peu est cette ligne :
command: hbbs -r 192.168.2.203:21117
Car ton réseau est en 172.24.0.0
 
Dernière édition:
Bonjour krononox,

Alors enfaite ce que tu me dit dans mon code " Car ton réseau est en 172.24.0.0"

je l'avais pris dans ce forum pour essayer la configurer qui à été proposer voici le lien :


Sinon j'ai refait le code de ce que rustdesk porpose voici le code à nouveau et j'ai modifier :

rustdesk-net: par network_mode c'est bien ça ?

Voici le code :




Code :

Code:
version: '3'

networks:
  network_mode:
    external: false

services:
  hbbs:
    container_name: hbbs
    ports:
      - 21115:21115
      - 21116:21116
      - 21116:21116/udp
      - 21118:21118
    image: rustdesk/rustdesk-server:latest
    command: hbbs -r rustdesk.example.com:21117
    volumes:
      - ./data:/root
    networks:
      - network_mode
    depends_on:
      - hbbr
    restart: unless-stopped

  hbbr:
    container_name: hbbr
    ports:
      - 21117:21117
      - 21119:21119
    image: rustdesk/rustdesk-server:latest
    command: hbbr
    volumes:
      - ./data:/root
    networks:
      - network_mode
    restart: unless-stopped
 
Bonsoir

Tu as 2 possibilités :

- le mettre directement dans les services en mettant par exemple

YAML:
version: "3"

services:

  myservice:

    image: myservice:latest

    network_mode: host

- en utilisant un network attaché à l'host que tu appelles dans chaque service comme par exemple

version: "3"
services:
myservice:
image: myservice:latest
networks:
- host

networks:
host:
external: true


Ça donnerait par exemple dans le 1e cas

version: '3'

services:
hbbs:
container_name: hbbs
ports:
- 21115:21115
- 21116:21116
- 21116:21116/udp
- 21118:21118
image: rustdesk/rustdesk-server:latest
command: hbbs -r rustdesk.example.com:21117
volumes:
- ./data:/root
depends_on:
- hbbr
restart: unless-stopped
network_mode: host

hbbr:
container_name: hbbr
ports:
- 21117:21117
- 21119:21119
image: rustdesk/rustdesk-server:latest
command: hbbr
volumes:
- ./data:/root
restart: unless-stopped
network_mode: host

Désolé pour l'indentation mai je suis actuellement sur smartphone 😉

Après je pense que tu dois remplacé rustdesk.example.com par ton ip de nas.

Si ça ne fonctionne pas je peux essayer d'installer pour voir mais je ne pourrais le faire que courant de semaine prochaine. Peut être que @MilesTEG peut t'apporter son aide il a l'air de connaître rustdesk
 
Dernière édition:
Salutations 👋🏻
Je suis cette discussion d’un peu loin mais maintenant qu’on me demande de l’aide va falloir que je me creuse les méninges un peu pour me rappeler comment j’ai mis en service le rustdesk…
C’est un peu complexe , trop à mon goût , pour un résultat satisfaisant sans plus.

@krononox : veux-tu bien mettre des balises de code quand tu postes du code car l’indentation a souvent de l’importance (comme en YAML) mais permet aussi de mieux lire le code.
Va voir ici : https://www.forum-nas.fr/threads/wi...ilisation-du-forum-des-nas.17438/#post-130118


Sinon quand je serais sur mon ordi je regarderai ce que j’ai mis comme trucs dans le docker-compose.
 
Bonjour krononox :)

Merci pour votre retour :)

Je viens de faire un teste et visiblement toujours pareil sa bloque en interne.

Vers l’extérieur quand je met mon adresse ip Publique il me dit prêt à se connecter il le trouve, mais quand je lance rustdesk sur mon pc en interne et que je lui donne la même adresse de l'autre machine Ip Publique et la cles PUB il me dit pas connecté pas prêt....

Voici le code que j'ai rentrer dans mon Stacks :


Code:
version: '3'

services:
  hbbs:
    container_name: hbbs
    ports:
      - 21115:21115
      - 21116:21116
      - 21116:21116/udp
      - 21118:21118
    image: rustdesk/rustdesk-server:latest
    command: hbbs -r IP PUBLIQUE:21117
    volumes:
      - ./data:/root
    depends_on:
      - hbbr
    restart: unless-stopped
    network_mode: host

  hbbr:
    container_name: hbbr
    ports:
      - 21117:21117
      - 21119:21119
    image: rustdesk/rustdesk-server:latest
    command: hbbr
    volumes:
      - ./data:/root

    restart: unless-stopped
    network_mode: host

Voici quelque capture d'écran dans docker^^
Je tes pris aussi une capture d'ecran pour le nas et de la box pour les ports


Merci à vous deux c'est vraiment gentil :)

Il y a pas d'urgence absolu faite quand vous pouvez il y a pas de souci :)

 

Pièces jointes

  • 1.JPG
    1.JPG
    74 KB · Affichages: 3
  • 6.JPG
    6.JPG
    82.1 KB · Affichages: 3
  • 5.JPG
    5.JPG
    85.8 KB · Affichages: 2
  • 4.JPG
    4.JPG
    98.6 KB · Affichages: 2
  • 3.JPG
    3.JPG
    119.6 KB · Affichages: 2
  • 2.JPG
    2.JPG
    122.2 KB · Affichages: 3
  • 7.JPG
    7.JPG
    70.3 KB · Affichages: 2
Dernière édition:
Re coucou je viens vous donner des nouvelle.

J'ai réussie avec ce code à voir des fichier qui on fini par s'installer dans mon nas dans le dossier HBBS mais par contre l'autre reste toujours vide et il refuse toujours de se connecter avec ma connexion interne.

Voici se qui se trouve dans mon dossier HBBS.

Et voici le code :

Code:
version: '3'

networks:
  rustdesk_network:
    name: rustdesk_network
services:
  hbbs:
    container_name: hbbs
    ports:
      - 21115:21115
      - 21116:21116
      - 21116:21116/udp
      - 21118:21118
    image: rustdesk/rustdesk-server:latest
    command: hbbs -r IP PUBLIC:21117 -k WnuJZa7BOddgdfgdfgfgdfgfgdE=
    volumes:
      - /volume1/Docker/rustdesk/hbbs:/root
    networks:
      - rustdesk_network
    labels:
      - "com.centurylinklabs.watchtower.enable=true"
    depends_on:
      - hbbr
    restart: unless-stopped

  hbbr:
    container_name: hbbr
    ports:
      - 21117:21117
      - 21119:21119
    image: rustdesk/rustdesk-server:latest
    command: hbbr -k WnuJZa7BOddgdfgdfgfgdfgfgdE=
    volumes:
      - /volume1/Docker/rustdesk/hbbr:/root
    labels:
      - "com.centurylinklabs.watchtower.enable=true"
    networks:
      - rustdesk_network
    restart: unless-stopped
 

Pièces jointes

  • 2.JPG
    2.JPG
    56.6 KB · Affichages: 2
Dernière édition:
Re coucou je viens vous donner des nouvelle.

J'ai réussie avec ce code à voir des fichier qui on fini par s'installer dans mon nas dans le dossier HBBS mais par contre l'autre reste toujours vide et il refuse toujours de se connecter avec ma connexion interne.

Voici se qui se trouve dans mon dossier HBBS.

Et voici le code :

Code:
version: '3'

networks:
  rustdesk_network:
    name: rustdesk_network
services:
  hbbs:
    container_name: hbbs
    ports:
      - 21115:21115
      - 21116:21116
      - 21116:21116/udp
      - 21118:21118
    image: rustdesk/rustdesk-server:latest
    command: hbbs -r IP PUBLIC:21117 -k WnuJZa7BOddgdfgdfgfgdfgfgdE=
    volumes:
      - /volume1/Docker/rustdesk/hbbs:/root
    networks:
      - rustdesk_network
    labels:
      - "com.centurylinklabs.watchtower.enable=true"
    depends_on:
      - hbbr
    restart: unless-stopped

  hbbr:
    container_name: hbbr
    ports:
      - 21117:21117
      - 21119:21119
    image: rustdesk/rustdesk-server:latest
    command: hbbr -k WnuJZa7BOddgdfgdfgfgdfgfgdE=
    volumes:
      - /volume1/Docker/rustdesk/hbbr:/root
    labels:
      - "com.centurylinklabs.watchtower.enable=true"
    networks:
      - rustdesk_network
    restart: unless-stopped
Bonsoir

Alors j'ai commencé à tester et je dois dire que je suis dans le même cas que toi !

J'ai essayé plusieurs stacks en mode réseau host, bridge, macvlan, un mélange de macvlan et bridge entre hbbr et hbbs mais rien n'y fait. De plus il me prend bien le server relay que j'indique, le poste est visible et prise en main OK. Mais si je paramètre le server ID, la je n'ai plus rien 🤔 j'ai même essayé l'image s6 mais idem.

Par contre n'affiches pas ta clé privé.
Lors du 1e lancement, le container crée dans hbbs/data 2 fichiers id_ed25519.pub et id_ed25519 (ta clé) tu les copies colles dans hbbr/data.
Pour les commandes mets plutôt :
command: hbbs -r IP PUBLIC:21117 -k _
Le -k _ indique qu'il exige une clé et il va venir les rechercher dans les fichiers générés.

D'après mes recherches rapides il y a des soucis de Nat en auto hébergé (il faut faire du Nat loopback pour le réseau interne) , beaucoup passent pas des vps.
Tu peux éventuellement essayer Oracle free cloud qui offre 2 vps gratuits (il faut créer un compte et donner sa cb mais ils ne débitent pas) et faire l'installation sur 1 des 2 vps.

Sur le papier la mise en place a l'air simple mais dans la pratique...
 
Bonjour krononox :)

T’inquiète pas l cles Pub qui s'affiche n'est pas la bonne ;).

Tu as tout compris pour le souci que je rencontre, j'ai également lu de mon côté qui fallait que les deux fichier d_ed25519.pub et id_ed25519 (ta clé)soit dans le dossier HBBR mais cela ne change rien.

Ensuite pour infos (car je n'arrête pas de travailler dessus depuis vendredi):ROFLMAO::ROFLMAO::ROFLMAO:

Attention dans le code comme tu dit krononox, si on rajoute la cle -k cles PUB dans les commande HBBS ET HBBR le chiffrement n'est plus chiffré donc en terme de protection pas top du tout.

1719380429206.png

Mais par contre si on garde le même code et que l'on enlève juste les les pub dans les command et bien le chiffrement et bien chiffré.

1719380465179.png

Autre chose aussi que j'ai remarqué "car j'ai travaillé cet nuit encore un peu dessus", notre asustor nous proposer gratuitement un service DNS "qui est activé de mon côté" j'ai donc tenté de mettre mon adresse DNS de chez asustor et figuré vous que ça fonctionne.

Mais on retombe dans le même souci, ça fonctionne en externe et si on veux paramétrer en interne, le serveur ne le trouve pas. Si je met mon VPN ça fonctionne sans souci.

Je suis d'accord avec pour le souci en interne, je suis en train de travailler dessus avec ma livebox orange mais pour le moment ça ne fonctionne toujours pas. Tu as une idée toi ou MilesTEG ?

Car utiliser un VPN à chaque fois pas cool puis en plus tout dépent de la bande passante du VPN aussi j'aurai préférer y avoir accès direct avec ma connexion^^
 
Bonjour

Pour la commande oui il ne faut pas indiquer la clé mais mettre -k _
Pour être franc j'ai juste essayé mais je ne me connecte qu'en vpn sur mon réseau 😂
Personnellement j'essaierais de l'installer sur un vps, mais je t'avoues que je ne suis pas trop fan de rustdesk. Je ne pourrais pas t'aider sur ce coup.
Par conte si tu persévères et trouve la solution n'hésites pas à la partager ça intéressera d'autres personnes 😉
 
Dernière édition:
Re Bonjour krononox,

ah oui j'ai pas essayé sans le code pub je vais essayer ;)

Par contre pour le VPN je suis en train de penser je peux pas en mettre un sur mon Nas pour me connecter dessus ?
 
Désolé je poste un 2èmes message juste pour vous dire que si j'utilise AdGuard Home pour configurer mon DNS pour faire un système Nat loopback vous pensez que ça peux fonctionner ?

J'ai également trouvé cet article :


Je pense que ça peux fonctionner je les installé sur mon nas actuellement.

Sauf qui dit qu'il faut configurer les DNS sur la box de chez orange je veux bien mais je met quoi comme adresse ?

Vous pouvez me guider si vous avez déjà fait s"il vous plaît ? ^^
 
Bonjour. Est-il prévu par l'équipe Asustor de mettre en oeuvre l'app rustdesk pour tous ? Ce serait génial ! Merci aux membres de cette communauté.