Qnap Antivirus : plus de mise à jour

plemo

Padawan
Bon étant donné que je n'ai jamais de chance, ça ne fonctionne pas du premier coup chez moi comme d’habitude ... :cry:

J'ai suivi les étapes à la lettre, j'ai eu un certain nombre de lignes jaunes de Malware Remover, comme quoi il avait supprimé de nombreuses infections je pense.

Redémarrage et la ... non seulement, en faisant "vérifier les mises à jour" je reçois toujours le meme message "impossible de mettre à jour le prologiciel......." mais en +, j'ai une notification à chaque redémarrage qui me dit que j'ai des mises à jour dispos dans l'app center et HD Station, alors que comme on le voit sur les captures, je n'ai pas de mises à jour ...

Help :cry:


 

Alexyber

Padawan
Bonjour à tous,

je viens de mettre en fonctionnement mon nouveau NAS TS453B, et apres migration de mes disques dur, j'ai EXACTEMENT les memes problemes :
- plus de mise a jour de firmware
- plus d'acces aux applications dans le app center (seulement celles en local)
- et mise a jour des données antivirus impossible ==> c'est ca qui me l'a fait detecte puisque ca me remonte une erreur au demarrage.

J'etais donc heureux lorsque j'ai vu l'ensemble des posts sur le sujet.....
Oui mais... ca ne marche pas :rolleyes: :( :-|

Quand je tape la fameuse commande sous putty en SSH : curl https://download.qnap.com/Storage/tsd/utility/derek-be-gone.sh | sh
J'obtiens :
curl: (7) Couldn't connect to server

Une idée ? et surtout... un coup de main ?
Merci!
alexis
 

Alexyber

Padawan
C'est ce que jai pense au début, car ça ressemblait à ça... Et que javais aussi une ou 2 erreurs qui faisaient penser à ça (notamment heure pas bonne qui se met pas à jour).

Sauf que jai réussi à mettre l heure a jour en manuel mais via la serveur ntp.
Et puis après jai vu ce thread et je me suis dit "Je vais tenter" ;)

Une piste ? Qq chose a vérifier ?

Merci !
Ps : et encore merci pour le SAV, trop content du nouveau nas ;)
Alexis
 

QoolBox

Représentant QNAP
mmmm bizarre

essaye d'installer le package malware remover manuellement

https://download.qnap.com/QPKG/MalwareRemover_3.4.1_20190125_182348.zip

dézipper et installer le .qpkg manuellement dans l'AppCenter en cliquant sur [+] en haut a droite

mais si curl n'arrive pas a se connecter.. soit le NAS ne resoud pas les noms (ou un problème sur le serveur qnap)
 

Alexyber

Padawan
J'ai déjà installé le malware remover 3.4.1.
Je l ai fait manuellement en le téléchargeant sur site qnap.
Ça a marché.
Je l ai fait tourner et il n a rien trouvé.

Ensuite jai essayer daller directement sur site qnap depuis mon pc : ça marche jai pu télécharger le fichier de commande et "derek-be-gone", donc le serveur a l air de marcher.

Je me suis dit que j allais le mettre sur le NAS pour le lancer en local.... sauf que jai pas réussi à trouver ou le mettre dans le NAS pour le voir dans l arborescence du ssh... possible de me dire ?
Mais bon je ne suis pas sûr que ce soit ça le problème du coup.
 

Alexyber

Padawan
Ok mais je le suis mal expliqué : jai mis le fichier derek-be-gone.sh sur mon NAS.
Pour le lancer en ssh sur putty depuis le fichier en local sur le NAS plutôt que sur le site de qnap.
Mais ensuite, dans putty quand je me promène dans l arborescence du disque, je trouve pas le fichier !
Je fais comment pour aller dans mes fichiers depuis putty ?

Mais bon... surtout... est ce que cest ca le soucis ?
 

Alexyber

Padawan
Merci, j'ai fait ca.
La commande a eu l'air de fonctionner. En tout cas je n'ai pas eu d'erreur, mais quasiment instantanement l'invite de commande reapparait.
Par contre, j'ai redemarre le NAS et... il y avait toujours les memes problemes !

Comme suggéré : je suis allé voir du coté des paramètres réseau (effectivement on dirait qu'il n'avait pas accès à internet).

Je suis allé dans les paramètre reseau : reseau / interfaces
Et apparemment, aucune passerelle n'était sélectionnée !
J'ai sélectionné le port ethernet branché au réseau et... c'est bon !

Merci pour le support sans faille pour tous mes petits tracas !! :-D
 

Chon

Chevalier Jedi
Bonjour à tous,

Petit déterrage car j'ai le même souci, la base virale de mon antivirus ne se met plus à jour depuis le 01/03 en automatique comme en manuel. Malware Remover est bien installé et fonctionnel.
Stéphane, la solution donnée > ICI < est-elle toujours d'actualité ?
 

QoolBox

Représentant QNAP
pour info :

À partir de mars 21, le serveur ClamAV requiert un binaire plus récent pour la mise à jour des définitions de virus. Pour cette raison, les modèles EOL ne seront pas en mesure d'effectuer la mise à jour automatique.

Cela affecte les NAS avec une version de firmware 4.3.6 ou plus ancienne, avec une version de ClamAV antérieure à la version 0.102.

image-1615186988850.png
 

Chon

Chevalier Jedi
Merci Stéphane.
Mon FirmWare est en 4.3.4 et je ne sais pas où trouver l'info pour la version de l'Antivirus mais je suis à l'évidence dans le cas de figure que tu décris.
Concrètement, ça veut dire quoi pour moi à partir du 21/03 ? Je n'ai plus d'antivirus ? Les MàJ seront forcément manuelles ?
 

QoolBox

Représentant QNAP
plus de mise a jour lié à la version seul les firmware 4.5.x auront la maj...
la mise a jour manuel .. j'ai pas testé mais je pense que c'est idem
 

Chon

Chevalier Jedi
Salut à tous,
QoolBox a dit:
plus de mise a jour lié à la version seul les firmware 4.5.x auront la maj...
Aurions-nous là un bel exemple de l'obsolescence programmée selon QNAP ? :eek:
Autant je peux comprendre que des outils nouveaux ne puissent pas être intégrés dans des NAS anciens pour des raisons de puissance, RAM, incompatibilité avec l'OS installé..., autant, pousser un appareil parfaitement fonctionnel au rebut en jouant sur la sécurité, je trouve ça plutôt lamentable. Et bien évidemment, si je n'avais pas posé la question ici, je n'en n'aurais sans doute jamais été informé par QNAP.
Hum, que j'aime ces façons de procéder ! :evil:
Les concurrents font-ils de même ?
 

QoolBox

Représentant QNAP
rappelle moi quel âge il a ton NAS ? :lol:

voir si on peut appeler cela de l'obsolescence programmé...

c'est simple tu regardes le numéro de série ...

Q20xxxxxxx = 2020
Q13xxxxxxx = 2013

après l'antivirus clamav dépend bien entendu de clamav... donc s'il change la façon dont est updaté leur binaire
vu qu'il fait parti du firmware ... bah c'est mort tant que le firmware n'est pas updaté...

j'ai déjà demandé à la R&D de viré l'antivirus du firmware est en faire un application Appcenter à part
1 - ca ferait de la place sur la LUN firmware pour d'autre fonctionnalités
2 - ca serait plus facile à gérer

je n'ai jamais installé d'antivirus sur mes NAS, estimant qu'un antivirus payant comme ESET sur mon poste de travail fait beaucoup mieux le boulot qu'un antivirus open source..
et comme je le dis souvent l'intérêt d'un antivirus sur un NAS et si seulement tu reçois des données de source inconnu (par FTP par exemple) et si tu aimes voir ton NAS travailler à longueur de temps (iops) et bouffer du processus mémoire et CPU...

:twisted: :twisted: :twisted: :twisted:
 

Chon

Chevalier Jedi
Merci Stéphane d'avoir pris le temps de cette longue explication.

QoolBox a dit:
rappelle moi quel âge il a ton NAS ? :lol:
voir si on peut appeler cela de l'obsolescence programmé...
C'est exactement ce que je veux dire, on parle là d'une période de 7 ans qui en temps informatique revient à parler de préhistoire et donc, oui, du matériel dont on prévoit le rebut d'ici 5 à 7 ans, j'appelle ça de l'obsolescence programmée. Ceci n'est pas propre à QNAP bien sûr, c'est le monde merveilleux dans lequel nous vivons.
Nous en avons un autre bel exemple > ICI < donné par EVOTk à propos de batteries d'onduleur.

QoolBox a dit:
après l'antivirus clamav dépend bien entendu de clamav... donc s'il change la façon dont est updaté leur binaire
vu qu'il fait parti du firmware ... bah c'est mort tant que le firmware n'est pas updaté...
j'ai déjà demandé à la R&D de viré l'antivirus du firmware est en faire un application Appcenter à part
1 - ca ferait de la place sur la LUN firmware pour d'autre fonctionnalités
2 - ca serait plus facile à gérer
Je comprends mieux le problème et ne peux être que d'accord avec toi.

QoolBox a dit:
je n'ai jamais installé d'antivirus sur mes NAS, estimant qu'un antivirus payant comme ESET sur mon poste de travail fait beaucoup mieux le boulot qu'un antivirus open source..
et comme je le dis souvent l'intérêt d'un antivirus sur un NAS et si seulement tu reçois des données de source inconnu (par FTP par exemple) et si tu aimes voir ton NAS travailler à longueur de temps (iops) et bouffer du processus mémoire et CPU...
Très intéressant. J'ai donc désactivé l'AV.
Du coup, un peu HS, à propos de sécurité, je crois me rappeler avoir lu je ne sais plus dans quel sujet que contrairement à ce qui est préconisé généralement en terme de sécu, tu déconseilles de désactiver le user "admin". Si je comprends l'importance du profil admin pour la gestion du NAS, qu'en est-il de la sécurité et des attaques récurrentes sur le nom admin ?
 

cc66

Nouveau membre
j'ai aussi le même problème avec l'antivirus depuis début mars . je l'arrête donc.

En ce qui concerne l'admin qu'il est impératif de garder, c'est vrai que c'est un peu surprenant.

Mais quand je pensais que c'était plus sécure d'avoir un 'nomperso' plutôt qu' 'admin' , quelqu'un m'a fait remarquer qu'il suffisait de créer pour 'admin' un plus long mot de passe comprenant l'association d'un nomperso + un mot de passe pour retrouver le même degré de sécurité vis à vis de la brute force que si il n'y avait seulement "mot de passe" pour un nom perso.

(mais je ne sais pas si je suis bien clair ? : nomperso et motdepasse n'est pas plus sécuritaire que admin+ nompersomotdepasse vis a vis d'une attaque brute force)
 
Haut Bas