Extinction inopiné du NAS

Discussion sur le paramétrage du NAS
zestef
Messages : 7
Enregistré le : 12 juin 2018

Extinction inopiné du NAS

Message par zestef » 12 juin 2018 22:12

Bonjour à tous,

Je viens vers vous pour vous partager un problème relativement gênant que je rencontre avec mon NAS QNAP TVS-EC1080 : Il s'éteint de manière brutale et complètement aléatoire.
Je vais essayer d'être synthétique :

Matériel concerné :
- NAS QNAP TVS-EC1080
- 8 Go de Mémoire (auparavant j'étais passé à 16Go, mais j'ai supprimé le module rajouté pour être certain que ce n'était pas une source de pb).
- 10 Disque de 8To (9 Seagate / 1 WD) en RAID 5
- Cache SSD 256Go Samsung Evo en MSata
- Onduleur Non Managé (auparavant managé via USB mais débranché depuis pour être certain que ce n'était pas une source de pb).
- Connexion Réseau 1GB via Switch Dlink (auparavant connecté via une agrégation de 4 liens 1GB mais désactivé pou être certain que ce n'était pas une source de pb).

Utilisation du NAS
- Plex Media Server
- Serveur de Fichier Classique (SMB)
- Sollicitation limité (pas plus de 2 clients simultané)
- Auparavant j'utilisais plus de solution (Container Station, ...) mais j'ai abandonné vu l'instabilité du NAS.

Problème Rencontré :
- Le NAS s'éteint de manière totalement aléatoire avec le message suivant au redémarrage : The system was not shut down properly last time.
- Aucune information sur l'initiation du processus d'extinction dans le system log

Occurrence :
- Aléatoire sur l'année 2017 : 3 fois entre mai et octobre 2017 -> Situation presque acceptable.
- Forte augmentation depuis avril 2018 : 24 Fois depuis le 9 avril 2018 -> Soit prêt de 1 arrêt tous les 2 jours :-x

Conséquences :
- Resync Régulier du Raid 5
- Perte totale d'un disque (remplacement effectué) :-?
- NAS quasi inutilisable... :evil:

Solutions déjà appliquées :
- Stabilité de la ligne électrique : aucune coupure, j'ai d'autres équipements branché sur l'onduleur qui ne subissent pas d'arrêt.
- Suppression de l’agrégation de lien network : passage de 4 cartes 1GB agrégé vers 1 lien 1GB simple (IP Fixe)
- Suppression du management de l'onduleur via USB.
- Suppression du module mémoire rajouté (retour de 16 Go à 8 Go).
- Rollback vers un firmware plus ancien et réputé provoquant le problème : 4.3.4.0486 (cf lien plus bas pour le rationnel).
- Rollback vers un firmware encore plus ancien : 4.3.3.0396
- Désactivation du SPLICE lié à SAMBA (cf lien plus bas pour le rationnel). : /sbin/setcfg Samba SPLICE 0
- Ouverture d'un incident chez QNAP en octobre 2017 sur lequel je n'ai pas trop insisté (nous avions retiré le module mémoire supplémentaire à l'époque).

- Le point semble être connu par le support mais non solutionné (cf. lien plus bas)
Une partie de ces solutions ont été trouvée en suivant les 2 sujets suivants :
https://www.reddit.com/r/qnap/comments/ ... ting_down/
https://forum.qnap.com/viewtopic.php?f= ... 2568098f10

Mais à ce jour aucun résultat probants dans l'application de ces solutions

Solution non encore appliquée :
- Rollback vers un firmware encore encore plus ancien : 4.2.x
- Kill du process du PIC Daemon qui contrôle le reset/power button (déjà essayé mais impossible de trouver la bonne manière).
- Passage par la fenêtre et remplacement par une marque tiers (mets ton idée ici :mrgreen: )

Une idée pour me soutenir moralement et techniquement ? :lol:

Merci de m'avoir lu ! (ça fait un peu pavé...)

A+
Stéphane

Avatar du membre
Gravitys
Chevalier Jedi
Messages : 321
Enregistré le : 27 août 2015

Re: Extinction inopiné du NAS

Message par Gravitys » 13 juin 2018 00:12

Ne lache pas le support tant que le pb n'est pas résolu...
TVS-671 I5/16Go - 4x4To Seagate NAS / 512Gb SSD
QTS 4.3.5.0722 build 20181007
HDD Backup : USB 8To WD - Back UPS Pro 900Va

Avatar du membre
FX Cachem
Site Admin
Messages : 9274
Enregistré le : 08 décembre 2013
Professionnel : Non
Localisation : Paris
Contact :

Re: Extinction inopiné du NAS

Message par FX Cachem » 13 juin 2018 11:59

Effectivement, tu as bien fait d'ouvrir un ticket au support QNAP qui passe très souvent sur le forum ;)

Ensuite, on a déjà eu le cas plusieurs fois : l'onduleur ou la RAM. Pour la RAM, tu as remis celle d'origine ce qui est une bonne idée pour trouver la source de ton souci. Je mettrai un billet sur l'onduleur, pas assez puissant pour le NAS. Ton installation électrique semble stable chez toi, je te conseille de brancher le NAS directement sur ta prise électrique avec aucun autre élément. Tu pourrais avoir une bonne surprise. Tu vas vite voir si c'est ça ou non.

Après, les raisons peuvent être nombreuses y compris la carte mère, mais avant d'en arriver là... explorons les autres pistes ;)
Blogueur sur Cachem et administrateur du Forum des NAS
NAS : Synology DS412+ | QNAP TS-470 Pro | ASUSTOR AS-302T

zestef
Messages : 7
Enregistré le : 12 juin 2018

Re: Extinction inopiné du NAS

Message par zestef » 13 juin 2018 21:24

Merci pour vos suggestions et le soutien moral :mrgreen:

- Barrette mémoire : oui j'ai remis celle d'origine depuis très longtemps (plus de 9 mois) mais je constate toujours le même comportement donc ce n'est pas l'origine du problème.

- Branchement direct sur le réseau électrique au lieu de l'onduleur : très bonne idée merci de la suggestion, j'ai fait le nécessaire ce soir, je vais surveiller le comportement sur les prochains jours.

- Incident Support QNAP : l'incident que j'avais ouvert en octobre 2017 avait été fermé suite à la suppression des barettes mémoires supplémentaires, le problème c'est quand même reproduit de nombreuses fois depuis. Si pas d'amélioration ll va donc falloir que je ré-ouvre un incident par contre j'ai clairement peur de de me faire "rembarrer" car j'ai une partie de mes disques (3 sur 10) qui ne font pas partie des disques supportés et quand je vois le thread reddit ou le support à gentiment remballer les gens avec des configurations "non supporté" au niveau HDD.

Dans tous les cas je vous tiens informé !

Merci.

Stéphane.

Avatar du membre
FX Cachem
Site Admin
Messages : 9274
Enregistré le : 08 décembre 2013
Professionnel : Non
Localisation : Paris
Contact :

Re: Extinction inopiné du NAS

Message par FX Cachem » 13 juin 2018 21:45

zestef a écrit :
13 juin 2018 21:24
Incident Support QNAP : l'incident que j'avais ouvert en octobre 2017 avait été fermé suite à la suppression des barettes mémoires supplémentaires, le problème c'est quand même reproduit de nombreuses fois depuis. Si pas d'amélioration ll va donc falloir que je ré-ouvre un incident par contre j'ai clairement peur de de me faire "rembarrer" car j'ai une partie de mes disques (3 sur 10) qui ne font pas partie des disques supportés et quand je vois le thread reddit ou le support à gentiment remballer les gens avec des configurations "non supporté" au niveau HDD.
On te mettra en lien avec Qoolbox sur le forum (Stéphane du support QNAP) mais il faudra auparavant ouvrir un ticket.
zestef a écrit :
13 juin 2018 21:24
Branchement direct sur le réseau électrique au lieu de l'onduleur : très bonne idée merci de la suggestion, j'ai fait le nécessaire ce soir, je vais surveiller le comportement sur les prochains jours.
Tiens nous au courant... au bout d'une semaine, on devrait en savoir un peu plus ;)
Blogueur sur Cachem et administrateur du Forum des NAS
NAS : Synology DS412+ | QNAP TS-470 Pro | ASUSTOR AS-302T

zestef
Messages : 7
Enregistré le : 12 juin 2018

Re: Extinction inopiné du NAS

Message par zestef » 15 juin 2018 14:13

Hello à tous,

Bon bad news malgré le branchement du NAS sans passer par l'onduleur de nouveau le même symptôme avec moins de 48h d'uptime :(

Avant d'ouvrir un call/incident chez QNAP, pensez-vous qu'il soit pertinent d'essayer un downgrade en 4.2 (j'ai le symptôme en 4.3.3 et en 4.3.4) ? ou de mettre à jour dans le dernie firmware disponible (même symptôme aussi).

Pour rappel je suis dans la configuration la plus "light" possible :
- Pas d'extension mémoire
- Pas d'aggrégation réseau
- Pas d'onduleur
- Aucune application active à l'exception du serveur Plex
- Aucune périphérique connecté

Merci !

Stéphane.

Avatar du membre
FX Cachem
Site Admin
Messages : 9274
Enregistré le : 08 décembre 2013
Professionnel : Non
Localisation : Paris
Contact :

Re: Extinction inopiné du NAS

Message par FX Cachem » 15 juin 2018 19:18

zestef a écrit :
15 juin 2018 14:13
pensez-vous qu'il soit pertinent d'essayer un downgrade en 4.2
Je ne pense pas... Ouvre un ticket au plus vite https://helpdesk.qnap.com/index.php? choisis Français en haut à droite ;)
Blogueur sur Cachem et administrateur du Forum des NAS
NAS : Synology DS412+ | QNAP TS-470 Pro | ASUSTOR AS-302T

zestef
Messages : 7
Enregistré le : 12 juin 2018

Re: Extinction inopiné du NAS

Message par zestef » 15 juin 2018 22:20

Merci du retour. Incident ouvert ce soir (je pense qu'il sera pris en compte après le week-end).

Dois-je mener une action particulière pour être en lien avec Qoolbox sur le forum (Stéphane du support QNAP) ?

Bon week-end !

A+
Stéphane.

Avatar du membre
FX Cachem
Site Admin
Messages : 9274
Enregistré le : 08 décembre 2013
Professionnel : Non
Localisation : Paris
Contact :

Re: Extinction inopiné du NAS

Message par FX Cachem » 16 juin 2018 12:32

zestef a écrit :
15 juin 2018 22:20
Dois-je mener une action particulière pour être en lien avec Qoolbox sur le forum (Stéphane du support QNAP) ?
Qoolbox ne gère pas les tickets le week-end, il a une vie à côté... en plus, c'est un grand amateur de foot :-D mais tu peux lui envoyer un petit MP (message privé sur le forum) avec ton numéro de ticket ;)
Blogueur sur Cachem et administrateur du Forum des NAS
NAS : Synology DS412+ | QNAP TS-470 Pro | ASUSTOR AS-302T

zestef
Messages : 7
Enregistré le : 12 juin 2018

Re: Extinction inopiné du NAS

Message par zestef » 16 juin 2018 15:32

merci pour cette information.

Yes clairement le week-end ensoleillé et footeux est bien préférable à la gestion d'incidents QNAP :lol:
(Je lui laisserais un MP dimanche en soirée, il devrait être de bon humeur avec le résultat de cet après midi même si la manière n'était pas au RDV :oops: ).

Merci encore pour ton temps, la rapidité et la qualité des réponses !

A+
Stéphane.

Répondre

Retourner vers « Installation, Démarrage, Configuration et Dépannage »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités