[Résolu][Plex] Installation

BitTorrent Sync, CouchPotato, Headphones, IPKG, NZBGet, pyLoad, SABnzbdplus, SickBeard, Subsonic, XBMC/KODI...
Répondre
Avatar du membre
Celena-007
Chevalier Jedi
Messages : 323
Enregistré le : 08 janvier 2016

Re: [Plex] Installation

Message par Celena-007 » 13 mai 2018 13:58

Phil a écrit :
12 mai 2018 16:09
Apparemment Plex conserve quelque part le compte qui a été utilisé lors de la première installation ?
heureusement qu'il le conserve comme toutes les options de configurations (je me voit mal le reconfigurer a chaque démarrage :D )...
j'avais pas penser a te dire d'effacer le fichier : Preferences.xml (qui contient le compte avec lequel le serveur se connecte)

Phil
Apprenti
Messages : 39
Enregistré le : 07 septembre 2016

Re: [Plex] Installation

Message par Phil » 17 mai 2018 22:36

J'ai reçu le mini-clavier Rii. Grâce à celui-ci, j'ai donc pu cliquer sur le bouton "Next", et avancer dans la configuration.
Le lien est fait entre mon écran et mon serveur Plex, j'ai bien accès à mes vidéos, le son passe bien sur la sortie optique du NAS, tandis que la vidéo passe sur la sortie HDMI.
Nickel pour tout ça.

Il me reste un tout petit souci à régler : j'ai des vidéos avec des fichiers sous-titres .srt.
Initialement, ils avaient le même nom que la vidéo, par exemple :

Code : Tout sélectionner

Fichier vidéo : MaVideo.mkv
Fichier sous-titres : MaVideo.srt
Sous Kodi, ça fonctionnait bien, il repérait directement le fichier .srt et incrustait les sous-titres dans la vidéo.
Sous Plex, ça ne fonctionne pas. Il semble qu'ils soit nécessaire d'indiquer la langue dans le nom du fichier .srt ? J'ai cru comprendre cela en lisant les indications en bas de cette page : https://support.plex.tv/articles/200471 ... our-media/
Si je reprends mon exemple :

Code : Tout sélectionner

Fichier vidéo : MaVideo.mkv
Fichier sous-titres : MaVideo.fr.srt
J'ai donc renommé mes fichier .srt en .fr.srt, puis ai lancé un scan, puis un refresh de la bibliothèque. Mais je n'ai accès à aucun sous-titres quand je lis la vidéo MaVideo.mkv. J'ai "none" dans la liste des sous-titres, alors que le fichier est bien présent dans le même répertoire, avec l'extension .fr.srt

Dans les réglages du serveur, j'ai bien mis "Préférer les sous-titres en français", avec l'option "mode des sous-titres toujours activés".

Est-ce qu'il y a d'autre opérations à faire pour que Plex détecte des sous-titres srt sur une vidéo ?

Merci.

Avatar du membre
Matt
Chevalier Jedi
Messages : 183
Enregistré le : 26 juin 2016

Re: [Plex] Installation

Message par Matt » 18 mai 2018 02:00

L'ajout de la région "en,fr,etc..." au fichier sous-titre n'est pas obligatoire pour que ça fonctionne correctement avec Plex, par contre il faut cocher dans réglages -> serveur -> agents

l'option "Local Media Assets" et la déplacer en haut de la liste.

Et faire une actualisation ensuite.
NAS: Asustor - AS3104T

Phil
Apprenti
Messages : 39
Enregistré le : 07 septembre 2016

Re: [Plex] Installation

Message par Phil » 18 mai 2018 20:46

Matt a écrit :
18 mai 2018 02:00
L'ajout de la région "en,fr,etc..." au fichier sous-titre n'est pas obligatoire pour que ça fonctionne correctement avec Plex, par contre il faut cocher dans réglages -> serveur -> agents

l'option "Local Media Assets" et la déplacer en haut de la liste.

Et faire une actualisation ensuite.
J'ai bien coché l'option, je l'ai mise en haut de la liste.
J'ai refait un scan, et une actualisation des métadonnées. Mais toujours pas de sous-titres français disponibles, alors que le fichier .srt est présent dans le même répertoire que la vidéo, avec le même nom... :(
Une idée ?

Edit : en fait ça fonctionne pour les films, mais pas pour les séries TV. Pour les série, j'ai créé mes bibliothèques moi-même (en les taggant comme des bibliothèques de séries). Pour la bibliothèque de films, c'est Plex qui l'a construite sans que je ne fasse quoi que ce soit...Peut-être qu'il faut que je supprime mes bibliothèques de série, et que je laisse Plex les faire seul ?

Avatar du membre
Matt
Chevalier Jedi
Messages : 183
Enregistré le : 26 juin 2016

Re: [Plex] Installation

Message par Matt » 18 mai 2018 22:11

Je sait pas ce que tu entend par "laisser Plex faire les bibliothèques" :)

Pour les séries, la meilleur façon de les classer c'est comme ça:

/Séries/
/Dr. House/Saison 1/S01E01.mp4
/Dexter/Saison 1/S01E01.mp4
Etc...
NAS: Asustor - AS3104T

Phil
Apprenti
Messages : 39
Enregistré le : 07 septembre 2016

Re: [Plex] Installation

Message par Phil » 19 mai 2018 16:34

Matt a écrit :
18 mai 2018 22:11
Je sait pas ce que tu entend par "laisser Plex faire les bibliothèques" :)

Pour les séries, la meilleur façon de les classer c'est comme ça:

/Séries/
/Dr. House/Saison 1/S01E01.mp4
/Dexter/Saison 1/S01E01.mp4
Etc...
Pour mes bibliothèques "Musique" et "Films" par exemple, je n'ai rien fait : Plex a analysé mon disque et les a constituées.
Pour la bibliothèque "Série TV" en revanche, il a fallu que j'utilise le menu "Ajouter une bibliothèque" et que je choisisse le type "Série TV" en indiquant le répertoire à considérer sur mon NAS.

Du coup j'ai supprimé cette bibliothèque, je viens de la recréer, après avoir vérifier que l'option Local Media Assets était cochée, et en tête.
Ca ne règle pas le souci... :(

Avatar du membre
Celena-007
Chevalier Jedi
Messages : 323
Enregistré le : 08 janvier 2016

Re: [Plex] Installation

Message par Celena-007 » 20 mai 2018 21:51

pour le sous titre tu utilise bien cette notation (en respectant les codes 3 lettres ou 2 lettres de ce tableau : https://en.wikipedia.org/wiki/List_of_ISO_639-2_codes):
- Film.fr.srt
- Film.fre.srt (ou Film.fra.srt)

lorsque tu les ajoutes il faut faire un "Rafraichir toutes les métadonnées" (pas scan)

il est important que le fichier porte le même nom Majuscule incluse

Local media asset doit être mit en haut dans l'onglet série (pas comme moi il est en bas) :
Screenshot-2018-5-20 Plex.png
de préférence le mettre en haut dans tous les sous menu de série.
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

Phil
Apprenti
Messages : 39
Enregistré le : 07 septembre 2016

Re: [Plex] Installation

Message par Phil » 21 mai 2018 10:26

C'est réglé ! :-D

J'ai supprimé ma bibliothèque Séries TV.
Puis j'ai de nouveau ajouté une bibliothèque de type série TV. Il y a une option "Avancés" dans l'assistant de création d'une bibliothèque, que je n'avais pas vu initialement. Dans cette option, il est possible de paramétrer l'agent que l'on souhaite utiliser pour la création de la bibliothèque. J'ai donc choisi TheTVDB, en ayant pris le soin auparavant de paramétrer comme il fallait cet agent dans les réglages : "Local Media assets" en tête et coché.
Après l'ajout avec cet agent, j'ai désormais bien accès à mes sous-titres, et également à toutes les métadonnées issues de TheTVDB.

A noter : ça fonctionne avec des sous-titres dont le nom est formaté comme suit :
Mon fichier vidéo : MaVideo.mkv
Mon fichier sous-titres : MaVideo.srt
Je n'ai pas eu besoin de préciser la langue dans le nom du fichier sous-titre (MaVideo.fr.srt). Là, ça empêche simplement Plex d'afficher la langue du sous-titre externe quand on navigue dans l'interface, mais c'est tout. Pour la lecture de la vidéo, ça n'empêche pas l'incrustation des sous-titres fr. Je conserve donc ce format de nommage, pour ne pas modifier tous les noms de mes fichiers .srt

Enfin mes soucis d'install' de Plex sont résolus !
Au final je le trouve aussi performant que Kodi à l'usage, voire-même plus abouti.

Merci à tous ceux qui sont intervenus ici pour m'aider. :wink:

Répondre

Retourner vers « Applications tierces pour les NAS Asustor »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités