Forum des NAS

Tous les fabricants de NAS réunis sur un forum unique : Asustor, Qnap, Synology...

Discussion sur le paramétrage du NAS
#14254
Bonjour à tous,
une surtension dévastatrice a mis à mal mon NAS synology qui semble HS et ma tour windows.
J'aimerais récupérer les données des disques durs du NAS.

Il y a cette méthode donnée par synology mais je n'ai plus de pc windows dispo chez moi pour le moment.

Comme j'ai un PI 2 à la maison je pensais pouvoir l'utiliser, j'ai donc branché un des deux disque du NAS sur un convertisseur SATA/USB et raccordé le tout à un port USB du PI.

En cherchant un peu partout sur le net j'ai vu que pour lire les disques synology il fallait utiliser mdadm et lvm2.

Voilà ce qui fonctionne presque chez moi :

Code : Tout sélectionner
root@Rasp2:~# mdadm --assemble --run /dev/md0 /dev/sda5
mdadm: /dev/md0 has been started with 1 drive.
root@Rasp2:~# 

root@Rasp2:~#  cat /proc/mdstat                        
Personalities : [raid1] 
md0 : active raid1 sda5[0]
      971897600 blocks super 1.2 [1/1] [U]
      
unused devices: <none>
root@Rasp2:~# 

Mais l'étape d'après ne fonctionne pas, les commandes lvm ne fonctionnent pas, pvscan ne trouve aucun volume:

Code : Tout sélectionner
root@Rasp2:~# pvscan
  No matching physical volumes found
root@Rasp2:~# 

Et du coup je n'arrive pas à monter /dev/md0 sur /mnt/test

Code : Tout sélectionner
root@Rasp2:~# mount -t ext3 /dev/md0 /mnt/test
mount: wrong fs type, bad option, bad superblock on /dev/md0,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

root@Rasp2:~# 

Une piste pour essayer de récupérer qqs films de vacances :roll: ?

[EDIT] je n'avais pas vu les catégories par marque, si un admin pouvait déplacer mon post dans la bonne section .. :oops::oops::oops:

#15065
Bonjour,
j'ai réussi à récupérer mes données.
Je ne suis pas arrivé à le faire sur le raspberry PI2, je ne sais pas pourquoi.
J'ai suivi la méthode de Synology à partir d'un PC windows et cela a fonctionné.

J'ai fais également un essai sur un odroid C1+ et cela a fonctionné.
Voici la démarche sur l'odroid :

Code : Tout sélectionner
sudo -i
mkdir /mnt/recupNas
apt-get install mdadm
apt-get install lvm2

root@odroid:~# mdadm -Asf && vgchange -ay
mdadm: /dev/md/2 has been started with 1 drive (out of 2).
  ffff0000-ffff1000 r-xp 00000000 00:00 0          [vectors]: mlock failed: Cannot allocate memory
  1 logical volume(s) in volume group "vg1000" now active
  ffff0000-ffff1000 r-xp 00000000 00:00 0          [vectors]: munlock failed: Cannot allocate memory

root@odroid:/mnt# pvscan
  PV /dev/md2   VG vg1000   lvm2 [927.00 GiB / 0    free]
  Total: 1 [927.00 GiB] / in use: 1 [927.00 GiB] / in no VG: 0 [0   ]
root@odroid:/mnt# vgscan
  Reading all physical volumes.  This may take a while...
  Found volume group "vg1000" using metadata type lvm2
root@odroid:/mnt# lvscan
  ACTIVE            '/dev/vg1000/lv' [927.00 GiB] inherit
root@odroid:/mnt# mount /dev/vg1000/lv /mnt/recupNas/
root@odroid:/mnt#

Il me reste à voir pour le repertoire chiffré mais ce sont des données que j'ai en backup.
SI cela peut aider quelqu'un d'autre un jour !

#15199
Oui j'ai bien flipé, le pb de l'onduleur c'est que j'ai trop tardé pour en mettre un, du coup les mois puis les années sont passées sans que cela ne soit un souci jusqu'à ce que .... et bien sur cela se produit peu de temps après avoir du faire des essais et avoir le NAS sur la mauvaise multiprise qui n'est plus protégée contre les surtensions ..... la loi de Murphy est toujours efficace :evil:

je suis conscient qu'un NAS n'est et ne sera jamais un backup, et les fichiers importants étaient sauvegardé à part mais c'est toujours pénible d'avoir tout à refaire et à chercher je suis bien content d'avoir limité la casse.

Petit HS :
Pour le moment pas trop de budget à mettre pour le compte "geek", un onduleur viendra surement dès que possible. Du coup j'ai migré tout ce que j'utilisais vers un Odroid (samba + owncloud + madsonic + nzbget, il reste la partie galerie photo à mettre en place, surement piwigo) me reste aussi à mettre un raid 5 à monter avec 3 disques 1To (et oui je suis un petit joueur) raccordés aux ports usb ... je trouve que cela fonctionne super bien pour mon utilisation (pas d'exigence de temps d'accès ni de volume trop important) et que ce n'est pas trop compliqué, c'est aussi le point positif que je peux trouver à cette mesaventure : je monte en compétence en linux.
ADM 3.5.0.R5D3

Bonsoir ! Sur un 3202T: outre mon problèm[…]

Bonsoir tout le monde ! J'ai un AS3202 depuis que[…]

Merci pour l'information. Je vais voir ton lien et[…]

Paramétrage Kodi18

Bonjour, je viens d'installer Kodi 18 sur mon NAS […]

Site hébergé sur un serveur IKOULA

Ikoula