Forum des NAS

Tous les fabricants de NAS réunis sur un forum unique : Asustor, Qnap, Synology...

Les applications mobiles (Android, iOS, Windows Phone) mais aussi les applications Windows et OS X
#95853
Salut la communauté,

Je tente tant bien que mal à me reconnecter de l'extérieur avec mon smartphone android à mes applications DS suite à un changement de fournisseur internet de Free vers Orange.
J'ai bien défini une addresse IP fixe pour le NAS sur la Livebox 5.
J'ai créé un DDNS pour pouvoir me connecter au NAS via la Livebox 5 et donc pallier au changement d'adresse IP Publique.
Maintenant mon pb est que je reçois le message d'erreur suivant lorsque je cherche à me connecter:
"Certificat SSL du Synology NAS n'est pas fiable "
Quand je vérifie le certificat, je me rend compte que Audio, Photo File station ne font pas partie des applications certifiées. Le pb vient peut être de là mais je ne sais pas comment le résoudre....
Merci d'avance pour votre aide!
#95858
Attention il y a deux certificats SSL différent :
Synology propose par défaut un certificat auto-signé , ce certificat pose en effet pb dans nb de cas , la solution :
Installé un certificat Let's Encrypt c'est gratuit et cela fonctionne avec une adresse en xxx.synology.me . Une fois ce certificat installé il faut viré le certificat Synology par défaut
Voir : Panneau de configuration , sécurité , certificat
#95878
Salut, Merci pour vos conseils. J'avais bien créé un certificat Let's Encrypt. Je n'avais pas supprimé le certificat synology. Je l'ai donc supprimé, malheureusement mon problème reste le même.
Je me demande si le certificat s'applique aussi pour les applications DS Photo, Note, File et Audio car Panneau de configuration , sécurité , certificat, si je regarde mon certificat Let's Encrypt il est uniquement pour : Web Dab Server, Cloud Station Server, FTPS, Paramètres système par défaut, Hyper Backup Vault.
Il n'est pas fait mention des application Photo station, Audio station, etc.
Est ce que ça pourrait être la cause du problème?
#95888
Normalement le certificat Let' s Encrypt est valable pour tout . Maintenant comme tu as changé de Box as-tu bien refait les directions de ports . :?:
Si le Nas est bien en IP fixe et les redirections de ports faite cela doit marcher comme sur des roulettes :?
#96485
Hello, j'ai le même problème que toi.
En passant par un proxy inversé, les noms de domaine pour les différentes applications synology (par exemple videostation.ndd.synology.me, audiostation.ndd.synology.me, etc...) se sont bien ajoutées tous seuls au certificat let's encrypt par défaut.
Je pense que ce certificat fonctionne de base pour toutes les applications DSM. Je ne pense pas qu'on ait quelque chose à configurer à ce niveau. Pourquoi le certificat n'est pas considéré comme fiable? j'en ai aucune idée. Si quelqu'un peut m'éclairer...
Ce message de certificat non fiable n'apparait qu'en HTTPS.
Dans les applications de smartphone il suffit de demander d'accéder au site quand même et ça fonctionne.
Mais dans les applications android TV comme DSVIDEO, on ne peut pas forcer l'accès.
Il semblerait que la solution consiste à se connecter en HTTP et non en HTTPS.

Je vais essayer de mon côté!
#96700
J'ai du nouveau pour DS video sur smartphone.
Il y a une étape importante que je n'avais pas faite (je ne savais pas qu'elle était à faire car c'est traitre...) c'est d'ajouter les sous domaines synology.me pour les applications du proxy inversé au certificat let's encrypt. En effet on voit dans le certificat: "Pour Drive, video.ndd.synology.me, music.ndd.synology.me mais en fait ces sous-domaines ne sont pas inscrits dans le certificat. Il faut remplacer le certificat et réécrire un par un les sous domaines dans "autres noms". Bref un problème de réglé!

Depuis je n'ai plus de message comme quoi le certificat est non fiable. Je peux accéder directement à la page de connexion des applications via un navigateur.
Pour DS video, en reconfigurant le reverse proxy en https, la lecture des films fonctionne en local via wifi en me connectant via video.ndd.synology.me:443 et en activant https sur la page de connexion.
C'est très bien mais je constate qu'en 4g ça ne fonctionne toujours pas. La lecture ne se fait plus. Mais je touche au but!
Installation de mon DS420+

je viens de tomber sur ce Tuto qui est sur le fo[…]

Hello Qoolbox, Is it possible to get Portainer V2[…]

Transfert entre nas

Bonjour à tous, Possesseur d'un antique […]

Bonjour tout le monde

Bonjour à tous, Possesseur d'un antique […]

Site hébergé sur un serveur IKOULA

Ikoula