Créé un serveur PXE et installer un Windows 7 ou 10

Les tutoriaux rédigés par les membres
Répondre
titis14
Chevalier Jedi
Messages : 308
Enregistré le : 06 septembre 2016

Re: Créé un serveur PXE et installer un Windows 7 ou 10

Message par titis14 » 02 nov. 2017 18:50

Cool cela avance, montre moi le fichier de ton menu, le codage.
Synology DS216+II + 4Go de ram + 2x WD Red 3To + onduleur Eaton 5S 550

Minos
Messages : 10
Enregistré le : 26 octobre 2017

Re: Créé un serveur PXE et installer un Windows 7 ou 10

Message par Minos » 02 nov. 2017 18:54

Bon y a du mieux ...

en fait j ai trouvé deux erreurs ...
la première la plus grosse ....le winpe4.iso n'était pas copié ....la loose :D
la seconde dans le chemin du install.bat \\192.168.0.25\pxe\images\Windows 10 Pro x64
pxe etait en majuscule ... je sais si bloaquent mais j'ai corrigé ...

maintenant j 'en suis la
winpe4_.JPG
winp_2.JPG
ben là je demande si c'est c'est pas un soucis de drivers reseaux...

j ai testé sur deux machines ...une VM HyperV et un portable ASUS....

Pareil.... :x
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

Minos
Messages : 10
Enregistré le : 26 octobre 2017

Re: Créé un serveur PXE et installer un Windows 7 ou 10

Message par Minos » 02 nov. 2017 18:56

Cool cela avance, montre moi le fichier de ton menu, le codage.
Tiens voilà le menu
DEFAULT vesamenu.c32
MENU TITLE Deploiement Images de Minos
MENU INCLUDE /pxelinux.cfg/master.cfg
menu color title 1;36;44 #ff8c00 #00000000 std
prompt 0
timeout 300
ONTIMEOUT chainlocal

LABEL local
MENU LABEL Boot local hard drive
LOCALBOOT 0

LABEL Memtest
KERNEL images/memtest

LABEL Installation Windows 10 Pro x64
LINUX memdisk
INITRD images/winpe4.iso
APPEND iso

titis14
Chevalier Jedi
Messages : 308
Enregistré le : 06 septembre 2016

Re: Créé un serveur PXE et installer un Windows 7 ou 10

Message par titis14 » 02 nov. 2017 19:05

OK cool je ne pense pas car tu arrive tout de même sur WinPe il a une commande pour avoir un menu et voir si le réseau et activé je cherche et je revient vers toi.
Ca peut être un problème de driver c'est le plus gros défaut de ce système et je ne sais pas comment faire pour avoir un max de carte compatible.
Chez moi ça marche avec une VM de Virtual Box essai pour confirmer que tout fonctionne bien.
Synology DS216+II + 4Go de ram + 2x WD Red 3To + onduleur Eaton 5S 550

titis14
Chevalier Jedi
Messages : 308
Enregistré le : 06 septembre 2016

Re: Créé un serveur PXE et installer un Windows 7 ou 10

Message par titis14 » 02 nov. 2017 19:11

En faite il faut refaire l'étape 9 et dé-commenter la ligne
-Repérez la ligne « %SYSTEMDRIVE%\windows\tinyshell.exe » ajoutez devant un « ; » afin de la commenter.
Reboot sur le PXE et tu devrai avoir le menu de droite sur la photo et avoir le Network Manager pour voir si tu es connecté.
firefox_2017-11-02_19-09-33.jpg
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Synology DS216+II + 4Go de ram + 2x WD Red 3To + onduleur Eaton 5S 550

Minos
Messages : 10
Enregistré le : 26 octobre 2017

Re: Créé un serveur PXE et installer un Windows 7 ou 10

Message par Minos » 02 nov. 2017 19:35

Voilà ce que ça donne :
j 'ai l'impression qu'il y a bien du réseau ...
networkpxe.JPG
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

Minos
Messages : 10
Enregistré le : 26 octobre 2017

Re: Créé un serveur PXE et installer un Windows 7 ou 10

Message par Minos » 02 nov. 2017 19:37

et encore du réseau
Capture33.JPG
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

Minos
Messages : 10
Enregistré le : 26 octobre 2017

Re: Créé un serveur PXE et installer un Windows 7 ou 10

Message par Minos » 02 nov. 2017 23:53

J ai l'impression que le lecteur réseau ne monte pas lors du winpe init...

ça reboot... :twisted:

Minos
Messages : 10
Enregistré le : 26 octobre 2017

Re: Créé un serveur PXE et installer un Windows 7 ou 10

Message par Minos » 03 nov. 2017 01:34

Bon ben voilà.... ;) :D

mon probleme venait du montage , j'ai dû passé avec le compte admin... un autre compte créée sur le NAS avec les droits en lecture sur le dossier pxe ...niet ...
avec admin ....yes :P
PXE_OK.JPG
par contre comment fais tu pour avoir le choix de l'install entre OS ?
j ai fait la modif dans le menu

mais par contre tu fais 2 lecteurs réseaux différents à monter en même temps un Z et K par exemple ..?

j ai testé mais toujours le 1° qui monte en occurrence Z

merci en tout cas ...
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

titis14
Chevalier Jedi
Messages : 308
Enregistré le : 06 septembre 2016

Re: Créé un serveur PXE et installer un Windows 7 ou 10

Message par titis14 » 03 nov. 2017 10:17

Pour moi cela fonctionne avec un compte sans droit admin et je viens de regarder il a les droits que en lecture.
Pour avoir plusieurs windows il suffit de changer le nom de l'iso au lieu d'avoir winpe4.iso tu mets win7x64.iso par exemple et tu édite ton menu.
Ensuite tu refait l'étape 9 pour un autre Windows afin d'avoir un nouvel ISO qui pointera vers le second Windows.
Synology DS216+II + 4Go de ram + 2x WD Red 3To + onduleur Eaton 5S 550

Répondre

Retourner vers « Tutoriaux »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités