[TUTO] - Container Station - Transmission via VPN par Haugene

Les tutoriaux rédigés par les membres
Wirby
Messages : 3
Enregistré le : 23 novembre 2017

Re: [TUTO] - Container Station - Transmission via VPN par Haugene

Message par Wirby » 28 nov. 2017 21:01

Bonjour,

Oui, j'ain installé le client VPN sur mon NAS, la connexion fonctionne bien si j'associe Download Station à la connexion VPN.
Dans les logs du container, tun0 esr bien ouvert.

Feudor
Padawan
Messages : 115
Enregistré le : 08 novembre 2015

Re: [TUTO] - Container Station - Transmission via VPN par Haugene

Message par Feudor » 28 nov. 2017 21:32

Ah c'est déjà plus chiant ! T'as été voir dans les issues du Github ? Il me semble avoir vu un problème similaire au tien

Wirby
Messages : 3
Enregistré le : 23 novembre 2017

Re: [TUTO] - Container Station - Transmission via VPN par Haugene

Message par Wirby » 28 nov. 2017 23:00

Je vais y jeter un oeil, merci :)
En mode de contournement, j'utilise Download Station, mais il manque quelques fonctionnalités (dossier surveillé pour importer automatiquement les torrents par exemple), et je n'ai pas trouvé comment accéder à l'interface Web sans me connecter au bureau du NAS.

thenils
Messages : 2
Enregistré le : 15 juin 2018

Re: [TUTO] - Container Station - Transmission via VPN par Haugene

Message par thenils » 17 juin 2018 15:59

Bonjour à tous,

tout d'abord merci pour ce tuto participatif qui m'a permis d'apprendre les bases de docker container pour répondre a un soucis que j'ai, à savoir que transmission n'utilise pas QVPN...

Ensuite, j'ai quelques questions:

La première étant, si on coche, dans un profil de connexion VPN dans QVPN, l'option "utiliser la passerelle par défaut pour le réseau disant", cela ne suffit-il pas faire transiter le traffic de Transmission via celui-ci?

Et la deuxième étant de savoir, si j'ai bien rédigé mon bout de code pour le container:
docker run --privileged -d \
-v /share/Multimedia/:/data \
-v /share/Multimedia/:/data/completed \
-e OPENVPN_PROVIDER=NORDVPN \
-e OPENVPN_CONFIG=France \
-e OPENVPN_USERNAME='login' \
-e OPENVPN_PASSWORD='mdp' \
-e "TRANSMISSION_PORT_FORWARDING_ENABLED=true" \
-e "TRANSMISSION_RPC_AUTHENTICATION_REQUIRED=true" \
-e "TRANSMISSION_RPC_ENABLED=true" \
-e "TRANSMISSION_RPC_USERNAME=qnap" \
-e "TRANSMISSION_RPC_PASSWORD=qnap" \
-e "TRANSMISSION_BLOCKLIST_ENABLED=true" \
-e "TRANSMISSION_BLOCKLIST_URL=http://list.iblocklist.com/?list=fr&fil ... eformat=gz" \
-e "OPENVPN_OPTS=--inactive 3600 --ping 10 --ping-exit 60" \
-e "LOCAL_NETWORK=192.168.xxx.xxx/24" \
-p 49092:49092 \
--dns 50.116.40.226 \
--dns 104.238.153.178 \
--restart=always \
--name Transmission-NordVPN \
haugene/transmission-openvpn
J'ai une erreur dans la console qui me dit "standard_init_linux.go:187: exec user process caused "exec format error" " ...

Et enfin, comment vérifier par ou transite le trafic sortant du NAS?

J'ai un TS-231P ainsi que la version 4.3.4.0597 du firmware.

D'avance merci!

Répondre

Retourner vers « Tutoriaux »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité