Forum des NAS

Tous les fabricants de NAS réunis sur un forum unique : Asustor, Qnap, Synology...

Les tutoriaux rédigés par les membres
par jfrobs
#72211
Ça fonctionne plutôt bien ce Linux center, hormis que visiblement quand on fait tourner un serveur tier dessus il n'ouvre pas tous les ports d'écoutes :/

La configuration réseau de Linux center n'est pas paraéétrable donc je ne sais pas trop comment il fonctionne sur le NAS...c'est un peu le problème.

J'aurai aimé pouvoir mettre la débian en Bridge afin qu'elle puisse être vu comme une machine sur le résseau,
#81402
Désolé du deterrage, mais j'ai tripatouillé un peu car, comme @jfrobs, j'étais embêté pour accéder au linux-center depuis l'exterieur. Je suis incapable de donner des détails mais :
- la virtualisation semble utiliser lxc
- lxc-net crée deux interfaces réseau dans le linux center, et un pont entre les deux
- selon les configurations, ce pont n'est pas indispensable
- je n'ai pas réussi à le désactiver proprement, mais j'ai réussi à le désactiver quand même.

En effet, sur mon système, une fois connecté en ssh sur le linux-center, une commande ip me renvoie :

Code : Tout sélectionner
# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
37: eth1@if38: <BROADCAST,MULTICAST> mtu 1500 qdisc noqueue state UP group default qlen 1000
	*****
       valid_lft forever preferred_lft forever
39: eth0@if40: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
	*****
       valid_lft forever preferred_lft forever

eth1 donnant une adresse qui me fait penser à la création d'un réseau privé virtuel.
eth0 me donnant l'adresse locale souhaitée.

La passerelle par défaut passait par l'interface eth1

Avec cette config, je peux acceder à tous les services du linux-center depuis mon réseau local,mais pas depuis l'exterieur, même en ouvrant les ports. J'ai donc testé les commandes suivantes (en root)

Code : Tout sélectionner
# ip link set dev eth1 down
# ip route add default via 192.168.1.101

--> je ferme eth1 et je fais transiter le trafic directement par ma passerelle (192.168.1.101 étant l'adresse de mon routeur)

Finalement, pour automatiser au démarrage, j'ai créé un script dans /etc/init.d (copié de celui d'apache pour les entêtes)

Code : Tout sélectionner
# cat /etc/init.d/change-network.sh  
#!/bin/sh
### BEGIN INIT INFO
# Provides:          changenetwork
# Required-Start:    $local_fs $remote_fs $network $syslog $named
# Required-Stop:     $local_fs $remote_fs $network $syslog $named
# Default-Start:     3 
# Default-Stop:      0 1 6
# X-Interactive:     true
# Short-Description: Change Network
# Description:       Change Network
#  This script will start the apache2 web server.
### END INIT INFO! 
ip link set dev eth1 down
ip route add default via 192.168.1.101

Rendre le fichier executable et faire un lien symbolique pour le lancer au runlevel 3

Code : Tout sélectionner
# chmod +x /etc/init.d/change-network.sh
# ln -s /etc/init.d/change-network.sh /etc/rc3.d/S99changenetwork

Mettre à jour les scripts de démarrage

Code : Tout sélectionner
# update-rc.d change-network.sh defaults

Je peux maintenant accéder à mes services depuis l’extérieur (sous réserve de l'ouverture des ports directement dans le routeur, évidemment)
Bref, c'est laid, c'est sale, mais ça marche

Clone d'un disque sur un autre

Merci Le blue fonctionne très bien mais je […]

Spotify et Firefox

Hello à tous, Bien occupé je trouve[…]

Dernière question, est ce que c'est possi[…]

Site hébergé sur un serveur IKOULA

Ikoula