Forum des NAS

Tous les fabricants de NAS réunis sur un forum unique : Asustor, Qnap, Synology...

Tout le reste...
#72773
Bonjour à tous,

J'ai un problème sur le chiffrement des dossiers et fichiers partagés un peu particulier que j'aimerai vous soumettre.
J'ai un DS218Play avec 2 HDD WD NasDrive de 4To en RAID 1, le tout acheté il y a environ 1 an. Tout fonctionnait nickel.
Ma config sécu était :
- authentification forte à la console web manager via google authenticator sur mon mobile
- chiffrement du dossier partagé racine de mon arborescence : Volume1/Racine/... (autant dire que toutes mes données sont chiffrées environ 1.5To)
- clé de chiffrement stockée sur support USB collée au cul du NAS pour déchiffrement à la volée au reboot (@keystore, ...) mais également enregistrée sous keepass.

Le problème que j'ai rencontré a évolué crescendo. Tout a commencé par le formatage de mon mobile et donc du google authenticator. Suite à ca, impossible de retrouver d'une manière ou d'une autre mes tokens, ni sous google/gmail, nul part.
Je pouvais toujours accéder à mon NAS via le partage réseau ou le lecteur réseau que j'avais monté au préalable sur mon Windows 10. Mais ca me faisais quand même bien chié car je n'avais plus accès au manager, alors j'ai décidé de réinitialiser la console d'admin ainsi que le compte admin via un reset hardware (maintient du bouton reset 2 fois 4 secondes).
Les bips du NAS ainsi que la diode orange clignotante m'indiquaient que le DSM n'était plus installé. Parfait je vais pouvoir le réinstaller, seulement lors de l'installation (.pat) ca foire à l'étape 2 (formatage de la partition...) lecteurs introuvables.
Je me suis arrété la pour le NAS.

J'ai décidé avant d'aller plus loin, de sauvegarder mes données. J'ai donc sorti mes 2 WD et j'en ai mis un dans un rack externe 3"5 et avec DiskInternals Linux Reader j'ai pu extraire mes données chiffrées (1.5To). J'ai tout déposé dans un DD externe en attendant de pouvoir les déchiffrer.

Vous l'aurez bien compris, j'ai 2 problèmes.
- J'aimerai savoir comment faire pour déchiffrer mes données sachant que les 2 WD ne sont plus dans le NAS et que je bénéficie de la clé de déchiffrement ?
J'ai tenté avec PGP Kleopatra mais impossible de faire le taf. Il n'est à priori pas capable de reconnaitre le fichier chiffré, ni la clé.

- Comment faire pour réinstaller DSM dans mon NAS sans perdre le contenu de mes HDD ?

Merci la communauté.
#72854
Hello,

Merci pour vos réponses :)

Voici le retour de syno :

Code : Tout sélectionner
Bonjour,

Merci d'avoir contacté le support synology

Pour accéder à votre dossier crypté :

- installez le paquet ecryptfs-utils

- choisissez un dossier comme point de montage (enc_test dans cet exemple)

- exécutez mount -t ecryptfs @enc_test@/ enc_test/

- rentrez le mot de passe

- configurez les options tel que ci-dessous

- cipher : aes: blocksize = 16; min keysize = 16; max keysize = 32 (not loaded)

- key bytes : 2

- Enable plaintext passthrough : n

- Enable filename encryption : y

- montez votre dossier avec ecryptfs-add-passphrase --fnek

- Would you like to proceed with the mount ? : yes

- Would you like to append sig **** in order to avoid this warning in the future? : no

 

Concernant votre NAS vous pouvez insérer uniquement un disque vierge et installer DSM dessus.

Vous pourrez ensuite insérez un de vos anciens disques et récupérer l'accès à vos données

On sent les gros techos ca fait du bien !

J'essaye tout ca et vous tient au courant.

Avatar de l’utilisateur
par Esteban
#72856
Va falloir leur dire qu’on dit “chiffre” et pas crypté ! ;0))))


Sent from my iPhone using Tapatalk
#73057
Alors je n'ai pas essayé les commandes linux car j'ai commencé par essayer de résoudre le problème de DSM.
J'ai donc remis mes 2 HDD dans le NAS puis réinitialisé le DSM via le bouton reset à l'arrière.

Tout s'est bien déroulé et la dernière version DSM a correctement été installé. Le NAS a rebooté et je peux maintenant de nouveau avoir accès en web à mon interface ainsi que déchiffrer le contenu de ma racine.
Vidéo surveillance

Hello https://www.forum-nas.fr/viewtopic.php?t=1[…]

Erreur Download Qnapclub

quel est ton NAS ? model et ta version de firmware

Firmware DSM 6.2.3-25426

Depuis l’installation de cette version, il y[…]

Plus qu'un mois avant Q3 :lol: Tu rigoles Q3 2[…]

Site hébergé sur un serveur IKOULA

Ikoula