OpenVPN et réseau local

Antivirus, Audio Station, Cloud Station, Download Station, iTunes Server, Media Server, Photo Station, Surveillance Station, Video Station...
Répondre
Play
Messages : 4
Enregistré le : 11 avril 2019
Professionnel : Non

OpenVPN et réseau local

Message par Play » 11 avr. 2019 12:21

Bonjour,

Ça fait un moment que je me prend la tête avec OpenVPN, et je fini par me demander s'il est réaliste de penser qu'il peut répondre à mon besoin.
En fait un besoin très simple.
J'aimerai que une fois connecté DS214+ via OpenVPN, j'ai accès aux périphériques de mon réseau local.
C'est à dire que une fois connecté, je puisse par exemple faire un ping de mes appareils.

Alors oui je sait, quand on regarde la config de OpenVPN sur le NAS c'est très simple, il y a juste une case à cocher pour accéder au réseau local.
Mais je dois pas avoir compris ce qu'elle représente car une fois connecté :
J'accède aux partages du NAS mais la console WEB ne répond pas (le tout sur 10.8.0.1).
Et pour ce qui est de faire un ping sur un équipement du réseau 192.168 ... même pas en rêve.
Le truc qui m'interpelle le plus c'est que une fois connecté, je n'ai pas de passerelle par défaut.

J'ai fait pas mal de recherches sur le sujet mais je dois avoir manqué le petit truc qui fait la différence.

J'ai fait la mise à jour DSM 6.2.2.
J'ai installé la dernière version de OpenVPN.
Configurer le VPN sur le NAS (pas grand chose à faire).
Exporté la configuration et copier celle-ci sur le PC portable.
Et je n'y arrive toujours pas.

Il y a dans tout cela forcément quelque chose de mal fait, mais je galère à savoir quelle est la brique que j'ai loupé.
Si vous avez des idées je suis preneur.

A tout hasard la chaine complète :
PC sous Windows 10 à jour => Partage de connexion Free => Freebox V6 Bridge => pfsense => DS214+ avec DSM 6.2.2
Ça fait un paquet de truc qui peuvent merder ...
Freebox V6 bridge IPV6
pfsense
DS214+

Avatar du membre
FX Cachem
Site Admin
Messages : 9761
Enregistré le : 08 décembre 2013
Professionnel : Non
Localisation : Paris
Contact :

Re: OpenVPN et réseau local

Message par FX Cachem » 23 avr. 2019 21:07

Hello,

Je n'ai pas testé OpenVPN depuis pas mal de temps... à tout hasard, as-tu fait un essai en L2TP/Ipsec.
Je te recommande le tuto de l'ami Esteban : [Tuto] Se connecter en VPN (L2TP/Ipsec)
Blogueur sur Cachem et administrateur du Forum des NAS
NAS : Synology DS918+ | QNAP TS-470 Pro | ASUSTOR AS-302T

Play
Messages : 4
Enregistré le : 11 avril 2019
Professionnel : Non

Re: OpenVPN et réseau local

Message par Play » 25 avr. 2019 12:33

Bonjour et merci pour la réponse.

En fait, je prend en général des solutions qui ne sont pas "attachée" à un constructeur ou un éditeur plus indépendant du tout.
Quand c'est possible bien entendu.
Et donc, une solution open source me semblait le plus approprié. OpenVPN.
Et la plus sécurisée aussi ...

Je pense que, plutôt que de persister à vouloir faire le VPN avec le NAS, je vais tenter de le faire avec le routeur.
Çà fonctionne pas mal avec un pfsense par exemple.
Mais dans ce cas précis, je voulais éviter d'en arriver là ... disons.
J'ai lu à droite à gauche que depuis DSM6, certaines choses comme par exemple le "pont" entre les deux interfaces réseau du NAS n'existe plus.
Je trouve ça ballot, mais je ne peut pas trop leur en vouloir puisqu'ils font aussi du matériel réseau de routage.
Donc bon ...

Pour autant, je m'adresse à vous au cas où il existe une solution malgré tout.
Freebox V6 bridge IPV6
pfsense
DS214+

lose
Chevalier Jedi
Messages : 453
Enregistré le : 01 février 2019

Re: OpenVPN et réseau local

Message par lose » 25 avr. 2019 13:51

Si tu y arrive a te connecter au vpn par 10.xxx.xxx.xxx as tu essayer de te connecter a dsm avec l'adresse 192.168.xxx.xxx ?

Envoyé de mon SM-G955F en utilisant Tapatalk

synolony ds1817+
Image 7 disque western digital red pro de 6 to en raid 6 - btrfs

box : livebox4

lapatte
Messages : 12
Enregistré le : 03 février 2019

Re: OpenVPN et réseau local

Message par lapatte » 29 avr. 2019 18:15

Salut, perso j'ai openVPN sur mon ds718+ et j'avais aussi des soucis pour accéder a mon réseau local car j'avais une règle du par-feu qui m'en empêchais, vérifie de ce coté là.
OS unraid
Config : (PC que je n'utilisais plus)
Corsair VS Series VS550
ASRock B150 Pro4/D3
Intel Core i5-6500
Corsair Vengeance Pro DDR3-1600 - 8 GB (2x4)
OCZ Trion 150 SATA 6 Gb/s 2.5'' SSD - 240 GB
WD Red NAS Hard Drive SATA 6 Gb/s - 2.0 TB 2x

Répondre

Retourner vers « Applications officielles »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité