[resolu] Routeur wifi avec DS216j

Caméra IP, Disque dur, Imprimante, Mémoire, UPS...
Avatar du membre
FX Cachem
Site Admin
Messages : 9768
Enregistré le : 08 décembre 2013
Professionnel : Non
Localisation : Paris
Contact :

Re: Routeur wifi avec DS216j

Message par FX Cachem » 05 août 2018 10:48

Ce que je vois, c'est que tu as des ports à l'entrée qui diffère du NAS... c'est une excellente idée.
En source, ne mets rien sauf si tu connais l'adresse. Par contre, il faut que tu mettes l'adresse IP locale (celle du NAS), ce que tu as masqué... non ? C'est l'adresse IP 192.168.xxx.xxx Ne met pas le port 5000 mais uniquement le 5001.
Blogueur sur Cachem et administrateur du Forum des NAS
NAS : Synology DS918+ | QNAP TS-470 Pro | ASUSTOR AS-302T

skelton
Apprenti
Messages : 46
Enregistré le : 27 mai 2017

Re: Routeur wifi avec DS216j

Message par skelton » 05 août 2018 16:01

FX Cachem a écrit :
05 août 2018 10:48
Ce que je vois, c'est que tu as des ports à l'entrée qui diffère du NAS... c'est une excellente idée.
En source, ne mets rien sauf si tu connais l'adresse. Par contre, il faut que tu mettes l'adresse IP locale (celle du NAS), ce que tu as masqué... non ? C'est l'adresse IP 192.168.xxx.xxx Ne met pas le port 5000 mais uniquement le 5001.
Hello Cachem :)

Qu’entends-tu par des ports à l’entree qui diffère du NAS?
Tu parles de la redirection ?
Source c’est sensé être l’adresse de quoi?

Pour l’adresse local c’est bien l’adresse ip du NAS du format 192.168.X.X, que j’ai bien ajouté.

D’ailleurs par rapport à ça... j’ai vu que ladresse ip locale du routeur est 192.168.1.1... du coup en DCHP tous les périphériques branchés ont comme ip, une ip du type 192.168.1.X...ce quivpose un souci puisque le NAS à un ip fixe qui est du type 192.168.0.X.
J'ai voulu du coup modifier l’adresse ip locale du routeur en 192.168.0.1 et là j’ai perdu la connexion wifi. Ce qui sur le coup m’a parue logique...J’ai essayé alors de me connecter sur l’adresse 192.168.0.1 mais je suis arrivé sur une page qui contenait un message me disant de vérifier les adresses ip, un truc dans le genre...

De plus je passe par un DDNS (si je ne me trompe pas de termes) et du l’ip fixe du NAS renvoit vers une url. Et c’est par celle ci que je me connecte.
(Comme tu as vu je me connecte aussi avec le port 35001 (qui redirige vers le 5001 pour avoir une connexion sécurisée).

Bref du coup je suis un peu coincé et ton aide me serait précieuse.
Merci beaucoup 🙂

Skelton

Avatar du membre
FX Cachem
Site Admin
Messages : 9768
Enregistré le : 08 décembre 2013
Professionnel : Non
Localisation : Paris
Contact :

Re: Routeur wifi avec DS216j

Message par FX Cachem » 06 août 2018 19:38

skelton a écrit :
05 août 2018 16:01
Qu’entends-tu par des ports à l’entree qui diffère du NAS?
Tu parles de la redirection ?
Oui... tu peux mettre la même chose ou changer. L'important c'est de bien noté celle en source qui sera celle utilisée à l'extérieur.
skelton a écrit :
05 août 2018 16:01
Pour l’adresse local c’est bien l’adresse ip du NAS du format 192.168.X.X, que j’ai bien ajouté.
Ça je te crois car je ne le vois pas dans ta capture d'écran :wink:
skelton a écrit :
05 août 2018 16:01
D’ailleurs par rapport à ça... j’ai vu que ladresse ip locale du routeur est 192.168.1.1... du coup en DCHP tous les périphériques branchés ont comme ip, une ip du type 192.168.1.X...ce quivpose un souci puisque le NAS à un ip fixe qui est du type 192.168.0.X.
J'ai voulu du coup modifier l’adresse ip locale du routeur en 192.168.0.1 et là j’ai perdu la connexion wifi. Ce qui sur le coup m’a parue logique...J’ai essayé alors de me connecter sur l’adresse 192.168.0.1 mais je suis arrivé sur une page qui contenait un message me disant de vérifier les adresses ip, un truc dans le genre...
Pourquoi avoir changé sur le routeur ? Et surtout pourquoi ne pas avoir la même plage d'adresse IP dans le routeur et le routeur ? Ce qu'il faut dans un premier temps (et c'est primordial), c'est que le réseau refonctionne correctement. Je ne sais pas si tu es toujours déconnecté de ton réseau WiFi... ou si c'est juste un problème d'IP.

Après tout ce que tu as fait me semble bien.

Donc en résumé :
  • Regarde la configuration de ton routeur qui doit être le serveur DHCP (sauf si c'est tu as une box en plus qui a son propre DHCP aussi) ;
  • Assure-toi que le routeur et ton NAS sont bien sur la même plage IP (n'hésite pas à faire une réservation d'IP pour le NAS depuis la section DHCP du routeur) ;
  • Essaye d'accéder à ton NAS depuis l'extérieur avec ton adresseIPpublique:35001 (pour la connaître https://www.whatismyip.com )
  • ensuite tu peux utiliser ton service de DDNS
Bon courage...
Blogueur sur Cachem et administrateur du Forum des NAS
NAS : Synology DS918+ | QNAP TS-470 Pro | ASUSTOR AS-302T

skelton
Apprenti
Messages : 46
Enregistré le : 27 mai 2017

Re: Routeur wifi avec DS216j

Message par skelton » 07 août 2018 00:32

FX Cachem a écrit :
06 août 2018 19:38

Pourquoi avoir changé sur le routeur ? Et surtout pourquoi ne pas avoir la même plage d'adresse IP dans le routeur et le routeur ? Ce qu'il faut dans un premier temps (et c'est primordial), c'est que le réseau refonctionne correctement. Je ne sais pas si tu es toujours déconnecté de ton réseau WiFi... ou si c'est juste un problème d'IP.
j'étais obligé car j'avais figé l'ip du NAS en 192.168.0.X donc comme j'étais en ip locale 192.168.1.1 je n'ai pas pu ajouter en DHCP l'ip du NAS.
le routeur ne voulait pas...Donc j'ai modifié l'ip locale du routeur en 192.168.0.1 et la j'ai pu ajouté l'ip figée du NAS.

Au final la j'ai retrouvé la connexion.
J'ai accès au NAS en local depuis le finder de mon mac et j'arrive même depuis l'interface sur le navigateur (yeah !!!)
Mais ya encore des soucis...

Pour résumer :
- je n'arrive pas à accéder au NAS depuis l'url que j'ai créé via un DDNS dans l'interface du NAS. j'étais sur le port 35001 (équivalent au port 5001). J'avais et j'ai toujours un certif Let's encrypt valide (au passage ça ne marche pas non plus depuis le port 35000 non sécurisé)
- j'accède uniquement depuis l'ip figée du NAS 192.168.0.X:5000 donc en non sécurisé (si je mets le port 5001 j(y accède mais j'ai un avertissement que c'est non sécurisé).
- dans l'interface du NAS quand je vais dans réseaux > interface réseaux > LAN > dedans je suis en ipv4 manuelle (c'est la que j'ai figée l'ip pour le NAS)
(j'ai testé de mettre en DHCP et ça n'a rien changé)
- quand je vais dans accès externe > DDNS, je vois mon url (nom d'hôte) que j'ai créé dans l'interface synology, pour accéder au NAS et en face il est marqué : erreur de réseau, vérifier votre DSN... je ne sais pas ce que c'est le DSN....????
Si je clique 2 fois dessus je rentre dans la page pour modifier cela...et la je ne sais pas pourquoi, mais j'ai des messages en rouge d'affichés notamment au niveau du champ email, comme quoi "il n'est pas possible de demander les infos du compte synology"...
Au niveau du champ statut j'ai le message : "erreur de réseau, vérifier votre DSN et vos paramètres réseau"

Tu as une idée d'ou cela peut venir ?

- j'ai aussi un souci au niveau de plex serveur qui est installé...quand je le lance il ne trouve plus mon NAS...j'imagine que tout est lié...

FX Cachem a écrit :
06 août 2018 19:38

Après tout ce que tu as fait me semble bien.

Donc en résumé :
  • Regarde la configuration de ton routeur qui doit être le serveur DHCP (sauf si c'est tu as une box en plus qui a son propre DHCP aussi) ;
Non le modem ne peut pas être configuré, pas d'interface de paramètrages (je suis au canada et les modem ici ce ne sont pas les box françaises...tout est fermé et pas de wifi, d'ou l'achat du routeur pour générer du wifi à la connexion)

FX Cachem a écrit :
06 août 2018 19:38
[*]Assure-toi que le routeur et ton NAS sont bien sur la même plage IP (n'hésite pas à faire une réservation d'IP pour le NAS depuis la section DHCP du routeur) ;
Tu pourrais détailler ça ? un exemple ?
FX Cachem a écrit :
06 août 2018 19:38
[*]Essaye d'accéder à ton NAS depuis l'extérieur avec ton adresseIPpublique:35001 (pour la connaître https://www.whatismyip.com )
Quand je fais ça j'accède bien au NAS mais pas en sécurisé, on me dit que le certificat n'est plus valide, or quand je clic sur le cadenas rouge ouvert dans la barre d'url je vois bien certificat non valide, je clique dessus et la j'ai le détail du certificats let's encrypt et il est marqué qu'il est valide jusqu'au 28 août...
je suis paumé...


Bref, j'avoue ne pas savoir comment me sortir de ça...ton aide Cachem me serait vraiment utile...si tu veux (peux) on pourrait se capter en direct pour que tu puisses voir cela ?

Merci pour tes retours.

Skelton

Avatar du membre
FX Cachem
Site Admin
Messages : 9768
Enregistré le : 08 décembre 2013
Professionnel : Non
Localisation : Paris
Contact :

Re: Routeur wifi avec DS216j

Message par FX Cachem » 08 août 2018 08:02

J'ai bien peur que tout soit lié à ta configuration IP du NAS. Si vraiment tu ne peux pas mettre ton NAS et routeur sur 192.168.1.x... il faut mettre 255.255.0.0 en sous-réseau. Ensuite, tu peux mettre le routeur en passerelle et même en DNS (ou mettre 1.1.1.1 ou 8.8.8.8).

Une fois ces choses faites... il faut voir si le NAS accède à Internet. Installe une application depuis le Centre de Paquet (juste pour contrôle).

Pour le certificat Let's encrypt (et le message d'erreur que tu as en 5001), c'est tout à fait normal. Tu dois avoir un souci de configuration. Là encore, il faut procéder étape par étape. Quand tu dis que tu accèdes au NAS avec ton adresse IP publique... on est d'accord que tu fais le test en dehors de chez toi (sur un autre WiFi ou avec un partage 4G de ton téléphone) ?

Je pense que tu touches du doigt ce que tu veux faire... mais qu'il y a trop de choses qui ont été faites d'un coup. C'est pour cela qu'il faut revoir chaque élément, un à un.
Blogueur sur Cachem et administrateur du Forum des NAS
NAS : Synology DS918+ | QNAP TS-470 Pro | ASUSTOR AS-302T

skelton
Apprenti
Messages : 46
Enregistré le : 27 mai 2017

Re: Routeur wifi avec DS216j

Message par skelton » 08 août 2018 17:30

FX Cachem a écrit :
08 août 2018 08:02
J'ai bien peur que tout soit lié à ta configuration IP du NAS. Si vraiment tu ne peux pas mettre ton NAS et routeur sur 192.168.1.x... il faut mettre 255.255.0.0 en sous-réseau. Ensuite, tu peux mettre le routeur en passerelle et même en DNS (ou mettre 1.1.1.1 ou 8.8.8.8).
ça va changer quoi de tout mettre sur 192.168.1.X ? si c'est sûr de faire tout marcher je pense que je peux modifier l'adresse du NAS en 192.168.1.22 au lieux de 192.162.0.22 et rechanger l'ip locale du routeur en 192.168.1.1 et du coup réouvrir les ports sur l'ip du NAS 192.168.1.22.

Sinon quand tu dis de "mettre le sous réseau en 255.255.0.0" c'est dans le NAS ? ou le routeur ?

Quand tu dis "mettre le routeur en passerelle et même en DNS (ou mettre 1.1.1.1 ou 8.8.8.8", tu veux dire quoi ? i il faut faire la manip sur le routeur ou le NAS ou les 2 ?

FX Cachem a écrit :
08 août 2018 08:02
Une fois ces choses faites... il faut voir si le NAS accède à Internet. Installe une application depuis le Centre de Paquet (juste pour contrôle).
A ce jour (sans avoir fais ce que tu cites juste au dessus), je n'ai réussi à installer que l'appli PLEX mais pas les applis natives de SYNOLOGY.
FX Cachem a écrit :
08 août 2018 08:02
Pour le certificat Let's encrypt (et le message d'erreur que tu as en 5001), c'est tout à fait normal. Tu dois avoir un souci de configuration. Là encore, il faut procéder étape par étape. Quand tu dis que tu accèdes au NAS avec ton adresse IP publique... on est d'accord que tu fais le test en dehors de chez toi (sur un autre WiFi ou avec un partage 4G de ton téléphone) ?
Le certificat let's encrypt semble ok, on me dit qu'il est valide. Oui depuis l'extérieur et aussi depuis mon mobile canadien (vu que je suis au canada) et sans wifi.
j'ai juste un avertissement que c'est un site dangereux quand j'y accède en https et port 35001, mais j'y accède ;-)
FX Cachem a écrit :
08 août 2018 08:02
Je pense que tu touches du doigt ce que tu veux faire... mais qu'il y a trop de choses qui ont été faites d'un coup. C'est pour cela qu'il faut revoir chaque élément, un à un.
J'espère que je vais arriver car ça me semble super compliqué :(
j'avais une super installation avec le NAS accessible depuis la freebox, le serveur plex sur le NAS et lui aussi accessible depuis la freebox...bon j'ai pas de freebox mais bon j'aimerai déjà que tout sois correctement accessible et après pour me connecter à plex du NAS, j'ai l'appli sur la TV donc la ça posera pas de souci.

Bref c'est pas gagné...merci pour ton aide Cachem.

Skelton

Avatar du membre
Esteban
Grand Maître Jedi
Messages : 2574
Enregistré le : 18 mai 2017
Professionnel : Non
Localisation : France

Re: Routeur wifi avec DS216j

Message par Esteban » 08 août 2018 19:49

Salut
Pas bcp de temps la, mais j’ai l’impression que ça part dans tt les sens ce post ....
Avant de voir Plex et autre, il est nécessaire de mettre tt sur le même LAN.
192.168.1.y ou 192.168.0.y ou encore192.168.x.y/255.255.0.0 - je partirai plus sur la config par défaut du routeur. Ça évitera des pbs futurs en cas de reset par exemple.

N hésite ps à éteindre et rallumer l’ensemble pour remettre d équerre à la fin- (Parfois, ça aide pas mal)
Les DNS tu peux mettre côté routeur.

Yaurait pas non plus un petit pare-feu qui coincerait ?

Tout se redoudra, faut juste un peu de méthode.


Via Tapatalk
DS218+ (6.2.2) 2Gb + 8Gb (CT102464BF186D-1866)
DS215j (6.2.2) Off Site Backup

Ubiquiti ERx - Borne AP AC LR - Cams HikVision + Dlink - EATON 800VA

OS des NAS - Base de telechargement Synology - Tuto VPN sur Synology

skelton
Apprenti
Messages : 46
Enregistré le : 27 mai 2017

Re: Routeur wifi avec DS216j

Message par skelton » 09 août 2018 00:18

Salut Esteban,
merci pour ton message.

Esteban a écrit :
08 août 2018 19:49
Avant de voir Plex et autre, il est nécessaire de mettre tt sur le même LAN.
192.168.1.y ou 192.168.0.y ou encore192.168.x.y/255.255.0.0 - je partirai plus sur la config par défaut du routeur. Ça évitera des pbs futurs en cas de reset par
exemple.
Ca je peux faire...le routeur par défaut a pour ip locale 192.168.1.1...donc je peux assigner en manuel sur le NAS l'ip 192.168.1.22, au lieu de 192.168.0.22 (et la fixer aussi dans le routeur).
Pour le masque de sous réseau je mets 255.255.0.0.
Esteban a écrit :
08 août 2018 19:49
N hésite ps à éteindre et rallumer l’ensemble pour remettre d équerre à la fin- (Parfois, ça aide pas mal)
Les DNS tu peux mettre côté routeur.
Quand tu dis, les DNS je peux mettre côté routeur..c'est à dire? Car si j'assigne une ip manuelle dans les paramètres du NAS, je dois forcément mettre un DNS...
et dans le routeur au niveau de l'ip locale (interne et externe), je dois mettre aussi un DNS...
Esteban a écrit :
08 août 2018 19:49
Yaurait pas non plus un petit pare-feu qui coincerait ?
Ya le pare feu du routeur qui est activé...si c'est pas nécessaire, dis moi et je le désactive...?


Via Tapatalk

Avatar du membre
Esteban
Grand Maître Jedi
Messages : 2574
Enregistré le : 18 mai 2017
Professionnel : Non
Localisation : France

Re: Routeur wifi avec DS216j

Message par Esteban » 09 août 2018 11:59

il existe plusieurs methodes, mais selon moi :

- Garde les parametres par defaut du Routeur : 192.168.1.y avec un masque 255.255.255.0
- Active une plage DHCP, genre de 192.168.1.100 à 192.168.1.120
- Mettre le NAS en DHCP. (et donc ne fixe pas d'ip depuis le NAS) - Ca evitera des conflits ou de pas voir le nas si changement de routeur, ou demenagement du nas ailleurs.
- Paramètre une IP du nas depuis le routeur avec l'adresse Mac du nas - Tu trouves par exemple l'adresse mac comme ca : https://www.youtube.com/watch?v=1uRuRWlrLlg ou au dos de l'appareil - (Normalement le routeur devrait aussi la voir)
- Tout ce qui est nouveau sur le LAN (sauf si tu adresses un ip manuellement depuis les matos) sera entre 192.168.1.100 et 120. a toi des les administrer comme bon te semble avec adresse mac sur le routeur. (C'est assez pratique de voir qui est quoi au meme endroit)
- Configure le DNS sur le routeur - (pour ton info : https://korben.info/1-1-1-1-ou-9-9-9-9- ... oisir.html)
- Les firewalls il faut les laisser bien entendus, sous réserves, qu'ils soient biens configurés. si le traffic est bloqué par un parefeu à cause d'une mauvaise config... bah ca marchera moins bien. Regarde mon tuto VPN (cf ma signature), ya un exemple.
- Ne clique pas sur EZ-Internet dans le nas
- Redemarre l'ensemble.
- verifie que tu as le net sur le nas
- essaye de ty connecter (Hors LAN) avec l'adresse IP:5001 dans un premier temps -> Si OK -> essaye avec DDNS

Ca devrait etre bon :wink:
DS218+ (6.2.2) 2Gb + 8Gb (CT102464BF186D-1866)
DS215j (6.2.2) Off Site Backup

Ubiquiti ERx - Borne AP AC LR - Cams HikVision + Dlink - EATON 800VA

OS des NAS - Base de telechargement Synology - Tuto VPN sur Synology

skelton
Apprenti
Messages : 46
Enregistré le : 27 mai 2017

Re: Routeur wifi avec DS216j

Message par skelton » 09 août 2018 13:46

Bonjour Esteban.
Merci pour tout ça !

J’ai à priori capté tout ce que tu me conseilles sauf :

- le coup du pare feu / vpn. Je vais regarder ton tuto je vais peut-être mieux comprendre.
Pour info je disais que le pare feu du routeur était actif, oui c’est le cas, mais j’ai pas touché à sa config. C’est juste une case de cochée.
- pour faire l’essai avec le port 5001, ok mais si je souhaite garder mes redirections de ports (c’est à dire genre 35001 pour 5001, etc..) ça posera pas de soucis?
Suffit juste que je fasse les redirections dans le routeur en plus de ce que tu me conseilles de faire ?
- dernière chose, pourquoi tu me parles d’EZ-Internet ?

Merci encore pour tout.
Je teste ça et je te dis.

Répondre

Retourner vers « Matériels compatibles »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité