QNAP TVS 671 et usage en serveur de BDD?

Tout le reste...
Répondre
nikan
Messages : 14
Enregistré le : 30 mars 2016

QNAP TVS 671 et usage en serveur de BDD?

Message par nikan » 04 avr. 2018 22:45

Salut
ma question va paraître un peu bête, mais j'avoue que je sèche un peu.

Je suis médecin et je viens d'installer une configuration réseau pour notre nouveau cabinet. L'usage est essentiellement un logiciel de gestion de dossiers patients, une BDD donc.

La configuration actuelle comprend:
- un serveur: I7, 16Go de RAM, SSD, Carte ethernet 1Gbt
- 16 postes client: I5, 8Go de Ram, SSD sur tous les poste, ethernet 1Gbt
- tous les câbles sont de catégorie 6
- switch paramétrable full duplex 1Gbt

Malgré tout cela, l'accès à certaines données sont extrêmement lents sur les postes clients, alors que sur le serveur cet accès est assez rapide. En même temps je ne vois pas comment améliorer le réseau dans la configuration actuelle. Les seuls choix possibles, AMHA seraient:

- prendre un serveur de type Xeon (mais bonjour le coût) genre dell.... Mais quel configuration?
- prendre si possible mon QNAP TVS 671 en replaçant les DD par des SSD (le tout en raid) et et utiliser les 4 ports ethernet en agrégation, sachant qu'il a 4Go de Ram

Alors voici mes questions:
1°- Le choix d'un Nas QNAP est il pertinent ou faut il partir sur serveur dédié classique
2°- Si on peut partir sur le QNAP, comment le paramétrer pour avoir les meilleurs flux sur le réseau (type Raid en particulier, le type d'agrégation des ports?)

Merci de vos avis

Avatar du membre
fbernard
Apprenti
Messages : 32
Enregistré le : 02 mai 2017

Re: QNAP TVS 671 et usage en serveur de BDD?

Message par fbernard » 06 avr. 2018 20:09

En termes de matériel, ce que tu as est largement suffisant pour 16 clients, à moins que les données utilisées soient particulièrement lourdes (imagerie médicale?).
Avec un serveur dédié, un réseau en Gigabit, et aussi peu de postes, si la quantité de données est raisonnable (sortir l'historique médical du patient), ça devrait ête super rapide.
Ca ressemble plutôt à des soucis de paramétrage réseau, voire éventuellement d'indexation sur la base (mais tu dis que tout marche bien sur le serveur).

quelques trucs à vérifier en premier :
le serveur a une IP fixe (ou un bail permanent sur le serveur DHCP, qui lui attribue otujours la même adresse IP)
les clients accèdent au serveur directement en indiquant l'adresse IP, pas un nom de serveur
Sur le réseau, il y a un serveur DHCP (probablement une box ADSL ou fibre)?
C'est quoi la base de données? MySQL? Oracle? SQL Server? Windev HFSQL? sur quel système d'exploitation?

L'agrégation de liens, oublie, sauf si tu souhaites filmer les consultations en 4K en simultané dans tous les cabinets...
Changer de serveur, pareil, oublie. Tu peux utiliser un outil de supervision des performances (CPU, RAM, IO) pour savoir s'il est trop chargé, mais à mon avis, s'il ne fait rien d'autre qu'héberger une base de données, il doit se tourner les pouces toute la journée.
TVS-1282-i5-6500-16Go, 2x250Go M2, 4x525Go SSD, 4x8To HDD, et un i7-6700T qui attend d'être installé...

Répondre

Retourner vers « Divers »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités