Page 26 sur 27

Re: [ Qapache + PHP 7.2.5 ] [ 2.4.33 ] Apache WebServer + PHP + Extension

Posté : 09 mai 2018 13:52
par panada
Yessss désolé j'ai pas bien ouvert mes yeux. Mais tout refonctionne très bien avec une ancienne version! Merci!!!

Re: [ Qapache + PHP 7.2.5 ] [ 2.4.33 ] Apache WebServer + PHP + Extension

Posté : 22 mai 2018 16:42
par Toxic
Stephane, FYI:

24 May 2018, PHP 7.2.6

Code : Tout sélectionner

- EXIF:
  . Fixed bug #76164 (exif_read_data zend_mm_heap corrupted). (cmb)

- FPM:
  . Fixed bug #76075 --with-fpm-acl wrongly tries to find libacl on FreeBSD.
    (mgorny)

- intl:
  . Fixed bug #74385 (Locale::parseLocale() broken with some arguments).
    (Anatol)

- Opcache:
  . Fixed bug #76205 (PHP-FPM sporadic crash when running Infinitewp). (Dmitry)
  . Fixed bug #76275 (Assertion failure in file cache when unserializing empty
    try_catch_array). (Nikita)
  . Fixed bug #76281 (Opcache causes incorrect "undefined variable" errors).
    (Nikita)

- Reflection:
  . Fixed arginfo of array_replace(_recursive) and array_merge(_recursive).
    (carusogabriel)

- Session:
  . Fixed bug #74892 (Url Rewriting (trans_sid) not working on urls that start
    with "#"). (Andrew Nester)

Re: [ Qapache + PHP 7.2.5 ] [ 2.4.33 ] Apache WebServer + PHP + Extension

Posté : 22 mai 2018 17:23
par QoolBox
got it thanks

Re: [ Qapache + PHP 7.2.6 ] [ 2.4.33 ] Apache WebServer + PHP + Extension

Posté : 23 mai 2018 18:20
par QoolBox
Updated x64 versions

Code : Tout sélectionner

updated PHP Core to 7.2.6
Libsodium (added)
Sodium Extension added
GNUPG Extension added

Fixed Xdebug Zend extension not load by default

Re: [ Qapache + PHP 7.2.6 ] [ 2.4.33 ] Apache WebServer + PHP + Extension

Posté : 25 mai 2018 19:15
par QoolBox
arm-x41 + arm64 version added (no gnupg extension)

Re: [ Qapache + PHP 7.2.6 ] [ 2.4.33 ] Apache WebServer + PHP + Extension

Posté : 12 juin 2018 00:38
par Toxic
FYI:

07 Jun 2018, PHP 7.2.7

Code : Tout sélectionner

- Core:
  . Fixed bug #76337 (segfault when opcache enabled + extension use
    zend_register_class_alias). (xKhorasan)

- CLI Server:
  . Fixed bug #76333 (PHP built-in server does not find files if root path
    contains special characters). (Anatol)

- OpenSSL:
  . Fixed bug #76296 (openssl_pkey_get_public does not respect open_basedir).
    (Erik Lax, Jakub Zelenka)
  . Fixed bug #76174 (openssl extension fails to build with LibreSSL 2.7).
    (Jakub Zelenka)

- SPL:
  . Fixed bug #76367 (NoRewindIterator segfault 11). (Laruence)

- Standard:
  . Fixed bug #76410 (SIGV in zend_mm_alloc_small). (Laruence)
  . Fixed bug #76335 ("link(): Bad file descriptor" with non-ASCII path).
    (Anatol)

Re: [ Qapache + PHP 7.2.7 ] [ 2.4.33 ] Apache WebServer + PHP + Extension

Posté : 22 juin 2018 18:05
par QoolBox
updated to php 7.2.7

Re: [ Qapache + PHP 7.2.7 ] [ 2.4.33 ] Apache WebServer + PHP + Extension

Posté : 26 juin 2018 10:01
par Mikiya
Merci encore pour le suivi :)

Re: [ Qapache + PHP 7.2.7 ] [ 2.4.33 ] Apache WebServer + PHP + Extension

Posté : 09 juil. 2018 09:41
par dumb4ever
How can one use port 443 for Virtual Host web server ?
Is there a specific instruction that we can follow ?

What i did to have port 443 to star is by going on Qnap Setting:
1. System
2. General Settings
3. System Administration tab
4. Enable secure connection (HTTPS) to 443

but when i run this command:
wget --header="Host: site.domain.com" -O - https://localhost
I get:
[~] # wget --header="Host: site.domain.com" -O - https://localhost
--2018-07-09 22:56:41-- https://localhost/
Resolving localhost (localhost)... 127.0.0.1
Connecting to localhost (localhost)|127.0.0.1|:443... connected.
ERROR: no certificate subject alternative name matches
requested host name ‘localhost’.
To connect to localhost insecurely, use `--no-check-certificate'.
Thank You

Re: [ Qapache + PHP 7.2.7 ] [ 2.4.33 ] Apache WebServer + PHP + Extension

Posté : 11 juil. 2018 17:26
par dumb4ever
dumb4ever a écrit :
09 juil. 2018 09:41
How can one use port 443 for Virtual Host web server ?
Is there a specific instruction that we can follow ?

What i did to have port 443 to star is by going on Qnap Setting:
1. System
2. General Settings
3. System Administration tab
4. Enable secure connection (HTTPS) to 443

but when i run this command:
wget --header="Host: site.domain.com" -O - https://localhost
I get:
[~] # wget --header="Host: site.domain.com" -O - https://localhost
--2018-07-09 22:56:41-- https://localhost/
Resolving localhost (localhost)... 127.0.0.1
Connecting to localhost (localhost)|127.0.0.1|:443... connected.
ERROR: no certificate subject alternative name matches
requested host name ‘localhost’.
To connect to localhost insecurely, use `--no-check-certificate'.
Thank You
I actually manage to get it all running on 80 and 443 :) if anyone have any question, feel free to ask and i'll do my best to answer.

Thanks