[ Qapache + PHP 7.2.8 ] [ 2.4.33 ] Apache WebServer + PHP + Extension

BitTorrent Sync, KODI, IPKG, NZBGet, pyLoad...
osimood
Messages : 15
Enregistré le : 26 septembre 2016

Re: [ Qapache + PHP 7.2.4 ] [ 2.4.29 ] Apache WebServer + PHP + Extension

Message par osimood » 09 avr. 2018 12:38

aliasjcdenton a écrit :
09 avr. 2018 01:32
osimood a écrit :
09 avr. 2018 00:50
I can not delete the folder where the data is "corrupted"... typically I have this type of error:
rm: can't remove 'XYZ': No such file or directory
what to do?...
I had exactly the same problem right after I updated Qapache to the last version [ Qapache + PHP 7.2.4 ] [ 2.4.29 ].

Impossible to run Qapache, impossible to reinstall it, and impossible to uninstall it from the AppCenter or manually with command line. Lot of files are corrupted and when you run the "ls -alh" command in Qapache directory and subdirectories, only the filenames are displayed, but all the permissions are replaced with question marks (something like ????????? ???????? ????).

And the worst is that it propagated to other directories and shared folders. First I thought about a virus, then I scanned with Malware remover and antivirus but found nothing.

Then I immediately backuped all my files which were still not corrupted and reseted my NAS and I'm actually reinstalling it from scratch.

Now I don't know if I can reinstall the last version of Qapache or if I have to install a previous version... :( :cry:
That is indeed EXACTLY the problem I am facing.
- TS-563 with latest firmware and encrypted partition

aliasjcdenton
Messages : 26
Enregistré le : 02 septembre 2016

Re: [ Qapache + PHP 7.2.4 ] [ 2.4.29 ] Apache WebServer + PHP + Extension

Message par aliasjcdenton » 09 avr. 2018 13:11

TS-451+ with last firmware and encrypted disks too. Before I updated Qapache to the latest version, everything was ok. But now I'm unable to say that Qapache is responsible or not. Just right after the update I was unable to run Qapache anymore, nor to uninstall it, even with "rm -rf" command. And "ls -alh" returned "????????? ???'?" permissions.

What is strange is that it even propagated in NextCloud folder structure.

I suspected a virus but nothing found. Then I checked the disks but no filesystem problem too. Then since I really need my NAS, I formatted it to reinstall it completely.

I'm unfortunatelly unable to determine what is the problem... :-(

And now I think I wiil reinstall a previous version of Qapache, waiting to see if other people faced the same problem and found a solution, in case the problem came from Qapache...

osimood
Messages : 15
Enregistré le : 26 septembre 2016

Re: [ Qapache + PHP 7.2.4 ] [ 2.4.29 ] Apache WebServer + PHP + Extension

Message par osimood » 09 avr. 2018 14:48

That is interesting! Indeed it propagate, but for me it even was outside the htdocs folder:
- one folder in htdocs can not be deleted.
- one database (QMariaDB) can not be deleted either... (files remaining)

I really do not want to have to wipe my NAS again....

aliasjcdenton
Messages : 26
Enregistré le : 02 septembre 2016

Re: [ Qapache + PHP 7.2.4 ] [ 2.4.29 ] Apache WebServer + PHP + Extension

Message par aliasjcdenton » 09 avr. 2018 15:02

It affected some folders in my home folder too (in "homes" share) containing some movies and pictures that were then unable to be deleted too and with "??????????" permissions.

Really strange.

Avatar du membre
QoolBox
Représentant de QNAP
Messages : 6122
Enregistré le : 02 janvier 2014
Professionnel : Oui
Localisation : France
Contact :

Re: [ Qapache + PHP 7.2.4 ] [ 2.4.29 ] Apache WebServer + PHP + Extension

Message par QoolBox » 09 avr. 2018 19:02

bad news regarding 2.4.33... it is conflicting on compilation with some headers from 2.4.29

it needs a full recompilation once again :(

that will take a lot of time

osimood
Messages : 15
Enregistré le : 26 septembre 2016

Re: [ Qapache + PHP 7.2.4 ] [ 2.4.29 ] Apache WebServer + PHP + Extension

Message par osimood » 09 avr. 2018 19:05

QoolBox a écrit :
09 avr. 2018 19:02
bad news regarding 2.4.33... it is conflicting on compilation with some headers from 2.4.29

it needs a full recompilation once again :(

that will take a lot of time
Thank you for the update. two small questions Stephane:
Any chance to have an x86 version for older NAS that are not supported ?
Did you have a look at the issue described above and would have any clue about what is causing it ?
Merci beaucoup pour ton boulot !
O

Avatar du membre
QoolBox
Représentant de QNAP
Messages : 6122
Enregistré le : 02 janvier 2014
Professionnel : Oui
Localisation : France
Contact :

Re: [ Qapache + PHP 7.2.4 ] [ 2.4.29 ] Apache WebServer + PHP + Extension

Message par QoolBox » 09 avr. 2018 19:07

No more x86 glibc is too old.. and too many patch are needed to make it compile correctly

no idea about the error... here all is working perfectly on x86-64, arm64 and armx41
Modifié en dernier par QoolBox le 09 avr. 2018 20:21, modifié 1 fois.

osimood
Messages : 15
Enregistré le : 26 septembre 2016

Re: [ Qapache + PHP 7.2.4 ] [ 2.4.29 ] Apache WebServer + PHP + Extension

Message par osimood » 09 avr. 2018 19:17

Out of curiosity, do you use encrypted partitions ?

osimood
Messages : 15
Enregistré le : 26 septembre 2016

Re: [ Qapache + PHP 7.2.4 ] [ 2.4.29 ] Apache WebServer + PHP + Extension

Message par osimood » 09 avr. 2018 20:09

osimood a écrit :
09 avr. 2018 19:17
Out of curiosity, do you use encrypted partitions ?
or is there any log files or test I can provide to help resolving this for future updates ?

Toxic
Padawan
Messages : 86
Enregistré le : 21 février 2015

Re: [ Qapache + PHP 7.2.4 ] [ 2.4.29 ] Apache WebServer + PHP + Extension

Message par Toxic » 10 avr. 2018 01:40

QoolBox a écrit :
09 avr. 2018 19:02
bad news regarding 2.4.33... it is conflicting on compilation with some headers from 2.4.29

it needs a full recompilation once again :(

that will take a lot of time
OK no worries, Take your time. Thanks for the update though!
Regards Simon

TVS-463-16G 4 x NIC - 4.3.4.0597 - TS-453BT3 4.3.4.0597 - TS-121 - 4.3.3.0546
Network: VM Hub3 (200/10) - Sophos XG 17.1.0 GA - UCK - UniFi AP AC Pro / AC Lite - TL-SG1016DE - Cisco SLM2008

Répondre

Retourner vers « Applications tierces »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 4 invités