Forum des NAS

Tous les fabricants de NAS réunis sur un forum unique : Asustor, Qnap, Synology...

BitTorrent Sync, KODI, IPKG, NZBGet, pyLoad...

Modérateur : QoolBox

#82851
QoolBox a écrit : 05 nov. 2019 08:42 that might happen because symlink fro QJDK8 is not present in your /opt

they can be multiple reason

as I've done a clean QDJ installation I do not know why there is not the link. In any case to have an absolute path is bad as the QPKG can decide to change the path as they like.

(I use a QTS 4.2.6 as I cannot move to 4.4.x because is an old NAS)

M

#82860
msavazzi a écrit : 24 nov. 2019 17:33 Sorry to bother but with latest version X86 (I have an old nas with OS 4.2.6, I cannot move to 4.4.x)
I get thousands of:
Code : Tout sélectionner
[2019-11-24T16:31:28,146] <localhost-startStop-1> INFO  db     - waiting for db connection...
[2019-11-24T16:31:28,146] <localhost-startStop-1> INFO  db     - waiting for db connection...
[2019-11-24T16:31:28,146] <localhost-startStop-1> INFO  db     - waiting for db connection...
[2019-11-24T16:31:28,146] <localhost-startStop-1> INFO  db     - waiting for db connection...
[2019-11-24T16:31:28,146] <localhost-startStop-1> INFO  db     - waiting for db connection...
[2019-11-24T16:31:28,146] <localhost-startStop-1> INFO  db     - waiting for db connection...
[2019-11-24T16:31:28,146] <localhost-startStop-1> INFO  db     - waiting for db connection...
[2019-11-24T16:31:28,146] <localhost-startStop-1> INFO  db     - waiting for db connection...
[2019-11-24T16:31:28,146] <localhost-startStop-1> INFO  db     - waiting for db connection...
and is not working.

Can you please check?

I tried to install both the X86 and the X86_X64 version but they never start. Remain locked.
I upgraded the NAS, removed old Unifi folder, tried a clean install with no luck

EDIT: I re installed version Unifi_5.11.50.1_x86 and worked at the first try :)
so there is something weird on the QPKG... sorry

#83320
QoolBox a écrit : 28 nov. 2019 13:51updated

I have an old 659. It run the OS 4.2.6 that is 32 bit.

Can you be so kind to package it even for this version?

I've tried to install the X86_X64 and it does not start, from the log:

Code : Tout sélectionner
[2019-12-04T19:16:16,700] <localhost-startStop-1> INFO  system - ======================================================================
[2019-12-04T19:16:16,727] <localhost-startStop-1> INFO  system - UniFi 5.12.35 (build atag_5.12.35_12979 - release/release) is started
[2019-12-04T19:16:16,728] <localhost-startStop-1> INFO  system - ======================================================================
[2019-12-04T19:16:16,731] <localhost-startStop-1> INFO  system - BASE dir:/share/MD0_DATA/.qpkg/Unifi/UniFi
[2019-12-04T19:16:16,951] <localhost-startStop-1> INFO  system - Current System IP: 169.254.100.100
[2019-12-04T19:16:17,999] <localhost-startStop-1> INFO  system - Hostname: nas-homelan
[2019-12-04T19:16:19,763] <localhost-startStop-1> INFO  db     - waiting for db connection...
[2019-12-04T19:16:22,513] <db-server> INFO  db     - DbServer stopped
[2019-12-04T19:16:26,611] <db-server> INFO  db     - DbServer stopped
[2019-12-04T19:16:30,634] <db-server> INFO  db     - DbServer stopped

I think this is the issue:

Code : Tout sélectionner
[/share/MD0_DATA/.qpkg/Unifi/UniFi/bin] # ./mongo
./mongo: error while loading shared libraries: librt.so.1: wrong ELF class: ELFCLASS32
[/share/MD0_DATA/.qpkg/Unifi/UniFi/bin] # ./mongod
./mongod: error while loading shared libraries: librt.so.1: wrong ELF class: ELFCLASS32

Thank you
M

#83384
QoolBox a écrit : 05 déc. 2019 23:35 I will try to setup a a NAS with an old 4.2.5 to be in 32bit.. and check

but just saw that MongoDB do not support anymore 32bit architecture.. may be the root of the problem, if a newer mongodb version is required to run latest version

Argh! this would be bad indeed.

M

#83945
QoolBox a écrit : 05 déc. 2019 23:35 I will try to setup a a NAS with an old 4.2.5 to be in 32bit.. and check

but just saw that MongoDB do not support anymore 32bit architecture.. may be the root of the problem, if a newer mongodb version is required to run latest version

Were you able to check?
I did other test but I'm not too good and was not able to solve it

  • 1
  • 15
  • 16
  • 17
  • 18
  • 19
  • 24

Merci pour ce retour

NAS premiers pas

Salut, tu devras étendre ta partition avec[…]

Remplacement DD et bruit

Les dernières livraisons de disques sont pl[…]

Coupure Courant TS-219P

Tu pourrais si tu avais un NAS de la même ma[…]

Site hébergé sur un serveur IKOULA

Ikoula