Forum des NAS

Tous les fabricants de NAS réunis sur un forum unique : Asustor, Qnap, Synology...

BitTorrent Sync, KODI, IPKG, NZBGet, pyLoad...

Modérateur : QoolBox

Source :

Download :x86 , x31, x41, arm64, arm-x19, x64

Transmission is a fast, easy, and free BitTorrent client.


QPKG Integration

Config file : /opt/QTransmission3/etc/config/json
default credential : qnap /qnap

Hi again,

I have been testing out v3.0 on my Qnap TS-1677X, and it is acting a little weird.

The installation works flawless (used the repo in Qnap WebGUI), and I edit the settings.json, and that is working, so far so good.

Today after it have been running all night, my system memory was low. I have 16 GB, and 2 GB reserved for a VM server. That have never happened before.

I checked Transmission through Transmission Remote GUI, and saw a couple of trackers had no connection, checked if Transmission v3 was whitelisted on the sites, and only one of them hadn't whitelisted it yet.

I removed Transmission completely from the NAS, rebooted, updated the firmware (manually), installed Transmission v3 (downloaded the file manually), stopped the service, edited settings.json, started the server.

The settings was back to the old settings with qnap / qnap and so on. Tried a few times and finally it went through.

It was still the same with the trackers as before - the same ones didn't work.

Tried a new port number - same result (yes, I have opened it in my router).

Tried to test the port through Transmission Remote GUI, and got and error with no http. Tested it on my other 2 Qnap's, and they responded with everything working (they run Transmission 2.94).

Shut down the Transmission app through App Center in Qnap WebGUI, but noticed that Transmission Remote GUI still had access to Transmission v3 on that NAS, so it's like there is running another instance of Transmission v3 in the background...

I have never experienced this before, and have been using Transmission for years on my Qnap systems...
Thanks for the latest update!

I have to mention that it has overwritten my settings, which are not located as indicated in

Config file : /opt/QTransmission3/etc/config/json
but rather in /opt/QTransmission3/etc/settings.json

Also, I am moving my post from the previous version to this thread:

It would be great to add to the release the improved Web Interface found here:

Steps I have followed to install.

  • Stop Transmission, this is important as changes are reverted if Transmission is running.
  • Clone web server tree is found here: ... master/src
  • Copy the files from the download src folder to /opt/QTransmission3/share/transmission (in my NAS)
    I have created a folder called remote-control.
  • Edit (/opt/QTransmission3/) and add the line
    Code : Tout sélectionner
    export TRANSMISSION_WEB_HOME=$QPKG_ROOT/share/transmission/remote-control
    Code : Tout sélectionner
    export HOME=$QPKG_ROOT
  • Restart Transmission and the new interface should be online.

I guess that an upgrade will overwrite the file, which will need to be edited again while maintaining the settings.


Do not be frightened by the Chinese screen captures, although the readme ( is in chinese, the web interface is actually in English, and it has some other languages as well as French and Spanish (as shown here: ... ntrol/i18n)
For the English read me: ... ntrol/wiki

I have not used the install script, rather than that I performed the steps listed in my previous post.
The install script stored here ( ... may perform other activities. You could take a look to understand its inner working. I lack some knowledge to fully understand it.

In my setup:

Thanks again and regards.

Je ne connais pas Asustor, mais tu es sur du puid/[…]

Salut, Synology utilisant le port 80/443 il n'y a[…]

Salut, Pour OpenVPN, je prévois un tuto pou[…]

Suite des mes péripéties. Les point[…]

Site hébergé sur un serveur IKOULA