Forum des NAS

Tous les fabricants de NAS réunis sur un forum unique : Asustor, Qnap, Synology...

BitTorrent Sync, KODI, IPKG, NZBGet, pyLoad...

Modérateur : QoolBox

#85940
Image

Source : https://www.php.net/

Download :

https://www.qnapclub.eu/fr/qpkg/866

about :

Replace the embedded Qnap PHP version to latest 7.4.x branch

configuration file directory : /opt/PHPFPM74/etc
logs directory : /opt/PHPFPM74/var/log

be carefull : some php applications are not yet compatible with PHP 7.4.x branch
disabling this qpkg, make you roll back to Qnap embedded PHP-FPM 7.3

php error logs enable by default :

cross compiled with the following modules enabled :

Code : Tout sélectionner
[PHP Modules]
amqp
apcu
bcmath
bitset
bz2
calendar
Core
ctype
curl
date
dba
dom
eio
ev
event
exif
fileinfo
filter
ftp
gd
geoip
gettext
gmp
gnupg
grpc
hash
hprose
hrtime
http
iconv
igbinary
imagick
inotify
intl
json
krb5
ldap
libxml
mailparse
mbstring
mcrypt
memcached
mongodb
msgpack
mysqli
mysqlnd
OAuth
odbc
openssl
pcntl
pcre
PDFlib
PDO
pdo_dblib
pdo_mysql
PDO_ODBC
pdo_pgsql
pdo_sqlite
pgsql
Phar
posix
propro
pspell
radius
raphf
readline
redis
Reflection
scrypt
session
shmop
SimpleXML
snmp
soap
sockets
sodium
solr
SPL
sqlite3
standard
swoole
taint
tidy
timezonedb
tokenizer
xattr
xdebug
xml
xmlreader
xmlrpc
xmlwriter
xsl
xxtea
yaml
Zend OPcache
zip
zlib

[Zend Modules]
Xdebug
Zend OPcache
#93121
bonjour

cela ne marche pas chez moi
j'ai mis le package depuis l'interface, mais en ligne de commande j'ai toujours :

[~] # /mnt/ext/opt/apache/bin/php -v composer.phar install
PHP 7.3.7 (cli) (built: Jul 2 2020 04:34:05) ( NTS )
Copyright (c) 1997-2018 The PHP Group

dans le dossier, j'ai toujours des liens sur la 7.3 , il me semblait avoir compris que cette version devait remplacer la version 7.3 embarqué sur le nas, c'est bien cela ?

Code : Tout sélectionner

-rwxr-xr-x 1 admin administrators    60384 2020-07-01 22:21 pcretest*
lrwxrwxrwx 1 admin administrators        6 2020-07-12 11:07 php -> php7.3*
-rwxr-xr-x 1 admin administrators 10823576 2020-07-01 22:36 php7.3*
-rwxr-xr-x 1 admin administrators 10766056 2020-07-01 22:36 php-cgi*
lrwxrwxrwx 1 admin administrators       10 2020-07-12 11:07 php-fpm -> php-fpm7.3*
-rwxr-xr-x 1 admin administrators 10867032 2020-07-01 22:36 php-fpm7.3*
lrwxrwxrwx 1 admin administrators       10 2020-07-12 11:07 php-fpm-proxy -> php-fpm7.3*
-rwxr-xr-x 1 admin administrators     8552 2020-07-01 22:21 pwauth*
-rwxr-xr-x 1 admin administrators    19496 2020-07-01 22:21 rotatelogs*


hors j'ai besoin d'avoir php 7.4.5 a minima pour une application en symfony
merci

25 octobre 2020 - 16h00. Bonjour, Je me bat toujo[…]

Salut, Je vois que tu as déjà bien[…]

Bonjour à tous, j'ai une sonnette "rin[…]

Compte Outlook avec Qmail Agent

Bonjour, pour moi, ce n'est pas très clair […]

Site hébergé sur un serveur IKOULA

Ikoula