[ Qapache + PHP 7.2.18 ] [ 2.4.39 ] Apache WebServer + PHP + Extensions

BitTorrent Sync, KODI, IPKG, NZBGet, pyLoad...
Avatar du membre
QoolBox
Représentant de QNAP
Messages : 7070
Enregistré le : 02 janvier 2014
Professionnel : Oui
Localisation : France
Contact :

Re: [ Qapache + PHP 7.2.15 ] [ 2.4.38 ] Apache WebServer + PHP + Extensions

Message par QoolBox » 02 mars 2019 14:16

tu as déjà un mariaDB embarqué.. certes ancienne mais fonctionnel

faut que je retravaille le qpkg mariadb du qnapclub car il interfere avec le socket de celle embarqué

phpmyadmin tu l'installé dans ton répertoire htdoc directement... attention de bien modifier le passe root de l'accés a MariaDB

Gesualda
Messages : 25
Enregistré le : 28 janvier 2019
Professionnel : Non

Re: [ Qapache + PHP 7.2.15 ] [ 2.4.38 ] Apache WebServer + PHP + Extensions

Message par Gesualda » 02 mars 2019 15:28

Merci de ce retour. J'ai rajouté un mot de passe à ROOT et rajouter un utilisateur. J'ai testé mes sites, tout fonctionne en HTTP.

Je voudrais rajouter que je n'arrive pas à acceder aux sites à partir de l'extérieur. Port 88 ouvert :
local : Num_IP_local:88/mon_dossier/ => Pas de soucis
Ext : IP_BOX:88/mon_dossier/ => Ne fonctionne pas (pour ce qui concerne le PHP).

Merci
L'impossible d'aujourd'hui sera possible demain.
----------------
TS-473 - 8go ram - Raid5 - 3 disques wd20 2To

Avatar du membre
QoolBox
Représentant de QNAP
Messages : 7070
Enregistré le : 02 janvier 2014
Professionnel : Oui
Localisation : France
Contact :

Re: [ Qapache + PHP 7.2.16 ] [ 2.4.38 ] Apache WebServer + PHP + Extensions

Message par QoolBox » 05 mars 2019 18:03

updated

Gesualda
Messages : 25
Enregistré le : 28 janvier 2019
Professionnel : Non

Re: [ Qapache + PHP 7.2.16 ] [ 2.4.38 ] Apache WebServer + PHP + Extensions

Message par Gesualda » 13 mars 2019 21:12

Bonjour,

J'ai fais la mise à jour après le dernier Update, ca marche nikel. Merci beaucoup.
Par contre, j'ai besoin d'adapter le php.ini. Pourrais je savoir ou trouver le fichier dans qapache ?

Merci beaucoup
JL
----------------------------------
J'édite le message, j'ai trouvé (enfin j'espère) : opt/etc/conf/
L'impossible d'aujourd'hui sera possible demain.
----------------
TS-473 - 8go ram - Raid5 - 3 disques wd20 2To

Toxic
Padawan
Messages : 97
Enregistré le : 21 février 2015

Re: [ Qapache + PHP 7.2.16 ] [ 2.4.38 ] Apache WebServer + PHP + Extensions

Message par Toxic » 13 mars 2019 21:22

Gesualda a écrit :
13 mars 2019 21:12
Bonjour,

J'ai fais la mise à jour après le dernier Update, ca marche nikel. Merci beaucoup.
Par contre, j'ai besoin d'adapter le php.ini. Pourrais je savoir ou trouver le fichier dans qapache ?

Merci beaucoup
JL
----------------------------------
J'édite le message, j'ai trouvé (enfin j'espère) : opt/etc/conf/
Hello. excuse my lack of french, but you will find php.ini here: /share/CACHEDEV1_DATA/.qpkg/Qapache/etc/conf/php.ini
Regards Simon

TVS-463-16G - 4.3.6.0875 - TS-453BT3 4.3.6.0875 - TS-121 - 4.3.3.0789
Network: VM Hub 3.0 <500/35> • UniFi USG Pro4 • UniFi USW-16-150W / USW-8-60W • UniFi CloudKey G2+ • UAP AC Pro / AC Lite • Dell 7050 MFF

Gesualda
Messages : 25
Enregistré le : 28 janvier 2019
Professionnel : Non

Re: [ Qapache + PHP 7.2.16 ] [ 2.4.38 ] Apache WebServer + PHP + Extensions

Message par Gesualda » 13 mars 2019 21:45

Hello Toxic, I had just found. thank you for the information
L'impossible d'aujourd'hui sera possible demain.
----------------
TS-473 - 8go ram - Raid5 - 3 disques wd20 2To

Gesualda
Messages : 25
Enregistré le : 28 janvier 2019
Professionnel : Non

Re: [ Qapache + PHP 7.2.16 ] [ 2.4.38 ] Apache WebServer + PHP + Extensions

Message par Gesualda » 14 mars 2019 12:18

bonjour Qoolbox

J'ai une question simple que je n'arrive pas à résoudre, alors je demande peut etre des pistes.
J'utilise Piwigo et la création des miniatures ne se fait pas. Tester sous windows avec wampserveur, et la création se fait( Alors rien à voir avec le script => Piwigo, d’où ma question).

Je pense que la relation se fait avec la librairie de GD et GD2. Après vérification dans info(), la librairie est activé. Mais bizarrement cela ne fonctionne pas. J'ai donc téléchargé une librairie php_gd.so et j'ai testé avec php.ini, rien à faire.
la, je sèche, j'ai besoin de conseil.

Merci d'avance
L'impossible d'aujourd'hui sera possible demain.
----------------
TS-473 - 8go ram - Raid5 - 3 disques wd20 2To

Gesualda
Messages : 25
Enregistré le : 28 janvier 2019
Professionnel : Non

Re: [ Qapache + PHP 7.2.16 ] [ 2.4.38 ] Apache WebServer + PHP + Extensions

Message par Gesualda » 14 mars 2019 22:52

J'ai trouvé la solution dans mon cas et je permets de le rajouter ici. Cela peut toujours servir !
Il a fallu retrouver le chemin (path) de Imagemagick. Pour ce faire j'ai utilisé ce petit script :

Code : Tout sélectionner

<?php
echo "<pre>";
system("type -a convert");  
echo "</pre>";
?>
J'ai rajouté le script dans "LocalFiles" =>

Code : Tout sélectionner

$conf['ext_imagick_dir'] = 'ICI VOTRE CHEMIN COMPLET';
Ce qui est étonnant c'est qu'il ne retrouvait pas le chemin tout seul. Bref maintenant, j'en arrete la, pour ne pas poluer le post.
Merci
L'impossible d'aujourd'hui sera possible demain.
----------------
TS-473 - 8go ram - Raid5 - 3 disques wd20 2To

Avatar du membre
QoolBox
Représentant de QNAP
Messages : 7070
Enregistré le : 02 janvier 2014
Professionnel : Oui
Localisation : France
Contact :

Re: [ Qapache + PHP 7.2.16 ] [ 2.4.38 ] Apache WebServer + PHP + Extensions

Message par QoolBox » 22 mars 2019 20:15

pre-release x64 version downloadable at :

http://www.qoolbox.fr/Qapache_2438.7216 ... 4.qpkg.zip

Code : Tout sélectionner

All libs and extension updated to latest version
move to OpenSSL 1.1.1b (branch)
fixed Qapache do not start on x73 series (due to mod_ssl)
php core updated to 7.2.17RC1

extension added :

gender
igbinary
lzf
seaslog
taint
xmldiff
xmlreader
xmlwriter

Known issue

libsodium extension error


Gesualda
Messages : 25
Enregistré le : 28 janvier 2019
Professionnel : Non

Re: [ Qapache + PHP 7.2.16 ] [ 2.4.38 ] Apache WebServer + PHP + Extensions

Message par Gesualda » 23 mars 2019 08:49

Hello Qoolbox, merci énormément de cette mise à jour, cela fonctionne maintenant sur le TS-473. Je testerai SSL dans les jours à venir.

Juste une petite question. J'ai du, par commodité personnelle, modifié le port d'accès dans la config. cela fonctionne pas de soucis. Par contre le chemin n'est pas reconnu automatiquement par l'interface de configuration (du NAS). Peut-on le changer ou bien dois je le rajouter manuellement à chaque accès ?

Merci encore !
JLuc
L'impossible d'aujourd'hui sera possible demain.
----------------
TS-473 - 8go ram - Raid5 - 3 disques wd20 2To

Répondre

Retourner vers « Applications tierces »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 5 invités