Forum des NAS

Tous les fabricants de NAS réunis sur un forum unique : Asustor, Qnap, Synology...

Photo Station, Music Station, Video Statio, Download Station, HD Station, HappyGet...
par Antony91700
#82837
Bonjour,
J'ai un problème d'accès par internet à WordPress Multisite sur mon QNAP.
J'ai trouvé le bug dans wordpress, cela ressemble à un problème d'adresse relative et absolue dans wp-config ou htaccess.
J’explique la manip toute simple :
J'installe fraîchement wordpress et phpmyadmin (un site de test quasiment vide) où j'ai fait les mises à jour
Je vérifie s'il est accessible en IP local 192.168. x.xx : cela fonctionne nickel
Je vérifie s'il est accessible depuis mon IP fixe (82.64.xxx.xxx) : cela fonctionne nickel-chrome !

Je crée un réseau Multisite (toujours aussi fraîchement installé et quasiment vide) à partir du wordpress ci-dessus.
Je vérifie s'il est accessible en IP local 192. 168, etc.... : cela fonctionne bien !
Je vérifie s'il est accessible depuis mon IP fixe (82.64, etc..), cela fait un loopback sur l'IP locale
Je vérifie sur mon smartphone en 4G et là : page d'erreur.
J'ai un peu creusé la question, voici la partie wp-config pour info
/* Multisite */
/*define('WP_ALLOW_MULTISITE', true);
define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', false);
define('DOMAIN_CURRENT_SITE','192.168.0.36');
define('PATH_CURRENT_SITE', '/WordPress/');
define('SITE_ID_CURRENT_SITE', 1);
define('BLOG_ID_CURRENT_SITE', 1); */

si je mets en commentaires /* non exécuté comme ci-dessus je reviens en monosite accessible par internet
Si je retire le mode commentaires je reviens en multisite non accessible depuis internet.
Si je mets en commentaires la ligne define(Domaine current site .....) , il n'y a plus d'accès à la base de données.....
Si je mets mon URL fixe idem, ça ne marche pas par internet, pas mieux .....
Cette URL absolue empêche l'accès depuis internet.
Je pense que le htaccess pointe l'IP locale ( d'où le loopback) : ci après à titre d'information
RewriteEngine On
RewriteBase /WordPress/
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]

Je pense qu'il doit y avoir un petit truc à faire pour que cela marche.
Pour créer un WordPress Multisite j'ai suivi ce tuto
https://www.gregoirenoyelle.com/wordpre ... u-de-site/
Si quelqu'un peut refaire la manip sur son QNAP, et me proposer une solution, je serais très reconnaissant.
Je pense que tous les possesseurs d'un NAS QNAP qui hébergent un Wordpress Multisite sont concernés, et je ne trouve rien sur internet pour aider.

Cordialement
Antony
Avatar de l’utilisateur
par Jeanphil
#83035
Rare pour être souligné :
Merci Antony pour ton retour avec la solution 8-)

Re, Désolé pour cce retard :oops: […]

Erreur réseau 0x8007003

Bonjour à tous. J'essaye de transfér[…]

Firmware DSM 6.2.3-25426

Je viens de l'avoir aussi. :plusun:

CloudSync et le chiffrement

Je n'ai jamais testé... à essayer.

Site hébergé sur un serveur IKOULA

Ikoula