HD Station et VPN

Photo Station, Music Station, Video Statio, Download Station, HD Station, HappyGet...
yellowapple
Messages : 8
Enregistré le : 24 février 2018

Re: HD Station et VPN

Message par yellowapple » 22 janv. 2019 20:05

Bonsoir,

Avec plaisir pour le coup de main. Possible d'avoir une petite capture du network et virtual switch? Quel est le modèle de NAS?
Le PFsense est installé sur le virtualisation station. 1 et 2 sont deux possibilités pour la connectique réseau.
Le mode bridge permet un contrôle plus important si un firewall est installé. Mais il va falloir effectivement rajouter un AP interne.

A+
yA

Gorille
Padawan
Messages : 86
Enregistré le : 10 janvier 2016

Re: HD Station et VPN

Message par Gorille » 08 avr. 2019 17:06

Bonjour,

Réponse horriblement tardive mais j'ai eu pleins d'autres priorités et peu de temps pour faire des tests.
Pour répondre à tes questions :
- Mon NAs est un TS 453a
- Ci dessous 2 captures d'écran :
1 - Le VSwitch que j'ai créé entre les prises Ethernet #1 & #2 du NAS (mon routeur ISP est sur #1 et fourni la connectivité internet, ma SmartTV est pluguée via cable ethernet sur #2). L'adresse IP du VSwitch est la même que l'adresse locale de mon NAS
2 - La config QVPN que j'utilise

Avec ce set-up, ma SmartTV arrive à se connecter à internet (via le NAS donc) MAIS Le VPN ne marche pas : Le client VPN se connecte bie nau serveur NordVPN mais ni le traffic de la SmartTV, ni celui du NAS (j'ai essayé un browser dans HD Station) ne passe par le VPN....

NOTE : Si je supprime le VSwitch, la même config QVPN marche tres bien (testée également via un browser de HD Station)

A mon avis le problème est dans l’interaction entre le VSwitch et QVPN mais aucune idée de ce que cela peut être...

Des idées?

Merci par avance!!

Gorille

VSwitch
VirtualSwitch.png
QVPN Config
QVPN Config.png

Gorille
Padawan
Messages : 86
Enregistré le : 10 janvier 2016

Re: HD Station et VPN

Message par Gorille » 16 avr. 2019 17:51

Bonjour a tous,

Bon juste histoire de laisser une trace au cas ou quelqu'un à le même problème car je l'ai finalement résolu :-P
Vous pourrez au passage découvrir à quel point je suis une bille en réseau :lol:

Donc pour mémoire je cherchais initialement à utiliser le VPN de mon NAS (via QVPN et mon fournisseur de VPN "Nord VPN") pour le trafic internet de ma SmartTV. Je pensais que pour cela il fallait absolument que ma TV soit connectée en ethernet au NAS. Du coup j'avais créé un VSwitch pour donner de la connectivité internet sur l'adaptateur #2 du NAS auquel je reliais ma TV. Ça marchait bien mais dès que je démarrais ma connexion VPN, la connexion internet de la TV était perdue...

Au final j ai trouvé la solution sur un forum de support Synologie :-)
En fait le VSwitch était complètement inutile, je peux connecter ma TV sur mon router ISP et juste indiquer dans les réglages réseaux de la TV l'adresse IP de mon NAS en passerelle (par défaut c’était le router ISP).
Du coup la TV récupère internet via le NAS même si elle est branchée sur mon router ISP.
Enfin il faut penser a changer le DNS (toujours sur les réglages de la TV) pour qu'il pointe sur le DNS de mon fournisseur de VPN (Nord VPN).

Et la tout marche nickel avec ou sans connexion VPN.

Au final je pense que la configuration avec le VSwitch peut marcher si on remplace juste le DNS (pas besoin de changer la passerelle par défaut du coup) mais bon vu que c'est inutile j'ai laissé la TV sur le routeur ISP.

Par contre je ne me suis pas amusé à regarder si la bande passante ou le ping est moins bon maintenant que le NAS fait office de passerelle pour la TV. En tout cas rien d'évident à l'oeil nu!

Voilà et merci encore YellowApple pour ton aide.

Gorille

Répondre

Retourner vers « Applications officielles »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité