NAS TS251+ Configurer VPN ?

Discussion sur le paramétrage du NAS
plemo
Padawan
Messages : 106
Enregistré le : 21 septembre 2015
Professionnel : Non
Localisation : 78

NAS TS251+ Configurer VPN ?

Message par plemo » 07 févr. 2019 17:41

Bonjour à tous

Je suis en train de regarder et m'intéresser au VPN pour mon installation .
Je comprend quelques trucs mais pas d'autres.
J'ai cherché un peu sur le Fofo mais pas trouvé mes réponses dans les topics.

J'explique mon besoin : je souhaite utiliser le vpn entre mon NAS et Internet, entre mon ordinateur et Internet, entre mon smartphone et Internet.
Jusque la Ok, j'ai vu des tutos pour configurer chaque appareil suivant le protocole etc .
Mais j'aimerai aussi que la connexion entre mes appareils et mon NAS soient protégées par VPN également (du moins si faisable et nécessaire)

Ma question : dans QVPN, qu'est ce que l'onglet "VPN Server" ???
Car tous les tutos que je vois configurent la partie "VPN Client" ...

Merci d'avance
Nas : Qnap TS-251+ 4.3.3

Chon
Padawan
Messages : 92
Enregistré le : 07 février 2018

Re: NAS TS251+ Configurer VPN ?

Message par Chon » 08 févr. 2019 09:03

Salut,

La réponse est dans ta question.

Dans la partie Serveur, tu paramètres ton NAS pour qu'il devienne accessible depuis n'importe où dans le Monde (accès WAN pour Wild Access Network) via un protocole VPN (le plus sécure étant OpenVPN). L'ordinateur ou phone distant est alors le client et le NAS le serveur.
Une fois connecté, c'est comme si tu étais sur ton réseau local (LAN pour Local Acces Network).
Dans la partie Client, c'est l'inverse, tu souhaites rendre ton NAS plus anonyme sur internet, tu te connectes alors à un service VPN extérieur (payant si tu veux un service de qualité). Le NAS est alors client et le service extérieur serveur.

Tu peux bien sûr faire les 2 en même temps. :wink:
QNAP TS-269L
SYNOLOGY DS-713+

plemo
Padawan
Messages : 106
Enregistré le : 21 septembre 2015
Professionnel : Non
Localisation : 78

Re: NAS TS251+ Configurer VPN ?

Message par plemo » 08 févr. 2019 10:03

Wouahouh merci pour les réponses précises c'est tout ce que j'espérais :-D

Donc oui bien sur je parle d'un VPN payant je regardais un peu hier soir .

D'accord en gros : Server VPN : accès au NAS en VPN sécurisé
Client VPN : accès au Net de l'appareil en question en VPN sécurisé

Les 2 en meme temps c'est mon souhait évidemment .

Donc j'aurai à paramétrer la partie Server ainsi que la partie Client.

L'Open VPN est le plus secure ? OK merci pour l'info car effectivement je vois tout un tas de protocoles
Nas : Qnap TS-251+ 4.3.3

plemo
Padawan
Messages : 106
Enregistré le : 21 septembre 2015
Professionnel : Non
Localisation : 78

Re: NAS TS251+ Configurer VPN ?

Message par plemo » 08 févr. 2019 18:11

Euh il me vient une question ultime .

Utilisant le wifi chez moi entre mon Android et ma box par exemple, comment ça va se passer pour le vpn ?

Car le wifi va utiliser directement la box mais le vpn aura été paramétré seulement sur nas et ordi. Pas sur la box ...

Du coup, est-il possible de paramétrer le vpn directement sur la box pour que chaque appareil de la maison qui utilise l'ip wan de la box soient directement sous le vpn ?

Merci
Nas : Qnap TS-251+ 4.3.3

plemo
Padawan
Messages : 106
Enregistré le : 21 septembre 2015
Professionnel : Non
Localisation : 78

Re: NAS TS251+ Configurer VPN ?

Message par plemo » 08 févr. 2019 21:12

Bon en fait je suis clairement perdu :cry:

Je suis paumé entre le fait de devoir configurer Server ou Client.

Un truc que je comprend pas pour la maison : chaque appareil passe par la box pour aller sur le net, donc pourquoi ne pas paramétrer la box en client vpn et donc chaque appareil (ordi, NAS) serai donc sous le VPN de la box ?

Dois-je paramétrer le NAS en Server ET en Client ?

Si le NAS est en Server, dois-je configurer un VPN sur mon ordi ou smartphone pour m'y connecter ?

En gros je suis vraiment perdu dans les réglages :cry:

Mes besoins : 1, pouvoir me connecter au net avec chaque appareil en secure vpn, 2, pouvoir me connecter au NAS avec ordi et android en secure vpn (si le 1 ne le fait déja pas)

HELP merci :cry:
Nas : Qnap TS-251+ 4.3.3

Chon
Padawan
Messages : 92
Enregistré le : 07 février 2018

Re: NAS TS251+ Configurer VPN ?

Message par Chon » 10 févr. 2019 16:13

Salut,

Si ton souhait est de mettre tout ton réseau derrière un VPN, c'est bien sur la box qu'il faut paramétrer le client VPN. Tous tes appareils se connectant au Net par la box (ethernet et wifi) seront derrière le VPN. Du coup, pas la peine de le faire sur le NAS.
En revanche, tes appareils nomades connectés hors réseau local (4G) ne seront pas derrière le VPN. Il faudra que chacun soit configuré indépendamment.
Si tu fais le paramétrage sur la box, tu perds l'utilisation de l'IP fixe de ta box (si tu en as une comme chez Free par exemple).
Si tu optes pour cette solution, tu ne pourras plus te connecter à ton NAS depuis l'extérieur via l'adresse IP officielle qui t'est octroyée par ton FAI.
Il faut alors passer par un DDNS pour s'affranchir de cette adresse IP. Et ça tombe bien QNAP dans sa très grande bonté t'en offre un via ton compte (si tu l'as déjà créé) "myqnapcloud.com". Tu pourras alors te connecter à ton NAS depuis partout dans le Monde avec ton adresse "<Le NAS de Plemo>.myqnapcloud.com".

Ensuite, si tu veux utiliser la partie VPN serveur de ton NAS, c'est avec cette même adresse "<Le NAS de Plemo>.myqnapcloud.com" qu'il faudra paramétrer QVPN partie serveur.

Si tu n'as pas encore de compte "myqnapcloud.com", c'est >>> ICI <<< que ça se passe. :wink:
QNAP TS-269L
SYNOLOGY DS-713+

plemo
Padawan
Messages : 106
Enregistré le : 21 septembre 2015
Professionnel : Non
Localisation : 78

Re: NAS TS251+ Configurer VPN ?

Message par plemo » 10 févr. 2019 16:34

Alors de toute façon ayant paramétré il y a quelques semaines le HTTPS sur le nas du coup je n'utilise plus l'adresse IP mais bien mon nom de domaine myqnapcloud.

Donc si je met la box en client vpn, les informations qui arriveront jusqu'au nas et dans mon Android (en wifi) seront sous le vpn ?

2 : mon nas est actuellement paramétré en vpn server. J'ai remarqué via mon pc que je ne peux pas m'y connecter à l'interface admin tant que je ne connecte pas openvpn . Normal ? ( Car du coup ça veut dire que je pourrai plus m'y connecter au travail ou d'un autre pc ... )

3 : si jamais je connecte le pc au nas via openvpn , il est ensuite impossible de connecter le pc au net via le soft vpn du fournisseur ...
Ce qui est un peu embêtant car ça veut dire que je ne peux pas aller sur le nas et sur le web en même temps .

Edit : je viens de lire qu'en mettant la box en client vpn, seules les données allant dans la box seraient sous vpn et donc pas celle allant vers le pc ou le nas ...

C'est tellement dur de s'y retrouver :(
Nas : Qnap TS-251+ 4.3.3

Chon
Padawan
Messages : 92
Enregistré le : 07 février 2018

Re: NAS TS251+ Configurer VPN ?

Message par Chon » 10 févr. 2019 19:03

plemo a écrit :
10 févr. 2019 16:34
Donc si je met la box en client vpn, les informations qui arriveront jusqu'au nas et dans mon Android (en wifi) seront sous le vpn ?
Oui comme tout ce qui est dans ton LAN (réseau local).
plemo a écrit :
10 févr. 2019 16:34
2 : mon nas est actuellement paramétré en vpn server. J'ai remarqué via mon pc que je ne peux pas m'y connecter à l'interface admin tant que je ne connecte pas openvpn . Normal ? ( Car du coup ça veut dire que je pourrai plus m'y connecter au travail ou d'un autre pc ... )
Non, pas normal. Rassure moi, ton NAS est bien en IP fixe d'une façon ou d'une autre dans ton LAN (sous la forme 192.168.X.X) ? Depuis ton PC, tu navigues bien dans le volume du NAS via l'explorateur de fichiers ? Tu vois bien le NAS dans la partie réseau de l'explorateur du PC ?
Quant à QTS (config du NAS), tu dois pouvoir y accéder avec "<Le NAS de Plemo>.myqnapcloud.com".
plemo a écrit :
10 févr. 2019 16:34
3 : si jamais je connecte le pc au nas via openvpn , il est ensuite impossible de connecter le pc au net via le soft vpn du fournisseur ...
Ce qui est un peu embêtant car ça veut dire que je ne peux pas aller sur le nas et sur le web en même temps .
Mais pourquoi veux-tu connecter ton PC au NAS via VPN ???? Ils sont bien tous les 2 dans ton LAN non ?
La fonction VPN Serveur est faite pour connecter aux données du NAS DEPUIS L'EXTÉRIEUR de ton réseau ! Vire OpenVPN de ton PC, ça ne sert à rien sinon à te connecter à un autre réseau ailleurs dans le Monde !
Maintenant, pour ton PC du boulot, si tu veux accéder à QTS, tu n'actives pas OpenVPN et tu utilises "<Le NAS de Plemo>.myqnapcloud.com".
Si tu veux accéder aux données qui sont sur le NAS, tu passes par OpenVPN.
plemo a écrit :
10 févr. 2019 16:34
Edit : je viens de lire qu'en mettant la box en client vpn, seules les données allant dans la box seraient sous vpn et donc pas celle allant vers le pc ou le nas ...
Mais, si c'est ta box qui est client VPN, TOUT CE QUI EST À L'INTÉRIEUR DE TON RÉSEAU EST DE FAIT SOUS VPN PUISQUE TOUT TON TRAFIC PASSE PAR L'UNIQUE TUYAU DE LA BOX !!!
QNAP TS-269L
SYNOLOGY DS-713+

plemo
Padawan
Messages : 106
Enregistré le : 21 septembre 2015
Professionnel : Non
Localisation : 78

Re: NAS TS251+ Configurer VPN ?

Message par plemo » 10 févr. 2019 20:59

Chon a écrit :
10 févr. 2019 19:03
plemo a écrit :
10 févr. 2019 16:34
Donc si je met la box en client vpn, les informations qui arriveront jusqu'au nas et dans mon Android (en wifi) seront sous le vpn ?
Oui comme tout ce qui est dans ton LAN (réseau local). ==> Bon OK
plemo a écrit :
10 févr. 2019 16:34
2 : mon nas est actuellement paramétré en vpn server. J'ai remarqué via mon pc que je ne peux pas m'y connecter à l'interface admin tant que je ne connecte pas openvpn . Normal ? ( Car du coup ça veut dire que je pourrai plus m'y connecter au travail ou d'un autre pc ... )
Non, pas normal. Rassure moi, ton NAS est bien en IP fixe d'une façon ou d'une autre dans ton LAN (sous la forme 192.168.X.X) ? Depuis ton PC, tu navigues bien dans le volume du NAS via l'explorateur de fichiers ? Tu vois bien le NAS dans la partie réseau de l'explorateur du PC ?
Quant à QTS (config du NAS), tu dois pouvoir y accéder avec "<Le NAS de Plemo>.myqnapcloud.com".

==> Oui Nas sous IP fixe. Oui accès via Explo Windows. Oui je vois le NAs dans le réseau. J'y accède en effet via mon domaine myqnapcloud SAUF QUE si le NAS est en VPN Server ( essai hier) cet accès ne fonctionne plus TANT QUE je ne me connecte par via OpenVPN sur le pc.
plemo a écrit :
10 févr. 2019 16:34
3 : si jamais je connecte le pc au nas via openvpn , il est ensuite impossible de connecter le pc au net via le soft vpn du fournisseur ...
Ce qui est un peu embêtant car ça veut dire que je ne peux pas aller sur le nas et sur le web en même temps .
Mais pourquoi veux-tu connecter ton PC au NAS via VPN ???? Ils sont bien tous les 2 dans ton LAN non ?
La fonction VPN Serveur est faite pour connecter aux données du NAS DEPUIS L'EXTÉRIEUR de ton réseau ! Vire OpenVPN de ton PC, ça ne sert à rien sinon à te connecter à un autre réseau ailleurs dans le Monde !
Maintenant, pour ton PC du boulot, si tu veux accéder à QTS, tu n'actives pas OpenVPN et tu utilises "<Le NAS de Plemo>.myqnapcloud.com".
Si tu veux accéder aux données qui sont sur le NAS, tu passes par OpenVPN.

==> je voulais simplement sécurisé au maximum mon trafic, oui ils bien sur le meme LAN.
Oui mais que je sois à la maison ou au travail, le lien domaine myqnapcloud est le meme ...
Mais du coup on en revient à la meme problématique, si VPN Server activé : connexion obligatoire par OpenVPN on est d'accord sur ça ?
Donc si oui, accès impossible au travail et accès impossible aux autres users qui n'ont pas OpenVPN ...
plemo a écrit :
10 févr. 2019 16:34
Edit : je viens de lire qu'en mettant la box en client vpn, seules les données allant dans la box seraient sous vpn et donc pas celle allant vers le pc ou le nas ...
Mais, si c'est ta box qui est client VPN, TOUT CE QUI EST À L'INTÉRIEUR DE TON RÉSEAU EST DE FAIT SOUS VPN PUISQUE TOUT TON TRAFIC PASSE PAR L'UNIQUE TUYAU DE LA BOX !!!
==> J'ai raisonné comme ça mais en cherchant je suis tombé sur une info qui disait le contraire .
Nas : Qnap TS-251+ 4.3.3

danaerys
Messages : 3
Enregistré le : 21 février 2019

Re: NAS TS251+ Configurer VPN ?

Message par danaerys » 25 févr. 2019 23:21

Bonjour à tous

J'ai également paramétré un client VPN sur mon TS251+, mais je ne parviens pas à forcer Download Station à l'utiliser
Tous les détails ci-dessous pour reproduire et constater le problème
Si quelqu'un a une idée pour me décoincer, je le remercie d'avance !


*** Config ***
NAS QNAP TS251+ 2x4TB RAID 1 et 4GB RAM
QTS 4.3.6.0805
DS 5.2.0
QVPN 2.0.588
bonding 2 interfaces physiques eth0 et eth1 sur 192.168.0.10
gateway par défault de mon reseau = box internet 192.168.0.1

*** situation de référence SANS passer par un VPN ***
- ouvrir QVPN, aller dans client VPN
- pas de profil client VPN défini
- config conforme à l'attendu :

Code : Tout sélectionner

	[~] # netstat -r
	Kernel IP routing table
	Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
	default         livebox.home    0.0.0.0         UG        0 0          0 bond0
	127.0.0.0       *               255.0.0.0       U         0 0          0 lo
	192.168.0.0     *               255.255.255.0   U         0 0          0 bond0
- aller sur page de test ipmagnet.services.cbcdn.com/ et copier le magnet
- lancer Donwload Station, ajouter l'URL du magnet
- sur la page de test que l'on rafraichit, c'est bien l'IPv6 <scrampbled2> du NAS qui apparait comme client torrent, la meme que celle indiquée par ifconfig

Code : Tout sélectionner

	[~] # ifconfig
	bond0     Link encap:Ethernet  HWaddr <scrambled1>
	          inet addr:192.168.0.10  Bcast:192.168.0.255  Mask:255.255.255.0
	          inet6 addr: <scrambled2>/64 Scope:Global
	          inet6 addr: <scrambled2>/64 Scope:Link
	          UP BROADCAST RUNNING MASTER MULTICAST  MTU:1500  Metric:1
	          RX packets:19980855 errors:0 dropped:1001737 overruns:0 frame:0
	          TX packets:17072435 errors:0 dropped:0 overruns:0 carrier:0
	          collisions:0 txqueuelen:0
	          RX bytes:20489540247 (19.0 GiB)  TX bytes:10092428657 (9.3 GiB)
..
- jusque la, rien que de très normal

*** situation non OK en voulant passer par mon VPN ***
- j'ai un VPN NordVPN, je suis les instructions dans https://nordvpn.com/fr/tutorials/qnap-nas/openvpn/
- dans QVPN, création d'un profil de client VPN a partir d'un fichier ovpn fourni par NordVPN
- je lance la connection au VPN
- je clique sur 'utiliser le vpn comme passerelle par défaut du système'
- ca donne ceci, qui m'a pas l'air hyper propre en fait (notamment reste la route par défaut sur ma box)

Code : Tout sélectionner

	[~] # netstat -r
	Kernel IP routing table
	Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
	default         10.7.7.1        0.0.0.0         UG        0 0          0 tun2001
	default         livebox.home    0.0.0.0         UG        0 0          0 bond0
	10.7.7.0        *               255.255.255.0   U         0 0          0 tun2001
	127.0.0.0       *               255.0.0.0       U         0 0          0 lo
	192.168.0.0     *               255.255.255.0   U         0 0          0 bond0
- je lance Download Station via "AppCenter" en veillant bien à choisir "connexion à > [mon profil client créé à l'instant]"
- je vais sur la page de test ipmagnet.services.cbcdn.com/ et je copie le magnet
- je vais dans DS et je lance le téléchargement du lien magnet
- sur la page de test, c'est à nouveau l'IPv6 de mon NAS qui apparait :-( alors que je m'attendais à voir l'IPv4 du serveur VPN par lequel je passe
- je m'arrache les cheveux depuis une semaine .. est-ce que le fait que le tunnel ne soit passerelle par défaut que pour les adresses en 10.7.7 expliquerait le pb ?
qu'est ce que j'ai loupé comme étape ?


Merci d'avance pour votre aide


[EDIT 28/2/19]

Apres beaucoup d'essais et de tatonnements, j'ai enfin trouvé le pb !
J'avais configuré l'aggrégation de mes 2 ports Eth, et visiblement DS (ou QVPN ?) n'aime pas trop ..
Dès que j'ai supprimé le teaming, mon trafic passe correctement par le tunnel et je suis visible avec l'IP terminale du vpn !!!
En particulier c'est vrai au niveau de DS, qui est vu par les peers avec l'IP du serveur VPN auquel je suis connecté, et non celle de mon NAS !

si ca peut aider qq un..

PS - bug QTS signalé au support
Modifié en dernier par danaerys le 28 févr. 2019 23:32, modifié 2 fois.

Répondre

Retourner vers « Installation, Démarrage, Configuration et Dépannage »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 4 invités