Forum des NAS

Tous les fabricants de NAS réunis sur un forum unique : Asustor, Qnap, Synology...

Download Center, File Explorer, iTunes Server, SoundsGood, Surveillance Center, UPnP Media Server...
Avatar de l’utilisateur
par chryslertvert
#93514
Bonjour,

Suite au ticket suivant: viewtopic.php?f=13&t=14209&p=93435#p93435
J'essaie d'utiliser debian via linux center. Problème: debian semble pas accéder à internet.

Explication:
Livebox orange avec DHCP statiques pour le nas et debain
Installation de debian 10 server via linux center > ok
Connexion en ssh à debian > ok
Update de debian ou installation de paquet > ko

Voici ce que cela donne:

Code : Tout sélectionner
admin@LXCDEBIAN10S:~$ sudo apt-get update
[sudo] password for admin: 
Err:1 http://deb.debian.org/debian buster InRelease                                                                             
  Cannot initiate the connection to prod.debian.map.fastly.net:80 (2a04:4e42:1d::204). - connect (101: Network is unreachable) Could not connect to prod.debian.map.fastly.net:80 (151.101.120.204), connection timed out Cannot initiate the connection to deb.debian.org:80 (2a04:4e42:1d::645). - connect (101: Network is unreachable) Could not connect to deb.debian.org:80 (151.101.122.133), connection timed out
Err:2 http://security.debian.org/debian-security buster/updates InRelease                                     
  Cannot initiate the connection to prod.debian.map.fastly.net:80 (2a04:4e42:1d::204). - connect (101: Network is unreachable) Could not connect to prod.debian.map.fastly.net:80 (151.101.120.204), connection timed out Cannot initiate the connection to security.debian.org:80 (2a04:4e42:c00::204). - connect (101: Network is unreachable) Cannot initiate the connection to security.debian.org:80 (2a04:4e42:800::204). - connect (101: Network is unreachable) Cannot initiate the connection to security.debian.org:80 (2a04:4e42:400::204). - connect (101: Network is unreachable) Cannot initiate the connection to security.debian.org:80 (2a04:4e42:e00::204). - connect (101: Network is unreachable) Cannot initiate the connection to security.debian.org:80 (2a04:4e42:600::204). - connect (101: Network is unreachable) Cannot initiate the connection to security.debian.org:80 (2a04:4e42:a00::204). - connect (101: Network is unreachable) Cannot initiate the connection to security.debian.org:80 (2a04:4e42::204). - connect (101: Network is unreachable) Cannot initiate the connection to security.debian.org:80 (2a04:4e42:200::204). - connect (101: Network is unreachable) Could not connect to security.debian.org:80 (151.101.64.204), connection timed out Could not connect to security.debian.org:80 (151.101.192.204), connection timed out Could not connect to security.debian.org:80 (151.101.0.204), connection timed out Could not connect to security.debian.org:80 (151.101.128.204), connection timed out
Reading package lists... Done                              
W: Failed to fetch http://deb.debian.org/debian/dists/buster/InRelease  Cannot initiate the connection to prod.debian.map.fastly.net:80 (2a04:4e42:1d::204). - connect (101: Network is unreachable) Could not connect to prod.debian.map.fastly.net:80 (151.101.120.204), connection timed out Cannot initiate the connection to deb.debian.org:80 (2a04:4e42:1d::645). - connect (101: Network is unreachable) Could not connect to deb.debian.org:80 (151.101.122.133), connection timed out
W: Failed to fetch http://security.debian.org/debian-security/dists/buster/updates/InRelease  Cannot initiate the connection to prod.debian.map.fastly.net:80 (2a04:4e42:1d::204). - connect (101: Network is unreachable) Could not connect to prod.debian.map.fastly.net:80 (151.101.120.204), connection timed out Cannot initiate the connection to security.debian.org:80 (2a04:4e42:c00::204). - connect (101: Network is unreachable) Cannot initiate the connection to security.debian.org:80 (2a04:4e42:800::204). - connect (101: Network is unreachable) Cannot initiate the connection to security.debian.org:80 (2a04:4e42:400::204). - connect (101: Network is unreachable) Cannot initiate the connection to security.debian.org:80 (2a04:4e42:e00::204). - connect (101: Network is unreachable) Cannot initiate the connection to security.debian.org:80 (2a04:4e42:600::204). - connect (101: Network is unreachable) Cannot initiate the connection to security.debian.org:80 (2a04:4e42:a00::204). - connect (101: Network is unreachable) Cannot initiate the connection to security.debian.org:80 (2a04:4e42::204). - connect (101: Network is unreachable) Cannot initiate the connection to security.debian.org:80 (2a04:4e42:200::204). - connect (101: Network is unreachable) Could not connect to security.debian.org:80 (151.101.64.204), connection timed out Could not connect to security.debian.org:80 (151.101.192.204), connection timed out Could not connect to security.debian.org:80 (151.101.0.204), connection timed out Could not connect to security.debian.org:80 (151.101.128.204), connection timed out
W: Some index files failed to download. They have been ignored, or old ones used instead.

Toutes les idées sont les bienvenues...
Par avance merci.

Bonne journée,
jB

#93550
Le réseau, c'est déterministe. Il y a des paquets, des adresses sources, et des destinations. Faire clic clic j'essaie se révèle hélas extrêmement contre productif .

Si j'ai bien compris, tu envisages de déployer un conteneur linux pour y utiliser un système Debian 10 via le mécanisme de déploiement de conteneurs d'ASUS.

On voit que apt tente de parler à prod.debian.map.fastly.net:80sur l'IP v6 2a04:4e42:1d::204, et que, manifestement, ça ne route pas.

Commence par plutôt lancer une commande

Code : Tout sélectionner
ip -c addr show

sur ta console Debian, et montre nous.

Avatar de l’utilisateur
par webmail
#93563
déjà ça serait bien de voir si tu ping
essayes un

Code : Tout sélectionner
ping 8.8.8.8

mais je pense que ton interface réseau est down (non activée)

ensuite pour info, apt-get n'est plus nécéssaire, un

Code : Tout sélectionner
apt update

suffit tu peux oublier le -get ;)

Avatar de l’utilisateur
par chryslertvert
#93621
Merci @webmail et @gnubyte pour vos réponses et votre intéret.

Voici les retour des commands:

Code : Tout sélectionner
admin@LXCDEBIAN10S:~$ ip -c addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
15: eth1@if16: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether b2:f4:a5:06:56:eb brd ff:ff:ff:ff:ff:ff link-netnsid 0
    inet 10.172.5.2/24 brd 10.172.5.255 scope global eth1
       valid_lft forever preferred_lft forever
    inet6 fe80::b0f4:a5ff:fe06:56eb/64 scope link 
       valid_lft forever preferred_lft forever
17: eth0@if18: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether be:5d:af:96:35:0a brd ff:ff:ff:ff:ff:ff link-netnsid 0
    inet 192.168.1.32/24 brd 192.168.1.255 scope global dynamic eth0
       valid_lft 81893sec preferred_lft 81893sec
    inet6 fe80::bc5d:afff:fe96:350a/64 scope link 
       valid_lft forever preferred_lft forever
Code : Tout sélectionner
admin@LXCDEBIAN10S:~$ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=116 time=3.15 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=116 time=3.43 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=116 time=3.03 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=116 time=2.75 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=116 time=2.84 ms
^C
--- 8.8.8.8 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 8ms
rtt min/avg/max/mdev = 2.754/3.039/3.433/0.247 ms

En fait, la connexion fonctionne avec ces commandes:

Code : Tout sélectionner
sudo /sbin/route delete default gw 10.172.5.1 dev eth1
sudo /sbin/route add default gw 192.168.1.1 dev eth0

>> https://forum.asustor.com/viewtopic.php ... 536#p36536

Malheureusement la modification saute au redémarrage, ce qui est assez fréquent...

Ps: merci pour -get ;)

Avatar de l’utilisateur
par chryslertvert
#93645
@webmail, bonne question.
Le nas est classique.
Quant à l'installation de debian, je suis passé par linux center de l'app central rien toucher d'autre niveau config.
Pour répondre, je ne sais pas. Mais c'est peut-etre une bonne piste.
Avatar de l’utilisateur
par chryslertvert
#93664
J'ai noté que le problème avait été évoqué dans un autre ticket pour info:
viewtopic.php?f=54&t=10596&sid=2c37088a ... 5d8eda7a1a

Je ne suis donc pas le seul :whistle:
NAS pour archives et PiHole

Effectivement, Je confond les modèles, le […]

Bonjour, Je remarque depuis quelque temps que le […]

Bonjour, Je reviens à la pèche aux i[…]

Bonjour à tous

Bienvenue hughs et merci pour ta présentati[…]

Site hébergé sur un serveur IKOULA

Ikoula