Forum des NAS

Tous les fabricants de NAS réunis sur un forum unique : Asustor, Qnap, Synology...

Discussion sur le paramétrage du NAS
Avatar de l’utilisateur
par Loic.L
#86979
Bonjour à tous,

Je tente de modifier les fichiers @default et @default-ssl dans /volume0/usr/builtin/etc/apache2/sites-enabled afin de pointer directement sur le bon repertoire pour un DNS.
Mais a chaque redémarrage d'Apache il me remet les fichiers par défaut... et je perds la config :-(
Une idée pour résoudre ce problème ?
Merci.

Loic
Avatar de l’utilisateur
par Loic.L
#87215
Dami1 a écrit : 02 mars 2020 11:27 Dans Services/Serveur web/Hôte virtuel tu as renseigné quoi ?

Bonsoir,

En fait seule l'utilisation de Services/Serveur web/Hôte virtuel permet de créer des VH uniquement pour les applis web installées dans les www des users.
Quand on installe une appli par AppCentral il n'y a pas d'option pour gérer le VH (et c'est bien dommage !)
Du coup je créé via Services/Serveur web/Hôte virtuel un VH bidon que je modifie ensuite dans /volume0/usr/builtin/etc/apache2/sites-enabled pour le faire pointer dans /volume1/Web/XXX
Cependant, dès création d'un nouveau VH via Services/Serveur web/Hôte virtuel, les VH dans sites-enabled sont réinitialisés... et ça m'oblige à ré-uploader le bon fichier VH.

Euh... je ne sais pas si je suis très clair !
Merci de votre aide.

Loic

Avatar de l’utilisateur
par Dami1
#87733
voici la réponse qui m'a été apportée

"Hi Damien,

To avoid confuse and conflict of VirtualHost, we can only allow users to add/edit it from Services / Web server / Virtual host GUI,
I'm not sure why this user create VH here, and then he want to change the folder by editing the config file in / volume0 / usr / builtin / etc / apache2 / sites-enabled ?

He can edit to change to another path in that GUI.

Please let the user to describe what he wants which he cannot do it via Services / Web server / Virtual host GUI.

Thanks a lot."
Avatar de l’utilisateur
par Loic.L
#89513
Bonjour,

Merci Damien. Je reprends le fil ayant un peu de temps en ce moment pour retenter de régler le problème... (comme beaucoup !)

J'ai acheté un nom de domaine, par exemple "machin.net"
Je souhaite faire plusieurs sites web accessible par des sous-domaines.

Le 1er est dans /share/User Homes/User1/www/Site1. Je créé par l'interface du NAS, un hôte virtuel : site1.machin.net. Une fois bien paramétré chez le registar, le site1.machin.net est bien accessible par internet et arrive sans problème sur /share/User Homes/User1/www/Site1.

Pour le second site, j'installe phpbb par App-central. Une fois installé, comment y accéder de l'internet par phpbb.machin.net ???
C'est sur cela que je bute depuis plusieurs semaines !

Merci.
Loïc
Avatar de l’utilisateur
par Dami1
#89994
salut Loic

le problème majeur est de s'assurer que "phpbb.machin.net" soit correctement mappé au port NAS WAN IP + du serveur Web.

Si ok, tu peux configurer ce domaine dans Services Web/Virtualhost d'ADM.

Installe phpbb et assure-toi qu'il peut être lancé en LAN. (via l'icône de l'application de bureau ADM)
Ajoute un nouveau VirtualHost avec le nom d'hôte qui peut être mappé pour corriger l'IP WAN et parcoure le dossier
pour sélectionner /Web/phpbb (le dossier installé phpbb.)

Après cela, cela devrait bien fonctionner.

Damien

Why we need Proxy Port if no proxy server is confi[…]

Je ne suis pas sûr d'avoir tout compris... m[…]

Presentation de Web83

Je t'en prie... et tu verras, il y a de nombreux[…]

Achat NAS

Hello, Pour le NAS, inutile d'en prendre un avec […]

Site hébergé sur un serveur IKOULA

Ikoula