Asustor ssl // redirection // Unable to connect

chryslertvert

Chevalier Jedi
21 Juillet 2014
206
0
16
Bonjour,

J'ai quelques posts auxquels il faut que je réponde consciencieusement... Mais là il y a urgence.

Je souhaitais utiliser un certificat let's encrypt pour owncloud...
Génération du certificat sans souci. Je préfère forcer la redirection du http vers le https (il me semble à postériori que certaine applications asustor ne fonctionne pas en https, non?): je coche la case adéquat...

Patatra.

Je n'arrive plus à accéder à l'interphace ADM:
https://192.xxx.x.xx >> Message de félicitation, j'accède au serveur web
https://192.xxx.x.xx:yyyy >> Quand je suis l'url que j'utilisais avant IP + Port, j'ai un message d'erreur: Unable to connect

Par contre pour mon nom de domain owncloud:
https://owncloud.mondomaine.com >> j'arrive sur le message de felicitation du serveur web
http://owncloud.mondomaine.com >> ok mais as de redirection

Bref, c'est la cata vu que rien n'est en place.

L'appli android AiMaster ne se connecte plus.
Connection en ssh opérationnelle. Est-ce que je peux l'utiliser pour décoché manuellement la case fautive (redirection ssl)?

Par avance merci pour l'aide.
Jean-baptiste
 
Bonjour,

J'ai finalement résolu la situation en me connectant en ssh.

Rassuré!

Dans le fichier:
Code:
/volume0/etc/nas.conf
J'ai modifié la propriété:
Code:
HttpsOnly = No
Puis redémarré manuellement le NAS.

Cela ne fait pas avancé l'utilisation de let's encrypt mais j'ouvrirai un ticket dédié pour cela.

Bonne journée,
jb
 
FX Cachem a dit:
C'est assez étrange...

Je confirme. J'ai refait le test : Cloud Connect fonctionne toujours si Let's Encrypt est activé et/ou si saisie d'un DDNS autre (ou complémentaire dans ADM). Les 2 peuvent fonctionner séparément ou simultanément.
Néanmoins, je ne trouve pas la page officielle qui dit que Owncloud supporte officiellement Let's Encrypt. Peut être que ça vient de là... ou pas :geek: Je lis toutefois que tu n'es pas le seul à avoir des soucis avec Owncloud + let's encrypt ... :?
https://community.letsencrypt.org/t/issue-creating-certificate-for-owncloud/7280
 
Hello,

Pour ton soucis de unable to connect il serait interessant de voir les logs de lighttpd(qui gere l'interface adm).

Pour ton domaine owncloud.mondomaine.com il te faut modifier la conf apache et ajouter dans le fichier default un redirect tel que :
<VirtualHost *:80>
ServerName owncloud.mondomaine.com
Redirect / https://tondomaine/owncloudenterprices/
</VirtualHost>

Et ajouter dans le default ssl :
<VirtualHost *:443>
ServerName owncloud.mondomaine.com
DocumentRoot "/tonvolume/Web/repertoireowncloud"
Ssl on
</virtualhost>

Restart apache dans :
/usr/builtin/etc/init.d/S54apache restart

Car on a pas la possibilité depuis l'interface web ce type de configuration apparement.
 
Si on souhaite déclarer un vhost sur le port 80 ou 443 via l'interface web celle ci nous indiquera un message d'érreur indiquant que le port est deja déclaré. C'est pour cela que dans un autre poste j'indiquai que la création des vhost ne prenaient pas comme argument un champ tel que "ServerName" qui permettrait l'utilisation d'un port deja déclaré mais filtrant sur un servername bien specifique.

En gros l'interface web ne nous permet pas le custom des vhost 80 et 443 et je suis sure que si on tentaient de déclaré un vhost 8088 puis on lui ajoute(niveau apache) un servername = toto.modomaine.com et ensuite créer un autre vhost sur le même port 8088 mais avec un servername = titi.mondomaine.fr on ne pourra meme realiser l'étape de création du vhost car on aura une erreur indiquant que le port 8088 est déjà déclaré alors que utiliser 2 vhost sur le port 8088 est tout a fait possible avec des values servername différentes.

Car pour l'interface web adm créer un vhost = nouveau fichier.conf alors que pas forcément.. :0

Je sais pas si j'ai réussi à me faire comprendre là :rolleyes: :lol: