Asustor [Résolu] Problème sur la génération de certificat

kris_bar

Nouveau membre
Bonjour à tous,

Je me lance pour mon premier post, je vais essayé d'être le plus complet possible ! Le pire c'est que ce sujet à été traité X fois et j'ai vraiment l'impression de rien comprendre..

Le contexte:
=> Nas acheté il y a 1 semaine environ.
=> Serveur Emby bien rempli (mais pas de WAN pour le moment).
=> Port http et https modifiés
=> ADM defender en place et configuré.
=> nom de domaine acheté chez ovh il y a 1 semaine. Mon adresse publique dynamique est configuré pour ce nom de domaine.
=> Le nas est sur une IP fixe de mon réseau local


Hier soir je me suis servi un whisky (c'est le moment ou le petit est au lit et madame lit un livre, dans ces cas là, tout va bien 😎!! ) et j'ai généré un premier certificat sans soucis mais pas avec le nom de domaine que je voulais (juste pour me familiariser)...
2023-01-17_13h15_11.png

J'me suis dis c'est bon j'suis un pro ! Pour fêter ca je me suis servi un autre whisky et j'ai récupéré un nom de domaine chez ovh pour faire la même chose et impossible de pouvoir récupérer le certificat via let's encrypt. L'erreur ci-dessous revient sans cesse..

2023-01-17_13h03_55.png

J'ai plusieurs pistes (que j'ai suivi mais aucune ne marche)..

Piste 1: Arrêter de boire (modérément bien évidemment). Je me suis vite aperçu que cela ne mènerai nulle part..
Piste 2: J'ai passé le firewall de ma box orange en mode (tout ouvert) le tps de refaire l'opération pour récupérer le certificats => Même erreur (visible sur la dernière image ci dessus)
Piste 3: J'ai essayé de passer le NAS sur une DMZ (c'est dans l'interface de gestion du firewall d'orange). Là aussi j'ai essayé et pas mieux niveau résultat..

Et du coup me voila !!
Si vous avez des idées à me soumettre je suis preneur car là je sèche....

Peace !!
 

Neo974

Grand Maître Jedi
Piste 1: Arrêter de boire (modérément bien évidemment). Je me suis vite aperçu que cela ne mènerai nulle part..
Je dirais juste qu'il faut partager.
Piste 2: J'ai passé le firewall de ma box orange en mode (tout ouvert) le tps de refaire l'opération pour récupérer le certificats => Même erreur (visible sur la dernière image ci dessus)
Piste 3: J'ai essayé de passer le NAS sur une DMZ (c'est dans l'interface de gestion du firewall d'orange). Là aussi j'ai essayé et pas mieux niveau résultat..
Il faudrait refermer le tout et annuler la mise du NAS en DMZ.
Il faudrait sur ton interface OVH renseigner la partie DDNS afin que ton nom de domaine pointe vers ton ip externe.
Puis rediriger le port 80 de ta box vers le port 80 de ton NAS
 

kris_bar

Nouveau membre
Il faudrait refermer le tout et annuler la mise du NAS en DMZ.
C'est fait et j'ai testé avec et sans DMZ.

Il faudrait sur ton interface OVH renseigner la partie DDNS afin que ton nom de domaine pointe vers ton ip externe.
C'est fait également (cf contexte)
=> nom de domaine acheté chez ovh il y a 1 semaine. Mon adresse publique dynamique est configuré pour ce nom de domaine.

Puis rediriger le port 80 de ta box vers le port 80 de ton NAS
J'espère que ce n'est pas une question stupide mais étant donné que j'ai changé les ports par defaut, je dois rediriger le ports 80 de ma box vers le port que j'ai modifié (pour le http) sur mon nas c'est bien ca ?
 

kris_bar

Nouveau membre
J'ai des doutes...
1673961538723.png
Pour la redirection je ne sais pas trop l'interprété, cela signifie:
=> Que tout ce qui arrive depuis l'extérieur sur le port 80 va être redirigé sur mon nas asustor sur le port 8080 (car j'ai changer les ports par défaut)
=> Que tout ce qui arrive depuis l'extérieur ET a destination du nas asustor va lui être renvoyé sur le port 8080 ?
 
Dernière édition:

EVOTk

Modérateur
Membre du personnel
Que tout ce qui arrive depuis l'extérieur sur le port 80 va être redirigé sur mon nas asustor sur le port 8080 (car j'ai changer les ports par défaut)
C'est cela
Si le port de ton nas n'est pas 8080 alors il faut modifier la redirection
 

nedrack

Padawan
HEllo, cela va dépendre d'un choix.... mets tu en place un reverse proxy; ou veux tu juste utiliser Emby à l'extérieur et pas d'autres apps.

Si c'est juste pour emby, sur ta box, il faut que tu déclares les ports que tu as mis pour le http et le https dans Emby ( par défaut, 8096 en http et 8920 en https).

Si tu passes via le reverse proxy; tu n'ouvres qu'un seul port sur ta box pour toutes tes apps ( par ex le 8909) et dans le reverse proxy, tu paramètres que le sous-domaine et/ou chemin type emby.tonsite.fr ou tonsite.fr/emby redirige vers ton ip:ton numéro de port dans emby
 

kris_bar

Nouveau membre
Ho Ho Ho Hé Hé Hé @nedrack !!
En fait c'était ma prochaine étape mais je pense que tu as raison il faut y penser maintenant ... J'avais pour objectif de passer par nginx. Actuellement je n'ai que Emby en projet... Mais le fait est que j'espère ajouter plusieurs applications derrières !
Et puis même.... Si il n'y a que Emby, par curiosité j'aimerais tester cela !!
Merci à tous pour vos remarques pertinentes !!

Au fait j'ai résolu mon soucis... en fait le port sur lequel je m'entêté au début n'était pas le bon :) Mauvaise compréhension de ma part même si le sujet à été évoqué mainte et mainte fois !!!
#bouletunjour_boulettoujours (et vous avez pas fini de me voit :LOL:)
 
Haut Bas