[ QPydio ] [ 8.0.2 ] Professional Private Cloud

QoolBox

Grand Maître Jedi
PydioLogo250.png

Source : https://pyd.io/

Download :

http://www.positiv-it.fr/QNAP/APP/Qpydio_6.2.2.qpkg.zip [ Universel ]
http://www.positiv-it.fr/QNAP/APP/Qpydio_6.4.0.qpkg.zip [ Universel ]
http://www.positiv-it.fr/QNAP/APP/Qpydio_6.4.1.qpkg.zip [ Universel ]
http://www.positiv-it.fr/QNAP/APP/Qpydio_6.4.2.qpkg.zip [ Universel ]
http://www.positiv-it.fr/QNAP/APP/Qpydio_7.0.2.qpkg.zip [ Universel ]
http://www.positiv-it.fr/QNAP/APP/Qpydio_8.0.2.qpkg.zip [ Universel ]


A propos :

Anciennement appelé Ajaxplorer, Pydio vous permet de construire votre cloud personnel de manière professionnelle, concurrent direct de OwnCloud.

Pydio est une plateforme de partage de fichiers Open source destinée aux entreprises, dotée d’applications Web et mobiles simples et épurées, hébergée de façon totalement sécurisée sur vos serveurs et clouds privés. Aussi facile d’utilisation qu'un logiciel grand public, Pydio est conçu pour offrir une sécurité et un contrôle de classe professionnelle.

Incroyablement facile à installer pour les administrateurs systèmes, Pydio se connecte instantanément aux dossiers existants de vos employés et à vos espaces de stockage en place, sans aucune migration nécessaire.

La plateforme est totalement gratuite pour la Communauté ; une édition Entreprise offre un support professionnel, une personnalisation (logos, couleurs, marque blanche) et un déploiement BYOD ultrasimple sur les terminaux mobiles.

pydio.png
 

peyton

Padawan
Le QNAP me dit que l'appli n'est pas compatible avec le https..Bref je l'exécute, le Pydio diag tool me demande l'encryption SSL ce que je force dans le fichier de conf. Je relance et mon navigateur internet n'ouvre plus rien, erreur ssl. Je pense à un probleme de certificat. Des idées ? :|

Ps : J'ai un TS 231
 

QoolBox

Grand Maître Jedi
il y a pas d’authentification SSL dispo pour le moment, sinon génère tes certificats et modifie les fichiers Apache.conf et le fichier conf SSL de l'application.

;)
 

giopas

Grand Maître Jedi
Pour info, à première vue il paraît que le paquet ne survie pas à l'update à 4.2 Beta Preview. Au moins, il ne s'ouvre plus.

Le paquet se réinstalle bien dessus, mais si je vais sur http://10.0.0.1:15333 je reçois un erreur.

Il pourrait que c'est juste un problème de networking, mais je voulais entre temps le reporter.

giopas
 

QoolBox

Grand Maître Jedi
il faut que je prenne le temps de regarder

ils ont peut être changer quelques chose dans la config apache
 

QoolBox

Grand Maître Jedi
arrrrrrrrg

ils ont virés la lib php

maintenant php tourne avec php-fpm
Code:
 9309 admin      7600 S   php-fpm: master process (/etc/default_config/php-fpm-sys-proxy.conf)
 9310 admin      6980 S   php-fpm: pool www
 9311 admin      6980 S   php-fpm: pool www
25621 admin      7604 S   php-fpm: master process (/etc/default_config/php-fpm.conf)
25622 httpdusr   7360 S   php-fpm: pool www
25623 httpdusr   7360 S   php-fpm: pool www

ça me faire un taf de fou !!!

je sens que je vais tout basculer sous QApache comme dépendance
 

giopas

Grand Maître Jedi
Ouch!!! :eek: cela veut dire qu'il faudrait avoir deux instances Apache (avec Qapache aussi) installé? Ouf, pas très "ecolo" comme solution malheureusement...

À ce point, il vaut mieux que tu fasse le test avec la nouvelle version de bug fix qui vient de sortir:

https://pyd.io/pydio-core-6-0-8/

Merci pour ton support!!!

giopas
 

QoolBox

Grand Maître Jedi
Je vais regarder comment fonctionne le PHP-FPM c'est du fast-cgi... suis encore novice la dedans
 

giopas

Grand Maître Jedi
Code:
Tu mérite vraiment toutes les bières que tu bois :-)

Merci Stéphane ! Demain je te dis comment ça va (est-ce que je peux l'installer sur l'ancienne version, même avec 4.2?)

des bières j'aimerai bien en avoir dans mon frigo en ce moment avec cette canicule, au moin 50° dans mon bureau chez moi sous les combles... pffff

normalement la migration devrait passer... je n'ai pas testé perso

juste modifié les fichiers de config d'apache et chmoder en 775 le répertoire de QPydio (php-fpm ne tourne pas avec le compte admin)
 

giopas

Grand Maître Jedi
Salut Stéphane,

J'ai fait l'upgrade à la version 6.0.8_42 mais j'ai les problèmes suivants:

apache: Syntax error on line 15 of /share/CACHEDEV1_DATA/.qpkg/QPydio/apache.conf: Cannot load /usr/local/apache/modules/libphp5.so into server: /usr/local/apache/modules/libphp5.so: cannot open shared object file: No such file or directory

Nonobstant cela le qpkg arrive à s'installer correctement:

[App Center] Qpydio 6.0.8 installation succeded.
[App Center] QPydio enabled.

Pourtant si je vais sur http://xxx.qnapcloud.com:15333 j'ai le problème suivant:

This XML file does not appear to have any style information associated with it. The document tree is shown below.

<tree>
<message type="ERROR">
Repositories file (/data/plugins/conf.serial/repo.ser) exists but is not writeable!
</message>
</tree>

C'est surtout le deuxième problème qui bloque je pense...
 
Haut Bas