[ QJDK8 ] [ 1.8.241.1 ] Java Development Kit (dépendance)

QoolBox

Grand Maître Jedi
Dépendance JDK8 pour les applications nécessitant JAVA.

JDK+7+Release%2528techniciablog.blogspot.com%2529.jpg



Download QJDK8: x86, x64, arm64, x31, x41

https://qnapclub.eu/fr/qpkg/195

A propos :

module passif, les développeurs doivent exporter JAVA_HOME dans /op/QJDK8
 

sun_left

Nouveau membre
Hi QoolBox

Is there a QJDK for TS-221?

I guess TS-221 need arm-x19 version, because I can install QGit_2.8.1_arm-x19.qpkg.
 

QoolBox

Grand Maître Jedi
hard to find binaries for armv5

not sure it is possible, and a bit dangerous use java application on such server... Java like to eat your NAS memories :geek:
 

sun_left

Nouveau membre
QoolBox a dit:
hard to find binaries for armv5

not sure it is possible, and a bit dangerous use java application on such server... Java like to eat your NAS memories :geek:

Hi QoolBox

Thanks for reply!

If you find the qpkg, please tell me.

thanks a lot!
 

Moogle Stiltzkin

Nouveau membre
most likely need a newer 64bit version of JRE.

why not try QJDK8? from QNAP Stephane?

"JDK is a superset of JRE, and contains everything that is in JRE, plus tools such as the compilers and debuggers necessary for developing applets and applications. JRE provides the libraries, the Java Virtual Machine (JVM), and other components to run applets and applications written in the Java programming language"

https://www.forum-nas.fr/viewtopic.php?f=21&t=1595


does this mean it's better than JRE ? o_O


I tried uninstall JRE and use JDK8 instead, but qsirch no longer works, as it uses JRE as a dependency :?
 

QoolBox

Grand Maître Jedi
JDK8 is embedding JRE (look inside the directory) /opt/QJDK8

JDK is fully dev environnement, and has many more library than based JRE required by many application
 

PekeQNP

Nouveau membre
giopas a dit:
Are you sure it is a problem related to QJDK? What system version are you running? What Qmono version?
Sorry, for lack of Information. Let me rectify.
- TS-459 Pro II 3GB Ram x86
- Firmware 4.2.2.20161028 Scheduled update to 4.2.2.20161208 this weekend
- QJDK8 1.8.111 (disabled/stopped) and http://download.qnap.com/QPKG/JRE_8.65.0-0225_x86.zip maintainer: Optimus (Enabled and Active)
- QMONO 4.2.1.0 as found Sonarr is most stable with that version also tried v4.4.2 and 4.6.x but was unstable

For test purposes I've done:
- Disabling JRE and enabling QJDK8 1.8.111 where Sonarr do not start
- Uninstall JRE and enabling QJDK8 1.8.111 Sonarr do not start and complain no JRE on install
- Uninstall QJDK8 1.8.111 and installing JRE Sonarr works
- Installing and disabling QJDK8 1.8.111 while JRE installed and active Sonarr Works (My Current settings)

Note I have full access to ".QPKG" folder (Using ln -s) and add-on source files if needed.

giopas a dit:
Pour info, dans le repo de qnapclub il y a encore la version 101 au lieu de 111. Au moins en regardant par QTS.
Version I have installed is http://www.qnapclub.eu/provider.php/qpkg_dwl/99372/QJDK8_1.8.111_x86.qpkg from http://store.qnapclub.eu/store.php repo
 

giopas

Grand Maître Jedi
Encore une fois, il parait qu'il y a un problème avec les paquet téléchargé par le repository.

En effet j'ai téléchargé QJDK8 1.8.111 par qnapclub.eu (à travers QTS 4.3 beta) et KeyBox (duquel il dépend) ne marchait pas. J'ai donc téléchargé le paquet (en utilisant Download Station, donc même connection) à partir de ce site et KeyBox marche.
 

ftual

Nouveau membre
L'installation du QJDK 1.8.71 s'est correctement effectuée et est démarré. Mais impossible d'executer une comme java -jar ... Avez vous une explication ?
Merci
 
Haut Bas